Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при выводе изображения.

Ошибка при выводе изображения.
Я
   progaoff
 
25.06.19 - 13:01
Добрый день. Подскажите  пожалуйста с чем может быть связанно, вывожу фото в макет, на этом моменте сыпит Значение не является значением объектного типа (ПолучитьДвоичныеДанные)

СекцияИзображение.Параметры.Изображение = Новый Картинка(Фото.ПолучитьДвоичныеДанные(),Истина);
 
 
   DrWatson
 
1 - 25.06.19 - 13:05
(0) Нужно присмотреться к переменной Фото. Вероятно, это не двоичные данные, а какой-то другой тип.
   progaoff
 
2 - 25.06.19 - 13:05
(1) Двоичные, смотрел в отладке
   Cyberhawk
 
3 - 25.06.19 - 13:05
Там Неопределено
   Cyberhawk
 
4 - 25.06.19 - 13:06
(2) Что-то ты 3.14здишь. У ДД нет такого метода.
   progaoff
 
5 - 25.06.19 - 13:10
(3) Да, в одной карточке нет фото
   progaoff
 
6 - 25.06.19 - 13:10
Блин, а в макет просто в параметр слово "Фото" вылазиет все равно
   progaoff
 
7 - 25.06.19 - 13:21
Как эти фотки на макет вывести, подскажите.
   Cyberhawk
 
8 - 25.06.19 - 13:22
Вид ячейки "Параметр" должен быть а не "Текст"
   progaoff
 
9 - 25.06.19 - 13:23
(8) я конечно туплю) но там параметр не текст
   Cyberhawk
 
10 - 25.06.19 - 13:24
Рабы не мы, мы не рабы, ага
   progaoff
 
11 - 25.06.19 - 13:26
(10) Блин ну серьезно)
   SleepyHead
 
12 - 25.06.19 - 13:34
Проверяй тип, что хранится в переменной Фото? Помнится. три года назад делал для клиента вывод фотографии в служебное удостоверение. И тоже была подобная ошибка.

Выяснил, что до какого-то момента в регистре хранился один тип, потом начали другой хранить. проверка типа перед выводом решила проблему:

мФотография = Запись.Фотография.Получить();
Если ТипЗнч(мФотография)=Тип("Картинка") Тогда
   Обл.Рисунки.D1.Картинка =  мФотография;
Иначе
  Обл.Рисунки.D1.Картинка =  Новый Картинка(мФотография);
КонецЕсли;
   progaoff
 
13 - 25.06.19 - 13:40
(12) Значение не является значением объектного типа (D1)
   progaoff
 
14 - 25.06.19 - 13:41
(13) D1 это пустая картинка на макете
   SleepyHead
 
15 - 25.06.19 - 13:42
(13) рукалицо, ну это же пример МОЕГО кода. Подгоняйте под ваш.
   SleepyHead
 
16 - 25.06.19 - 13:43
И начните с того, что вам в еще в (1) ответили, разберитесь, что у вас в переменной Фото.
   progaoff
 
17 - 25.06.19 - 13:46
(16) Фото это картинка
   SleepyHead
 
18 - 25.06.19 - 13:48
(17)

СекцияИзображение.Параметры.Изображение = Новый Фото;

Ну, а так работает?
   SleepyHead
 
19 - 25.06.19 - 13:49
Слово Новый только там лишнее

СекцияИзображение.Параметры.Изображение = Фото;
   progaoff
 
20 - 25.06.19 - 13:51
Если ТипЗнч(ЗначениеГруппировки) = Тип("СправочникСсылка.Номенклатура") И Не ЗначениеГруппировки.ЭтоГруппа Тогда
            Фото = Выборка.Хранилище.Хранилище.Получить();
            Если Фото = Неопределено Тогда
                Продолжить
            Иначе
            СекцияИзображение.Параметры.Изображение = Новый Картинка(Фото.ПолучитьДвоичныеДанные(),Истина);
            КонецЕсли;
        КонецЕсли; (19)
   progaoff
 
21 - 25.06.19 - 13:51
Вот не пойму, в параметре макета вместо фотки выводит просто слово "фото"
   SleepyHead
 
22 - 25.06.19 - 13:52
(21) издевается, вот почему.
   progaoff
 
23 - 25.06.19 - 14:00
(22) в скд на раз  отрабатывает.
   FFIL0S0FF
 
24 - 25.06.19 - 14:06
Я вот пару дней такую же тему заводил))

Не нужно выводить на макет параметр.

Выведи на макет рисунок и ему уже присваивай значение

Вот пример:

ФаксимилеХранилище=ПолучитьФаксимиле(Выборка.ФизическоеЛицо,ПараметрыДокумента.Дата);
Факсимиле = Новый Картинка(ФаксимилеХранилище.Получить());

///////////////////////////

ОбластьМакета.Рисунки.D2.Картинка=ПараметрыОрганизации.ПредсФакс;
ОбластьМакета.Рисунки.D5.Картинка=ПараметрыОрганизации.ПредсФакс;
ОбластьМакета.Рисунки.D3.Картинка=ПараметрыОрганизации.ПредсФакс;
ОбластьМакета.Рисунки.D4.Картинка=ПараметрыОрганизации.ПредсФакс;


ОбластьМакета.Рисунки.D6.Картинка=ПараметрыОрганизации.Член1Факс;
ОбластьМакета.Рисунки.D7.Картинка=ПараметрыОрганизации.Член2Факс;


Как то так
   FFIL0S0FF
 
25 - 25.06.19 - 14:08
В типовой бухе есть документ "Счет на оплату" посмотри как там печать и подпись выводят.
Через параметр выводить не вариант.
   progaoff
 
26 - 25.06.19 - 14:34
свершилось мля


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.