Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Штрих-м драйвер для работы с ФФД с 01.07.2019 (ИНН и Наименование Покупателя)

Штрих-м драйвер для работы с ФФД с 01.07.2019 (ИНН и Наименование Покупателя)
Я
   jq
 
24.06.19 - 15:37
Добрый день, подскажите пожалуйста или помогите структурировать информацию по Штрих-М... От самого штриха информации почти ноль...

Имеются две конфигурации УТ11 типовая последней версии и 1С7.7 доработанная, Штрих-М ФР 01Ф, прошивка от 24.10.2018, обновлялась для перехода на НДС 20%, лицензия приобретена на 2019 год. Версия драйвера 4.14.747 (на сайте штриха написано, что данная версия сертифицирована 1С по ФФД 1.05). Также на сайте сейчас выложена новая версия 4.14.772 (ФФД от 01.07.2019).

В интернете нашел на форуме Штрих-м, что уже в прошивке от 24.09.2018 добавлена возможность передать в состав чека теги 1227, 1228, и в состав операции теги 1229, 1230, 1231.
Теперь с 01.07.2019 интересует печать и передача в ОФД данных: ИНН покупателя (1227) и Наименование покупателя (1228), а также Код страны (1230) и Номер ГТД (1231).

В итоге, что нужно для корректной работы с 01 июля? Я правильно понимаю, что:

1) нужно обновить драйвер ФР на самую последнюю версию? 4.14.772 (ФФД от 01.07.2019).

2) Прошивку обновлять не нужно? Т.к. она от 24.10.2018, а теги передаются с 24.09.2018

3) Для УТ11 - каким методом или свойством драйвера ФР передать указанные теги в УТ11? Или они уже передаются в автоматическом режиме для драйвера ФР в УТ11?

4) Для 7.7 - каким методом или свойством драйвера ФР передать указанные теги в 1С7.7? Например, суммы передаются через ОбъектФР.Summ1, Summ2,... Налоги через свойство Tax1, Таx2 и т.п.
А как передать значение тегов 1227, 1228, 1230, 1231?
 
 
   NikeArz
 
1 - 24.06.19 - 16:02
(0) Это для 1С77            
                        Объект.Пароль = Пароль;  
            Объект.НомерТега = 1227;    //TagNumber

            Объект.ТипТега = 7;            //TagType

            Объект.ЗначениеТегаСтрока = "НаименованиеПокупателя";  //TagValueStr    

            Объект.FNSendTag();// отправка тега

            Объект.СтрокаДляПечати = "";
            Если Объект.Результат <> 0 Тогда
                Результат = Объект.ОписаниеРезультата;
                Объект.АннулироватьЧек();
                Объект.РазорватьСвязь();
                Возврат Результат;
            КонецЕсли;
            Объект.НомерТега = 1228;    //TagNumber

            Объект.ТипТега = 7;            //TagType

            Объект.ЗначениеТегаСтрока = "ИННПокупателя";  //TagValueStr    

            Объект.FNSendTag();// отправка тега

            Объект.СтрокаДляПечати = "";
            Если Объект.Результат <> 0 Тогда
                Результат = Объект.ОписаниеРезультата;
                Объект.АннулироватьЧек();
                Объект.РазорватьСвязь();
                Возврат Результат;
            КонецЕсли;
   jq
 
2 - 24.06.19 - 16:05
Спасибо, а имена свойств никто не подскажет? Хотелось бы все таки в одну строчку передать значение, а не в 10 строк) Раньше в документации к драйверу были перечислены все имена свойств и методов драйвера, сейчас не могу найти нигде с последними изменениями...
   NikeArz
 
3 - 24.06.19 - 16:11
Одной строчкой не получится. У этих тегов я не нашел имен свойств.
   jq
 
4 - 24.06.19 - 16:13
Вот и я не нашел, но они точно есть, должны быть зашиты в драйвере...
   jq
 
5 - 24.06.19 - 16:17
Нашел вот что... здесь на форуме, а затем на итс

ффд 1.05 изменения 01.07.19


https://its.1c.ru/db/metod8dev#content:4829:hdoc:chapter270
   jq
 
6 - 24.06.19 - 16:17
Только не понятно для ФФД 1.05 будет работать или нет???
   jq
 
7 - 24.06.19 - 16:18
CustomerInfo, CustomerINN, CountryOfOrigin, CustomsDeclaration

Только не понятно для ФФД 1.05 будет работать или нет???
   jq
 
8 - 24.06.19 - 17:07
1) нужно обновить драйвер ФР на самую последнюю версию? 4.14.772 (ФФД от 01.07.2019).

2) Прошивку обновлять не нужно? Т.к. она от 24.10.2018, а теги передаются с 24.09.2018

3) Для УТ11 - каким методом или свойством драйвера ФР передать указанные теги в УТ11? Или они уже передаются в автоматическом режиме для драйвера ФР в УТ11?
   Hsals
 
9 - 26.06.19 - 16:54
Апну тему:

Пункты 1 и 2 - техподдержка Штриха сказала, да такой версии прошивки и такой версии драйвера хватит.

Пункт 3 - хз

Пункт 4 - я пробую передавать через XML, но на печати ни ИНН покупателя, ни наименования покупателя, ни номера ТД, ни кода страны пока не вижу. Делаю для 1с 7.7 ТиС. Ошибок при печати чека нет.
У кого-нибудь при передаче через xml получилось вывести эту инфу на чек?
   Hsals
 
10 - 27.06.19 - 09:40
Отвечу сам себе: помогла рекомендация товарища victuan1:

Тест драйвера, таблица 17:
поле 25 поменял с 0 на 1
Все сразу напечаталось. (само собой, в xml все это должно быть передано)
   jq
 
11 - 27.06.19 - 17:06
У меня не работает.

Передаю в обработке обслуживания ФР для Штрих-м в 7.7 ТиС, через
ОбъектДрайвераФР.CustomerInfo и ОбъектДрайвераФР.CustomerINN, по аналогии с ОбъектДрайвераФР.Summ1 и ОбъектДрайвераФР.Tax1,
флаг в таблице 17 поле 25 = 1, на чеке теги не печатаются...
   M0ok
 
12 - 28.06.19 - 15:18
(10) Подскажите пожалуйста, каким образом можно значение в этом поле изменить?
   Ray Zexter
 
13 - 28.06.19 - 15:31
(11) передавай по номеру тега
(12) Enter - новое значение - Enter
   M0ok
 
14 - 28.06.19 - 16:09
(13) Спасибо
   DimonZh
 
15 - 28.06.19 - 20:36
NikeArz, спасибо, с Покупателем все получилось,
а вот с тегами 1230, 1231 выдает ошибку - некорректные данные.
Код аналогичен приведенному примеру, находится в цикле по строкам чека перед Sale().
Может не правильно делаю?
   Samir
 
16 - 11.07.19 - 14:26
Объект.Пароль = Пароль;  
Объект.НомерТега = 1231;    //TagNumber

    
Объект.ТипТега = 7;            //TagType

                            
Объект.ЗначениеТегаСтрока = Строка(НомерГТД);  //TagValueStr    

                            
Объект.FNSendTagOperation();
   dovolos
 
17 - 24.07.19 - 17:09
(15) Получилось ли с 1230 и 1231? Ставил и до sale и после, выдает 51 и 94 ошибки. Если у кого-нибудь получилось, выложите пожалуйста пример, если можно с контекстом, чтобы было понятно в какой момент его отправлять. Спасибо!
   NikeArz
 
18 - 24.07.19 - 17:28
(17) Выкладываю куски кода:
        //Выполнение Операции

        Объект.FNOperation();//для ФФд 1.05

        
        Если Объект.Результат <> 0 Тогда
            Результат = Объект.ОписаниеРезультата;
            Объект.АннулироватьЧек();
            Объект.РазорватьСвязь();
            Возврат Результат;
        КонецЕсли;
        
        Если ПараметрыККТ.ФФД > 0 Тогда 
            
            //Отправка единицы предмета расчета ФФД 1.05 и 1.1 НЕ работает

            Если НЕ ПустаяСтрока(ЕдиницаИзмеренияПредметаРасчета) Тогда
                Объект.Пароль = Пароль;  
                Объект.НомерТега = 1197;    //TagNumber

                Объект.ТипТега = 7;            //TagType

                Объект.ЗначениеТегаСтрока = СокрЛП(ЕдиницаИзмеренияПредметаРасчета);  //TagValueStr    

                Объект.FNSendTagOperation();// отправка тега

                Объект.СтрокаДляПечати = "";
                Если Объект.Результат <> 0 Тогда
                    Результат = Объект.ОписаниеРезультата;
                    Объект.АннулироватьЧек();
                    Объект.РазорватьСвязь();
                    Возврат Результат;
                КонецЕсли;
            КонецЕсли;
            
            //Отправка код страны ФФД 1.05 и 1.1

            //Отправка ГТД ФФД 1.05 и 1.1

            Если ПараметрыККТ.ТипОперации = Перечисления.ТипыОперацийЧекККМ.ОплатаКредита
                ИЛИ ПараметрыККТ.ТипОперации = Перечисления.ТипыОперацийЧекККМ.ОплатаОтЮрЛица Тогда
                //И ПараметрыККТ.ЭтоЮридическоеЛицо

                Если НЕ ПустаяСтрока(Товар.КодСтраныПроисхожденияТовара) 
                    И СокрЛП(Товар.КодСтраныПроисхожденияТовара) <> "643" 
                    И НЕ ПустаяСтрока(Товар.НомерТаможеннойДекларации) Тогда
                    
                    Объект.Пароль = Пароль;  
                    Объект.НомерТега = 1230;    //TagNumber

                    Объект.ТипТега = 7;        //TagType

                    Объект.ЗначениеТегаСтрока = СокрЛП(Товар.КодСтраныПроисхожденияТовара);  //TagValueStr    

                    Объект.FNSendTagOperation();// отправка тега

                    Объект.СтрокаДляПечати = "";
                    Если Объект.Результат <> 0 Тогда
                        Результат = Объект.ОписаниеРезультата;
                        Объект.АннулироватьЧек();
                        Объект.РазорватьСвязь();
                        Возврат Результат;
                    КонецЕсли;
                    
                    Объект.Пароль = Пароль;  
                    Объект.НомерТега = 1231;    //TagNumber

                    Объект.ТипТега = 7;        //TagType

                    Объект.ЗначениеТегаСтрока = СокрЛП(Товар.НомерТаможеннойДекларации);  //TagValueStr    

                    Объект.FNSendTagOperation();// отправка тега

                    Объект.СтрокаДляПечати = "";
                    Если Объект.Результат <> 0 Тогда
                        Результат = Объект.ОписаниеРезультата;
                        Объект.АннулироватьЧек();
                        Объект.РазорватьСвязь();
                        Возврат Результат;
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;    
        
        //Отправка Кода Товарной Номенклатуры ФФД 1.05 и 1.1

        Если ПараметрыККТ.РазрешитьПередатьКТН Тогда//Отправка тега маркировки //Убрать как будет новая прошивка

            Если НЕ ЗначениеНеЗаполнено(Товар.ДанныеКодаТоварнойНоменклатуры.ГлобальныйИдентификаторТорговойЕдиницы) 
                И НЕ ЗначениеНеЗаполнено(Товар.ДанныеКодаТоварнойНоменклатуры.СерийныйНомер) 
                И Товар.ДанныеКодаТоварнойНоменклатуры.ТипМаркировки > 0 Тогда//Отправка тега маркировки

                Объект.Пароль = Пароль;  
                Объект.MarkingType         = Товар.ДанныеКодаТоварнойНоменклатуры.ТипМаркировки;    
                Объект.GTIN             = Товар.ДанныеКодаТоварнойНоменклатуры.ГлобальныйИдентификаторТорговойЕдиницы;
                Объект.SerialNumber     = Товар.ДанныеКодаТоварнойНоменклатуры.СерийныйНомер;
                Объект.FNSendItemCodeData();// отправка тега маркировки

                Объект.СтрокаДляПечати = "";
                Если Объект.Результат <> 0 Тогда
                    Результат = Объект.ОписаниеРезультата;
                    Объект.АннулироватьЧек();
                    Объект.РазорватьСвязь();
                    Возврат Результат;
                КонецЕсли;

Код не полный!!!!
Вы должны понять что все
Объект.FNSendTag()  и  Объект.FNSendTagOperation() выполняются только
после регистрации операции Объект.FNOperation(); с той разницей что Объект.FNSendTagOperation()
применяется в цикле и привязывается к товару, а Объект.FNSendTag() выполняется после цикла и привязывается к чеку.
   dovolos
 
19 - 24.07.19 - 18:58
(18) Николай спасибо! А Объект.FNOperation() выполняется до Sale() или после, или же Операция будет целиком фиксироваться FNSendTagOperation?
   NikeArz
 
20 - 25.07.19 - 09:26
(19)  Sale() не должно быть. Этот метод применялся при ФФД 1.0
   NikeArz
 
21 - 25.07.19 - 09:27
(19) Пришли e-Mail. Вышлю кусок полностью как идет печать чека.
   dovolos
 
22 - 25.07.19 - 12:58
(21) в аську написал


Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.