Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ПриЗаписи ошибка - Преобразование значения к типу Булево не может быть выполнено

ПриЗаписи ошибка - Преобразование значения к типу Булево не может быть выполнено
Я
   asn-sasha
 
24.06.19 - 15:14
Доброго времени суток, уважаемые эксперты!
Нужна ваша подсказка: ПриЗаписи делаю поиск по номенклатуре и если она есть тогда оповещение... Но почему то ошибка - Преобразование значения к типу Булево не может быть выполнено...
Думаю дело кавычки в кавычках у названия позиции номенклатуры... - CoaguChek XS 2x24 tests (en/fr/es/pt) (Тест-полоски "Коагучек ИксЭс PT тест", 2x24 шт.)


Процедура ПриЗаписи(Отказ)
    Если Справочники.Номенклатура.НайтиПоНаименованию ("CoaguChek XS 2x24 tests (en/fr/es/pt) (Тест-полоски ""Коагучек ИксЭс PT тест"", 2x24 шт.)") ИЛИ Справочники.Партнеры.НайтиПоНаименованию("Тест-полоски для коагулометра портативного ""Коагучек РТ тест"" 24 шт. (CoaguChek PT Test, 24 tests)")  Тогда
        Сообщить ("В заказе есть позиции, участвующие в акции 140/300/620.");
    КонецЕсли;
    
КонецПроцедуры
 
 
   Amra
 
1 - 24.06.19 - 15:17
НайтиПоНаименованию возврашает не булево. Продам СП, ДОРОГО
   asn-sasha
 
2 - 24.06.19 - 15:21
(1) подскажи пожалуйста! а я помолюсь за тебя!
   Жан Пердежон
 
3 - 24.06.19 - 15:22
Возвращаемое значение:

Тип: СправочникСсылка.<Имя справочника>; Неопределено.
Ссылка на найденный элемент справочника.
Если не существует ни одного элемента с требуемым наименованием, то будет возвращена пустая ссылка.
Если для справочника наименование не задано (длина = 0) и поиск выполняется по полному соответствию, то будет возвращено Неопределено.
   stix2010
 
4 - 24.06.19 - 15:22
неопределено  это не булево, читай СП
   asn-sasha
 
5 - 24.06.19 - 15:30
не могу понять что не так я делаю.... обьясните плс товарищи!

ищу позицию по наименованию, в модуле объекта ПриЗаписи...

Процедура ПриЗаписи(Отказ)
    Если Справочники.Номенклатура.НайтиПоКоду("УТ000006624") ИЛИ Справочники.Номенклатура.НайтиПоКоду("УТ000006621")  Тогда 
        Сообщить ("В заказе есть позиции, участвующие в акции 140/300/620.");
    КонецЕсли;
    
КонецПроцедуры
   CHerypga
 
6 - 24.06.19 - 15:34
Процедура ПриЗаписи(Отказ)
    Если Справочники.Номенклатура.НайтиПоКоду("УТ000006624") <> Справочники.Номенклатура.ПустаяСсылка() ИЛИ Справочники.Номенклатура.НайтиПоКоду("УТ000006621") <> Справочники.Номенклатура.ПустаяСсылка()  Тогда 
        Сообщить ("В заказе есть позиции, участвующие в акции 140/300/620.");
    КонецЕсли;
    
КонецПроцедуры

но вообще-то за такое надо бить, желательно ногами
   Жан Пердежон
 
7 - 24.06.19 - 15:34
(6) говнокод в любом случае
   singlych
 
8 - 24.06.19 - 15:36
(5) А ты находчивый.
- Почему не работает Если НайтиПоНаименованию Тогда?
- Потому что оно возвращает не булево.
- Спс, понял. Напишу Если НайтиПоКоду.
   CHerypga
 
9 - 24.06.19 - 15:37
(7) мало того, сейчас у ТС во всех заказах якобы будут позиции участвующие в акции
   asn-sasha
 
10 - 24.06.19 - 16:27
Помогли дай бог вам здоровья!
 
 Рекламное место пустует
   hhhh
 
11 - 24.06.19 - 17:00
(10) читай (9) до полного просветления.
   Ц_У
 
12 - 24.06.19 - 17:03
(10) НайтиПо[Коду,Наименованию ... и прочее] возвращает ссылку на элемент или пустую ссылку того же типа

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует