Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Оценка риска- код

Оценка риска- код
Я
   TumenJan
 
11.06.19 - 14:25
Все привет!
Как можно сделать:

https://yadi.sk/i/9Wnltp0SxjYxuA

Здесь нужно выбрать в столбце какой-нибудь элемент, потом в 2 столбце, и в третьем столбце а на выходе должен показать результат в ввиде уровня риска.

Подскажите, может есть у кого мысли
 
 
   RomaH
 
1 - 11.06.19 - 14:31
что сделать-то надо?
   RomaH
 
2 - 11.06.19 - 14:33
кто такой "а"?
где выход?
какой у "уровня риска" вид?
   MakaMaka
 
3 - 11.06.19 - 14:33
(0) Думаю сегодня вторник, 2019 год, пишу из России
ps Ленин, Тутанхамон, Вася.
Кто тоже?
   MakaMaka
 
4 - 11.06.19 - 14:34
Но я бы обвел 5-ку. Она мне нравитя
   TumenJan
 
5 - 11.06.19 - 14:37
Если на рисунок посмотреть, если допустим выбрать в первой колонке любое значение "Возможно", потом выбираешь во второй колонке, допустим "Редко", и в третьем выбираем допустим "Инвалидность" - Если все эти точки соединить получается уровень риска примерно между средним и низким.
))
   RomaH
 
6 - 11.06.19 - 14:37
(0) тебе это не надо
   TumenJan
 
7 - 11.06.19 - 14:37
Вот не понять как его сделать, т.е. нужно все сопастовлять
   RomaH
 
8 - 11.06.19 - 14:39
ГенераторСлучайныхЧисел
   KILL_OFF_COBECTb
 
9 - 11.06.19 - 14:39
Может быть имеется ввиду, что для каждого столбца из первых трех, каждому значению в них присвоить какой-то балл по шкале от 1 до 6
Потом просуммировать и разделить на 3. получим уровень риска в % соотношении, и в соответствии с последним столбцом получить значение риска
   RomaH
 
10 - 11.06.19 - 14:41
   KILL_OFF_COBECTb
 
11 - 11.06.19 - 14:43
пример:
"Вероятность" = Случалось прежде" = 4\6
"Подверженность" = "Еженедельно" = 3\6
"Результат" = "Смертельные случаи" = 6\6
Итог = 72% что соответствует Уровень риска = Высокий
   RomaH
 
12 - 11.06.19 - 14:44
Почти всегда - постоянно - смертельные = ????

Почти не возможно - Редко - Смертельные = ???


где логика?
   RomaH
 
13 - 11.06.19 - 14:45
Почти не возможно - постоянно - Смертельные = ???
   TumenJan
 
14 - 11.06.19 - 14:47
ну наверное такой вероятности не будет) (13)
   bootini
 
15 - 11.06.19 - 14:47
(0) А где там столбцы? На картинке? Что надо выбрать и что получить?
   KILL_OFF_COBECTb
 
16 - 11.06.19 - 14:48
(11) не заметил что в столбце подверженность - перевернут наоборот. редко = 1\6, а постоянно = 6\6 соответственно.
(13) (12) почему же нет логики, это просто теория вероятности, то что она здравому смыслу не поддается это отдельный вопрос))
   RomaH
 
17 - 11.06.19 - 14:48
(16) я не утверждал, что логики нет, - я спрашиваю - каков должен быть результат, и прошу объяснить почему
   TumenJan
 
18 - 11.06.19 - 14:49
(15) ну там не столбцы, а ввиде линии
   TumenJan
 
19 - 11.06.19 - 14:49
(16) ))
   mistеr
 
20 - 11.06.19 - 14:49
Формула! Где формула?! (С)
   TumenJan
 
21 - 11.06.19 - 14:51
какой блин написать код к этой теории вероятности, есть мысли)
   KILL_OFF_COBECTb
 
22 - 11.06.19 - 14:51
(21) есть, ща
   bootini
 
23 - 11.06.19 - 14:53
присвоить каждому значению весовой коэффициент, и в зависимости от суммы или произведения коэффициентов вычислять вероятность
   Lama12
 
24 - 11.06.19 - 14:53
(0) Для "Смертельный случай" возможно 36 вариантов построения связей. Где вес, или вероятность, или частота, какой ни будь числовой эквивалент каждой точки? Где границы уровней риска? Задача то примитивная, но компьютер может работать только с числовыми значениями. Где числа?
   bootini
 
25 - 11.06.19 - 14:54
   Lama12
 
26 - 11.06.19 - 14:55
(21) Уровень риска = Результат * Подверженность * Вероятность.
Это формула и код. Чего тут программировать?
   KILL_OFF_COBECTb
 
27 - 11.06.19 - 14:57
каждому значению в столбце присваиваешь значение от 1 до 6 от меньшего по уровню. потом суммируешь, делишь на 3 и на 6 и умножаешь на 100%,
в шкале уровня риска 9 вариантов (как я понял надо выбрать цифру) то есть 1 уровень если 0% < Результат < 11%, 2 уровень если 12% < Результат < 22% и т.д.
   Dotoshin
 
28 - 11.06.19 - 14:58
(0) А какие риски оцениваются? Ну то есть кто чем и во имя чего рискует?
   Garykom
 
29 - 11.06.19 - 15:01
(0) Можно, но не бесплатно
   KILL_OFF_COBECTb
 
30 - 11.06.19 - 15:04
(17)
по моему мнению это так
Почти всегда - постоянно - смертельные = 9
Почти не возможно - Редко - Смертельные = 4
Почти не возможно - постоянно - Смертельные = 6
 
 
   Lama12
 
31 - 11.06.19 - 15:07
(30) (27)  Вес должны сказать либо эксперты либо статистика. Третьего не дано.
   TumenJan
 
32 - 11.06.19 - 15:07
(30) а как 9 получилось? Вроде как 7 получается или ...
   Lama12
 
33 - 11.06.19 - 15:09
Мда... как-то после вот этого https://yandex.ru/images/search?cbir_id=1781542%2F0OUtypPe1fi3UNO-G3rV5g&cbird=5&rpt=imageview&redircnt=1560254849.1 даже подсказывать не хочется.
   KILL_OFF_COBECTb
 
34 - 11.06.19 - 15:09
(32) почему 7? у тебя все столбцы максимально возможный уровень риска имеют 100% по сути
   TumenJan
 
35 - 11.06.19 - 15:12
(34) все равно понять не могу(, как код написать
   KILL_OFF_COBECTb
 
36 - 11.06.19 - 15:13
(33) я даже в профиль не смотрел, пофиг.
а на счет веса и статистики, согласен в том случае, если бы это стояло в условии. а у нас примитивный вариант.
   KILL_OFF_COBECTb
 
37 - 11.06.19 - 15:31
(35) ну как вариант можно написать кучу конструкций Если Тогда...
например:
Если ПочтиНевозможно Тогда Верояность = 1;
ИначеЕсли Маловероятно Тогда Верояность = 2;
....
ИначеЕсли ПочтиВсегда Тогда Верояность = 6;
КонецЕсли;

Если Редко Тогда Подверженность = 1;
ИначеЕсли Ежеквартально Тогда Подверженность = 2;
....
ИначеЕсли Постоянно Тогда Подверженность = 6;
КонецЕсли;

Если ПерваяПомощь Тогда Результат = 1;
ИначеЕсли ОказаниеМедПомощи Тогда Результат = 2;
....
ИначеЕсли СмертельныеСлучаи Тогда Результат = 6;
КонецЕсли;

Риск = Верояность + Подверженность + Результат;
Риск = Риск/18;
Риск = Риск*100;

Если Риск >= 0 и Риск < 11 Тогда
    Результат = 1;
Иначе Риск >= 11 и Риск < 22 Тогда
    Результат = 2;
...
КонецЕсли;
Сообщить("Результат: " + Результат);
   Irbis
 
38 - 11.06.19 - 15:58
На картинке из (0) жуткий бред, в некоторых множествах сгруппированы неоднородные понятия.

Начать следует с определения элементарных событий, вида функции плотности вероятности, оцифровки её параметров и только потом уже переходить к расчетам.
Как можно сравнивать ежегодный риск например в 300/365 и дневной в 1/24 (цифры с потолка разумеется)

Похоже предлагается обсуждение непарнокопытного млекопитающего в условиях отсутствия вещества.
   Вафель
 
39 - 11.06.19 - 16:02
(38) при чем здесь функция вероятности? просто ради умного словца?
тут тупо нужна талица соотвествий
   Irbis
 
40 - 11.06.19 - 16:12
(39) Для расчета вероятностей. Эта функция параметризованная, и есть искомая модель. И в целом её нахождение и есть решение задачи. А расчет конкретного значения при исходных данных уже не составит никакой сложности.
   Вафель
 
41 - 11.06.19 - 16:14
(40) определить вероятность каждого события - это уже совсем другая задача
   Irbis
 
42 - 11.06.19 - 16:18
(41) Можно обойтись и таблицей, но что делать если попадется промежуточное значение? Линейная аппроксимация иногда может дать очень далёкий от истины ответ. Потому и советую подобрать тип закона (нормальный, экспоненциальный и т. д.), а затем параметризировать модель
   Вафель
 
43 - 11.06.19 - 16:23
(42) ты какую то свою задачу решаешь, не ту что в (0)
   Irbis
 
44 - 11.06.19 - 16:28
(42) В (0) нет задачи, там поди туда не знаю куда и найди то не знаю что. Если все варианты расписаны заранее, то всё можно запихнуть в макет, таблицу, массив или любой другой подходящий или не очень объект, и просто позиционироваться на нужную точку в пространстве входящих координат.
   TumenJan
 
45 - 12.06.19 - 03:54
(37) Если Риск >= 0 и Риск < 11 Тогда
    Результат = 1;
Иначе Риск >= 11 и Риск < 22 Тогда
    Результат = 2;

Эту часть не могу понять), откуда 11
   quest
 
46 - 12.06.19 - 08:40
(0) clips в руки - и делай.
   TumenJan
 
47 - 12.06.19 - 10:41
(37) Если ПочтиНевозможно Тогда Вероятность = 1;
    ИначеЕсли Маловероятно Тогда Вероятность = 2;
    ИначеЕсли Слышал Тогда Вероятность = 3;    
    ИначеЕсли СлучалосьПрежде Тогда Вероятность = 4;
    ИначеЕсли Возможно Тогда Вероятность = 5;
    ИначеЕсли ПочтиВсегда Тогда Вероятность = 6;    
    КонецЕсли;
    
    Если Редко Тогда Подверженность = 1;
    ИначеЕсли Ежеквартально Тогда Подверженность = 2;
    ИначеЕсли Ежемесячно Тогда Подверженность = 3;
    ИначеЕсли Еженедельно Тогда Подверженность = 4;    
    ИначеЕсли Ежедневно Тогда Подверженность = 5;    
    ИначеЕсли Постоянно Тогда Подверженность = 6;
    КонецЕсли;
    
    Если ПерваяПомощь Тогда Результат = 1;
    ИначеЕсли ОказаниеМедицинскойПомощи Тогда Результат = 2;
    ИначеЕсли СерьезныйСлучай Тогда Результат = 3;
    ИначеЕсли Инвалидность Тогда Результат = 4;
    ИначеЕсли ОдинСмертельныйСлучай Тогда Результат = 5;
    ИначеЕсли СмертельныеСлучаи Тогда Результат = 6;
    КонецЕсли;
    
    Риск = Вероятность + Подверженность + Результат;
    Риск = Риск/18;
    Риск = Риск*100;
    
    Если Риск >= 0 и Риск < 11 Тогда
        Результат = 1;
    ИначеЕсли Риск >= 11 и Риск < 22 Тогда
        Результат = 2;
    КонецЕсли;
    Сообщить("Результат: " + Результат);

Ошибка: {Документ.ОтчетОПроведенииАудита1.Форма.ФормаДокумента.Форма(1523)}: Преобразование значения к типу Булево не может быть выполнено
     Если ПочтиНевозможно Тогда Вероятность = 1;
   quest
 
48 - 12.06.19 - 11:01
ПочтиНевозможно имеет тип отличный от  булево.
   quest
 
49 - 12.06.19 - 11:02
(47) и открой для себя регистры сведений. что бы в коде такие портянки не писать
   TumenJan
 
50 - 12.06.19 - 11:26
(49) Подскажи как этот код закончить:
Если Риск >= 0 и Риск < 11 Тогда
    Результат = 1;
Иначе Риск >= 11 и Риск < 22 Тогда
    Результат = 2;
...
....
...
..
КонецЕсли;
Сообщить("Результат: " + Результат);
   lEvGl
 
51 - 12.06.19 - 11:53
просидел провтыкал минут 20 пока посмотрел картинки, почитал , что пишут, дошел до 50 и понял, что 20 минут ушло зря и навсегда

(50) что ж ты делаешь, клава/колёк (кто ты там)?! многие из топика времени потратили больше, так с людьми нельзя
хрена там заканчивать?! в таком же духе до максимального варианта
за тебя уже придумали "систему кратности" всех этих вариантов и результата, осталось только даже не мозгом, а пальцами пошевелить и написать текст
(36) кажется, что смотрел ;)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.