Вход | Регистрация
 

Здравствуйте. Помогите пжл как сделать так чтобы при нажатии на кнопку открыть эл документ

Здравствуйте. Помогите пжл как сделать так чтобы при нажатии на кнопку открыть эл документ
Я
   Айрат_116
 
09.06.19 - 19:02
Помогите как сделать так чтоб при нажатии на кнопку в форме документа "Поступление"
Я мог открыть связанный эл документ

Я написал функцию
   &НаКлиенте
Процедура Перейти_ЭД(Команда)
    ЭД=Перейти_ЭДНаСервере();
    
КонецПроцедуры
&НаСервере
Функция Перейти_ЭДНаСервере()
    Запрос=Новый Запрос;
    Запрос.Текст="ВЫБРАТЬ
    |    ЭлектронныйДокументСписокПрикрепленныхДокументов.Ссылка КАК Ссылка,
    |    ЭлектронныйДокументСписокПрикрепленныхДокументов.ПрикрепленныйДокумент
    |ИЗ
    |    Документ.ЭлектронныйДокумент.СписокПрикрепленныхДокументов КАК ЭлектронныйДокументСписокПрикрепленныхДокументов
    |ГДЕ
    |    ЭлектронныйДокументСписокПрикрепленныхДокументов.ПрикрепленныйДокумент = &ПрикрепленныйДокумент";
    Запрос.УстановитьПараметр("ПрикрепленныйДокумент",Объект.Ссылка);
    Результат=Запрос.Выполнить().Выбрать();
    Если Результат.Следующий() Тогда
        Возврат Результат.Ссылка;
    Иначе
        Возврат "";
    КонецЕсли;
КонецФункции

Не получается почему то(
 
 
   mikecool
 
1 - 09.06.19 - 22:31
Процедура Перейти_ЭД(Команда)
    ЭД=Перейти_ЭДНаСервере();
Если ЗначениеЗаполнено(ЭД) ТОгда
    ОткрытьЗначение(ЭД);
КонецЕсли;
КонецПроцедуры
   Айрат_116
 
2 - 09.06.19 - 22:42
(1) Спасибо щас попробую
   Айрат_116
 
3 - 09.06.19 - 23:06
(1) Спасибо еще раз =) Получилось сделать)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.