Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Индикатор не работает

Индикатор не работает
Я
   Gray776
 
07.06.19 - 12:47
Вот код собственно
    ДокРеализация = Метаданные.Документы.РеализацияТоваровУслуг;
    
    ИндикаторОбработкиРеализаций = 0;
    ЭлементыФормы.ИндикаторОбработкиРеализаций.МаксимальноеЗначение = ТЗ_Реализации.Количество();
        Сообщить(ТЗ_Реализации.Количество());
    Для Каждого Стр Из ТЗ_Реализации Цикл
        ДокРеализация = Стр.Ссылка.ПолучитьОбъект();
        
        Для Каждого СтрНоменклатуры Из ДокРеализация.Товары Цикл
            
                Сообщить(СтрНоменклатуры.Номенклатура);
                Сообщить(СтрНоменклатуры.Цена);
                
                //ОбработкаТабличныхЧастей.ЗаполнитьЕдиницуЦенуПродажиТабЧасти(СтрНоменклатуры, ДокРеализация, омВалютаРегламентированногоУчета);
                НоваяЦена = Ценообразование.ПолучитьЦенуНоменклатуры(СтрНоменклатуры.Номенклатура, ДокРеализация.ТипЦен, ДокРеализация.Дата, омВалютаРегламентированногоУчета, 1, 1);
                СтрНоменклатуры.Цена = НоваяЦена;
                //
                //Сообщить(СтрНоменклатуры.Номенклатура);
                Сообщить(СтрНоменклатуры.Цена);
                
                
            КонецЦикла;
            Если ДокРеализация.Проведен Тогда
                ДокРеализация.Записать(РежимЗаписиДокумента.Проведение);
            Иначе
                ДокРеализация.Записать(РежимЗаписиДокумента.Запись);
            КонецЕсли;
            

            ЭлементыФормы.НадписьСтатус.Заголовок =  "Обработка реализации: " + Строка(Стр.Ссылка);
            
            ИндикаторОбработкиРеализаций = ИндикаторОбработкиРеализаций + 1;
            ОбработкаПрерыванияПользователя();
            
        КонецЦикла;
        ИндикаторОбработкиРеализаций = ЭлементыФормы.ИндикаторОбработкиРеализаций.МаксимальноеЗначение;
    КонецПроцедуры
 
 
   Вафель
 
1 - 07.06.19 - 12:48
может у элемента не тот реквизит что ты меняешь?
   Gray776
 
2 - 07.06.19 - 12:53
(1) Хммм сейчас гляну может и правда...
   Ювелир
 
3 - 07.06.19 - 12:59
http://catalog.mista.ru/public/76309/

Я так понял. не хватает.
ОбновитьОтображениеДанных();
   Gray776
 
4 - 07.06.19 - 13:09
(3) (1) Спасибо заработало... Не было выбрано поле данные на форме...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.