Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа с WEB-камерами

Работа с WEB-камерами
Я
   ChMikle
 
07.06.19 - 12:17
Доступ к Веб Камере из 1С 8.3 все работало , работало и тут на тебе
перестал срабатывать метод ВКВидео.ПодключитьКамеру(ID, "Камера", 3);
имя веб-камеры передается вместо id, а обратно вываливает полностью из программы .
 
 
   RomaH
 
1 - 07.06.19 - 12:26
обновили платформу?
   ChMikle
 
2 - 07.06.19 - 12:32
Да
   ChMikle
 
3 - 07.06.19 - 12:32
8.3.13.1644
   RomaH
 
4 - 07.06.19 - 12:33
ну и все - та версия ВК не будет работать больше
новая - за деньги
на инфостарте видел что-то в 10 раз дешевле
   ChMikle
 
5 - 07.06.19 - 12:34
сколько стоит ?
   ChMikle
 
6 - 07.06.19 - 12:35
и если откатить,то до какой платформы можно юзать бесплатно ?
   RomaH
 
7 - 07.06.19 - 12:40
10 000
не помню 11 или 12 ... отрисовка окон поменялась
   ChMikle
 
8 - 07.06.19 - 12:43
Как с разработчиком компоненты связаться на предмет покупки, не подскажешь  ?
   RomaH
 
9 - 07.06.19 - 12:44
в личке почта
   Nyoko
 
10 - 07.06.19 - 12:45
я в свое время просто из веб интерфейсас камеры по http брал jpg. просто и удобно..
   ChMikle
 
11 - 07.06.19 - 12:49
(10) А пример работы можете выложить ?
   ChMikle
 
12 - 07.06.19 - 12:52
(9) написал :)
   Юрий Лазаренко
 
13 - 07.06.19 - 12:57
Можно сделать промежуточную базу на старой версии платформы, даже файловую, камеру подключить к ней. Ее дергать из основной базы, промежуточная пусть берет картинку с камеры и отдает рабочей базе.
   RomaH
 
14 - 07.06.19 - 13:00
(11) пример ничем не отличается от того что есть у тебя


&НаКлиенте
Процедура Сфотографировать(Команда)
    Файл = Видео.ПолучитьФото(НЕ ВесьКадр);    //Возвращает картинку в размер видео-окна, если в функцию передать Ложь, будет сфотографировано всё видео (640х480)

    Фото = ПоместитьВоВременноеХранилище(Файл, УникальныйИдентификатор);
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Видео.Установить();
    Список = Видео.ПолучитьСписокКамер();    //возвращает список установленных камер по 2 строки на каждую

    Текст = Новый ТекстовыйДокумент;
    Текст.УстановитьТекст(Список);
    Для Строка = 1 по Текст.КоличествоСтрок() Цикл
        Элементы.Камера.СписокВыбора.Добавить(Текст.ПолучитьСтроку(Строка + 1), Текст.ПолучитьСтроку(Строка));
        Строка = Строка + 1;    //второй раз добавит сам цикл

    КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура КамераПриИзменении(Элемент)
    Видео.ОтключитьКамеру();
    
    ИмяОкна = ЭтаФорма.Окно.Заголовок;
    
    Если Камера <> "" Тогда
        //выводим картинку с выбранной камеры в указанные координаты указанного размера

        //4 последних параметра: x, y координаты левого верхнего угла окна, далее ширина и высота окна (они же соответствуют размерам получаемой фотографии)

        Видео.ПодключитьКамеру(Камера, ИмяОкна, 20, 85, 220, 280);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПриЗакрытии()
    Видео.ОтключитьКамеру();
КонецПроцедуры
   Garykom
 
15 - 07.06.19 - 13:53
Не у всех камер есть http или rtsp.
Но у кого нет можно легко сделать есть куча бесплатного и опенсурсного.
   Nyoko
 
16 - 07.06.19 - 14:24
(15) Да можно, или купить сразу камеру с http в моём случае была камера wifi китайская за 3 тр
   Garykom
 
17 - 07.06.19 - 14:27
(16) Че так дорого я по 1600р брал
   Garykom
 
18 - 07.06.19 - 14:28
(17)+ но просто фуллхд 1920х1080 не 4к какие то

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.