Вход | Регистрация
 

Как написать условие?

↓ [Волшебник, 04.06.19 - 21:39]
Как написать условие?
Я
   Айрат_116
 
04.06.19 - 21:08
Как написать условие?
Например
Если Строка<0 Тогда не брать сумму этой строки
 
 
   Ёпрст
 
1 - 04.06.19 - 21:11
(0)
Так и пиши:
Если СтрокаДокумента.Сумма<0 Тогда
   Продолжить;
КонецЕсли;
   Zombi
 
2 - 04.06.19 - 21:12
Если Строка < 0 Тогда
   БратьСуммуЭтойСтроки = Ложь;
КонецЕсли;

Что у тебя находится в переменной "Строка"? Ато сравнение может и не отработать.
   Фрэнки
 
3 - 04.06.19 - 21:16
нужно видеть контекст

контекст становится виден, когда известен код до и код после ожидаемой вставки условия
   Айрат_116
 
4 - 04.06.19 - 21:28
Щас попробую все что написали. Потом отпишу
   Web00001
 
5 - 05.06.19 - 03:07
Забавно, что ТС в вопросе практически написал ответ на свой вопрос. Учись задавть вопросы тред.
   Айрат_116
 
6 - 05.06.19 - 09:43
Можно еще вопрос как в запросе сделать такое условие?
условие  если есть остаток на начало года то не исключать остаток на начало года не обнулится. Если с нового прихода то исключается с текущего года.


Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ХозрасчетныйОборотыДтКт.Регистратор КАК Док,
        |    ХозрасчетныйОборотыДтКт.СубконтоДт1 КАК Наименование,
        |    ХозрасчетныйОборотыДтКт.СубконтоДт2 КАК Разделитель,
        |    ВЫБОР
        |        КОГДА ХозрасчетныйОборотыДтКт.СуммаОборот < 0
        |            ТОГДА 0
        |        ИНАЧЕ ХозрасчетныйОборотыДтКт.СуммаОборот
        |    КОНЕЦ КАК Значение
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(&НачалаПериода, &КонецПериода, Регистратор, СчетДт = &СчетДт08, , СчетКт = &СчетКт07, , Организация = &Организация) КАК ХозрасчетныйОборотыДтКт
        |ГДЕ
        |    (ХозрасчетныйОборотыДтКт.СубконтоДт2 = &СубконтоДт21
        |            ИЛИ ХозрасчетныйОборотыДтКт.СубконтоДт2 = &СубконтоДт22)";
    
    Если ЗначениеЗаполнено(Данные) Тогда
        Запрос.Текст=Запрос.Текст+" И ХозрасчетныйОборотыДтКт.СубконтоДт1 = &СубконтоДт1";
        Запрос.УстановитьПараметр("СубконтоДт1" , Данные);
    КонецЕсли;
    
    
    Запрос.УстановитьПараметр("КонецПериода", КонецДня(КонецПериода));
    Запрос.УстановитьПараметр("НачалаПериода", НачалаПериода);
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("СубконтоДт21", Справочники.СтатьиЗатрат.НайтиПоКоду("л00000044"));
    Запрос.УстановитьПараметр("СубконтоДт22", Справочники.СтатьиЗатрат.НайтиПоКоду("л00000045"));
    Запрос.УстановитьПараметр("СчетДт08", ПланыСчетов.Хозрасчетный.СтроительствоОбъектовОсновныхСредств);
    Запрос.УстановитьПараметр("СчетКт07", ПланыСчетов.Хозрасчетный.ОборудованиеКУстановке);
    
    ТЗ = Запрос.Выполнить().Выгрузить();
    ТЗ.Сортировать("Наименование");
    Возврат ТЗ;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.