Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Метаданные, получение типов

Метаданные, получение типов
Я
   SkAt
 
03.06.19 - 18:26
Доброго времени суток! Подскажите, пожалуйста, при вводе строки в конфигураторе <Тип("ДокументСсылка.ЗаказКлиента")> выходит подсказка на ввод имени типа. Как формируется этот список и можно ли получить его программно? Заранее спасибо.
 
 
   Жан Пердежон
 
1 - 03.06.19 - 18:33
если только метаданные - можешь сам в цикле пройтись по ним и составить;
остальное зависит от версии платформы и кроме как из заранее составленного списка не узнаешь.
   mistеr
 
2 - 03.06.19 - 18:35
Объект глобального контекста Метаданные.
   Вафель
 
3 - 03.06.19 - 18:41
в турбоконфе наверное можно
   SkAt
 
4 - 03.06.19 - 18:53
(1) Метаданные не обойти циклом, не обратится по индексу и т.п.
   Вафель
 
5 - 03.06.19 - 18:54
(4) конечно обойти
   mistеr
 
6 - 03.06.19 - 19:07
(4) Реальную задачу озвучь
   SkAt
 
7 - 03.06.19 - 19:29
(6) Попробую)) Обработка для поиска объекта БД по идентификатору ссылки. Должна быть универсальной (под УТ, КА, ЗУП, БП как минимум). Хочу собирать все объекты метаданных, обрабатывать, получать ссылку.
   PowerBoy
 
8 - 04.06.19 - 07:46
//Поиск объекта по GUID


&НаСервере
Процедура ПоискОбъектаПоGUIDНаСервере()
    // Вставить содержимое обработчика.

    УИ = Новый УникальныйИдентификатор(объект.GUID);
    Если ПолучитьСсылкуНоМенеджеруОбъекта(Справочники,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Документы,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыВидовХарактеристик,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыСчетов,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(ПланыОбмена,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(БизнесПроцессы,УИ) Тогда
    ИначеЕсли ПолучитьСсылкуНоМенеджеруОбъекта(Задачи,УИ) Тогда
        Сообщить("Объект не найден");
    КонецЕсли;
    объект.ДатаСозданияСсылки = UUID_Timestamp(объект.GUID);
    объект.ВерсияСсылки = UUID_Version(объект.GUID);
    объект.МакАдресСсылки = UUID_Node(объект.GUID);
КонецПроцедуры
&НаСервере
Функция ПолучитьСсылкуНоМенеджеруОбъекта(ОбъектыМенеджер,УИ)
 Для Каждого Менеджер Из ОбъектыМенеджер Цикл
  объект.НайденнаяСсылка = Менеджер.ПолучитьСсылку(УИ);
  Если объект.НайденнаяСсылка.ПолучитьОбъект() <> Неопределено Тогда
      Возврат Истина;
  КонецЕсли;
 КонецЦикла;
Возврат Ложь;
КонецФункции
   SkAt
 
9 - 09.06.19 - 23:35
(8) Благодарю! Воспользуюсь))

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.