Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как присвоить уникальный идентификатор набору записей

Как присвоить уникальный идентификатор набору записей
Я
   1сЮлия
 
03.06.19 - 10:38
Как присвоить уникальный идентификатор набору записей у меня есть табличные части,которые могут быть равны,для равных табличных частей можно присвоить свой уникальный идентификатор,чуть отличается табличная часть другой идентификатор. Как это реализовать?
 
 
   Cyberhawk
 
1 - 03.06.19 - 10:39
Для началча сформулировать критерии равенства / неравенства
   1сЮлия
 
2 - 03.06.19 - 10:51
Должны совпадата построчно ТабЧасть1.НомерСтроки =ТабЧасть2.НомерСтроки
                           ТабЧасть1.Показатель = ТабЧасть2.Показатель 
                           ТабЧасть1.ЗначениеПоказателя = ТабЧасть2.ЗначениеПоказателя  номеров строк 5 показателй и значений 5,построчно должны совпадать показатели,номера строк и значения если,что то отличается уже другой идентификатор
   Cyberhawk
 
3 - 03.06.19 - 10:53
ЗначениеВСтрокуВнутр(ТабЧасть1) попробуй
   H A D G E H O G s
 
4 - 03.06.19 - 10:55
(0)
Функция ПолучитьХешДляДанных(Данные) Экспорт
    СтрокаДанных="";
    Для Каждого ЭлементМассива Из Данные Цикл
        Если ТипЗнч(ЭлементМассива)=Тип("Структура") Тогда// Адрес в массиве

            Если НЕ ЭлементМассива.Свойство("Хеш") Тогда
                ЭлементМассива.Вставить("Хеш",ПолучитьХешДляДанных(ЭлементМассива));
            КонецЕсли;
            СтрокаДанных=СтрокаДанных+ЭлементМассива.Хеш;
        Иначе
            СтрокаДанных=СтрокаДанных+XMLСтрока(ЭлементМассива);
        КонецЕсли;
    КонецЦикла;
    Если СтрокаДанных="" Тогда
        Возврат "";
    КонецЕсли;
    Хеширование=Неопределено;
    Хеширование=Новый ХешированиеДанных(ХешФункция.MD5);
    Хеширование.Добавить(СтрокаДанных);
    ХешСуммаBase64 = Base64Строка(Хеширование.ХешСумма);
    Возврат ХешСуммаBase64;
КонецФункции
   H A D G E H O G s
 
5 - 03.06.19 - 10:56
Естественно, последовательность данных во входящем массиве должна соблюдаться.
   H A D G E H O G s
 
6 - 03.06.19 - 10:59
Набор записей можно смутировать в массив структур и тоже передать. Ну забывайте о сортировке только.
   1сЮлия
 
7 - 03.06.19 - 11:12
Это он возвращает уникальный идентификатор набору записей,а Данные это массив мне нужно ,я свою табчасть должна выгрузить в массив, я так понимаю?
   H A D G E H O G s
 
8 - 03.06.19 - 11:18
(7) массив структур
   1сЮлия
 
9 - 03.06.19 - 11:21
Спасибо большое,а в запросе можно как то это сделать? Чтобы в одном месте все сделать,вообще возможно ?
   H A D G E H O G s
 
10 - 03.06.19 - 11:28
(9) ytn
   H A D G E H O G s
 
11 - 03.06.19 - 11:29
нет

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.