Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не помещается текст в буфер обмена

Не помещается текст в буфер обмена
Я
   Dirk Diggler
 
02.06.19 - 17:35
В общем модуле есть вот такие 1 функция, и 1 процедура.

Вызываются из кода формы элемента справочника. Вопрос. Почему первая работает, а вторая падает с ошибкой

{ОбщийМодуль.Вспомогательный.Модуль(1919)}: Ошибка при получении значения атрибута контекста (clipboardData)
       О.ParentWindow.ClipboardData.Setdata("Text", "" + стрТекст);    
по причине:
Произошла исключительная ситуация: Ошибка при вызове OpenClipboard






Функция GUIDОБъектаВБуфер(Объект) Экспорт
    стрТекст = Объект.Ссылка.УникальныйИдентификатор();
    #Если Клиент Тогда
        О = Новый COMОбъект("htmlfile");
        О.ParentWindow.ClipboardData.Setdata("Text", "" + стрТекст);    
    #КонецЕсли
    
    Возврат стрТекст;
КонецФункции

Процедура ПоместитьВБуферОбмена(стрТекст) экспорт
#Если Клиент Тогда
       О = Новый COMОбъект("htmlfile");
       О.ParentWindow.ClipboardData.Setdata("Text", "" + стрТекст);    
#КонецЕсли
КонецПроцедуры
 
 
   Dirk Diggler
 
1 - 02.06.19 - 17:37
Что характерно, если идти отладчиком - все ок. Пауза нужна, штоле?
   shuhard
 
2 - 02.06.19 - 17:38
(1) почему бы нет ?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.