Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение табличного поля на форме внешней обработки цветом

Заполнение табличного поля на форме внешней обработки цветом
Я
   JuixyJes
 
31.05.19 - 12:00
Доброго времени суток, пишу маленькую обработку, на форме имеется два поля ввода с типом дата, так же имеется табличная часть. В табличной части добавляется столько колонок, сколько дней в месяце, указанном в одном из полей ввода( там есть дата, оттуда берется месяц). Как мне заполнить черным цветом те ячейки, которые попадают в промежуток между двумя датами?
 
 
   mikecool
 
1 - 31.05.19 - 12:03
это ты в 77 делаешь?
   mikecool
 
2 - 31.05.19 - 12:04
для 8х - приполученииданных у таб поля и оформлениестроки
   JuixyJes
 
3 - 31.05.19 - 12:05
(2) а можно по подробнее? Это 8.3 обычное приложение
   JuixyJes
 
4 - 31.05.19 - 12:06
Процедура КнопкаВыполнитьНажатие(Кнопка)
    КалендарныхДней = День(КонецМесяца(ПолеВвода1));
    Пока ЭлементыФормы.Корни.Колонки.Количество() <> КалендарныхДней Цикл
        ЭлементыФормы.Корни.Колонки.Добавить();
    КонецЦикла ;
    ВъездДень = (ПолеВвода1-НачалоМесяца(ПолеВвода1))/ (60 * 60 * 24);
    ВыездДень = (ПолеВвода2-НачалоМесяца(ПолеВвода1))/ (60 * 60 * 24);
    КоличествоДней = ((ПолеВвода2-ПолеВвода1)/(60*60*24))+1;

КонецПроцедуры
   JuixyJes
 
5 - 31.05.19 - 12:07
И вот как мне поля, которые между днями въезда и выезда (включительно) пометить цветами?
   catena
 
6 - 31.05.19 - 12:22
ЭлементыФормы.Корни.Колонки[ИмяКолонки].ЦветФонаПоля = Новый Цвет(0,0,0);
   Eg0rkas
 
7 - 31.05.19 - 12:25
можно еще в событии ПриВыводеСтроки, посмотреть ОформлениеСтроки, и в цикле по условию заполнять цвет фона
   JuixyJes
 
8 - 31.05.19 - 12:26
(6) А если у меня даты будут с 10 по 13, тогда мне ИмяКолонки как задать? И как поменять имя колонки при ее формировании впринципе?     



Для сч = День(ПолеВвода1) по День(ПолеВвода2) Цикл
        НовСтр = Корни.Добавить();
КонецЦикла;
   catena
 
9 - 31.05.19 - 12:28
(8)СП еще не купил?

КолонкиТабличногоПоля (TableBoxColumns)
Добавить (Add)
Синтаксис:

Добавить(<Имя>, <ТекстШапки>)
Параметры:

<Имя> (необязательный)

Тип: Строка. 
Имя колонки. Если имя колонки не указано, то будет сформировано имя вида "КолонкаN". 
<ТекстШапки> (необязательный)

Тип: Строка.
Текст, который будет выводиться в заголовке колонки табличного поля.
   JuixyJes
 
10 - 31.05.19 - 12:31
(9) Табличная часть формы это, при попытке задать имя колонки я получаю вот такую ошибку

{ВнешняяОбработка.Математика.Форма.Загруженность.Форма(5)}: Ошибка при вызове метода контекста (Добавить)
        ЭлементыФормы.Корни.Колонки.Добавить("День");
по причине:
Недопустимое значение параметра (параметр номер '1')
   catena
 
11 - 31.05.19 - 12:32
(10)А ты их все одинаково называешь?
   JuixyJes
 
12 - 31.05.19 - 12:36
(11) Спасибо, разобралась, мозг что-то совсем не варит
   mikecool
 
13 - 31.05.19 - 14:02
(7)  лучше ПриПолученииДанных

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.