Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отчет о движении товаров в форме документа

Отчет о движении товаров в форме документа
Я
   umkasort
 
30.05.19 - 13:58
В типовой документации самописный документ, пытаюсь вывести на форму стандартный отчет о движении документа, кнопка с отчетами появляется но ничего не происходит, но при нажатии ничего не происходит

В модуле формы записал
1) ПриСозданииНаСервере
ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
2) Добавляем процедуру
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

1С:Предприятие 8.3 (8.3.14.1630)
1С:ERP Управление предприятием 2 (2.4.7.151)
Серверная
 
 
   shuhard
 
1 - 30.05.19 - 14:19
(0) а так  ?

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    
    // СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды


    
КонецПроцедуры



// СтандартныеПодсистемы.ПодключаемыеКоманды

&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Объект);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Объект, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Объект);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды


// СтандартныеПодсистемы.Свойства

&НаКлиенте
Процедура Подключаемый_СвойстваВыполнитьКоманду(ЭлементИлиКоманда, НавигационнаяСсылка = Неопределено, СтандартнаяОбработка = Неопределено)
    
    УправлениеСвойствамиКлиент.ВыполнитьКоманду(ЭтотОбъект, ЭлементИлиКоманда, СтандартнаяОбработка);

КонецПроцедуры
// Конец СтандартныеПодсистемы.Свойства


&НаКлиенте
Процедура Подключаемый_ВыполнитьПереопределяемуюКоманду(Команда)
    
    СобытияФормКлиент.ВыполнитьПереопределяемуюКоманду(ЭтаФорма, Команда);
    
КонецПроцедуры
   umkasort
 
2 - 30.05.19 - 14:25
(2) Спасибо! Работает
   shuhard
 
3 - 30.05.19 - 14:29
(2) OK

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.