Вход | Регистрация
 

1с ЗУП 3.1 Внеш обработкой меняю табличную часть документа. Как запустить стандартный код?

1с ЗУП 3.1 Внеш обработкой меняю табличную часть документа. Как запустить стандартный код?
Я
   evorle145
 
29.05.19 - 12:52
Подключил внешнюю обработку с видом "Заполнение объекта", она заполняет табличную часть документа. Далее надо чтобы выполнилась стандартная процедура (которая выполняется, когда делаем подбор сотрудников):
&НаСервере
Процедура ОбработкаПодбораНаСервере(Знач Сотрудники)
    
    ....
    
    ....
    
    РассчитатьСотрудниковНаСервере(Сотрудники, ОписаниеТаблицыНачислений(РегистрацияНачисленийДоступна), Ложь);
    ЗарплатаКадрыКлиентСервер.КлючевыеРеквизитыЗаполненияФормыУстановитьОтображениеПредупреждения(ЭтаФорма);
    
КонецПроцедуры

но просто скопировать ее в мою обработку не выходит, потому что не понятно, что в нее подставить вместо "ЭтаФорма" и как следствие не понятно как из внешней процедуры обработать реквизиты этой самой формы, ведь на сервер нельзя передать форму...
 
 
   Gucci76
 
1 - 29.05.19 - 13:04
Может через ВладельцаФормы как-нить?
   evorle145
 
2 - 29.05.19 - 13:09
(1)         Форма = ЭтаФорма.ВладелецФормы;
по причине:
Свойство недоступно на сервере
пытался..
   evorle145
 
3 - 29.05.19 - 13:14
а, все, разобрался. Вот так можно:

КлючПоиска = Новый Структура("Ключ", ОбъектНачисление);

            Окна = ПолучитьОкна();
            Для каждого Окно1 из Окна Цикл

                Если Окно1.Содержимое.Количество() Тогда
                    Для каждого ФормаДокумента Из Окно1.Содержимое Цикл
                        Если СтрНайти(СокрЛП(ФормаДокумента.ИмяФормы), "Документ.Премия.Форма.ФормаДокумента")>0 Тогда
                            ФормаДокумента.Прочитать();
                            ФормаДокумента.ОбновитьОтображениеДанных();
                            Сообщить(МассивСотрудники.Количество());
                            ФормаДокумента.ОбработкаПодбораНаСервере(МассивСотрудники);

                        КонецЕсли;
                    КонецЦикла;
                КонецЕсли;

            КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.