Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как программно отнести сумму проводки в расхода первого раздела КУДИР.

Как программно отнести сумму проводки в расхода первого раздела КУДИР.
Я
   sodeistvie26
 
29.05.19 - 11:20
Добрый день! Вот такой код:

    //// Формирование проводок
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ = Документы.ОперацияБух.СоздатьДокумент();
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Дата = ДатаНачисленияОперации;
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Содержание = "Начислены проценты по сбережению " + ИмяКлиента + " за " + Месяц(ДатаНачисленияОперации)+ " месяц " + Год(ДатаНачисленияОперации)+ " года." ;
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Организация = Справочники.Организации.НайтиПоРеквизиту("ИНН","2632112633");
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Записать();
    НовыйДокументПереводаПроцентовИНачисленияНДФЛСсылка = НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Ссылка;
    Проводки = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    // Создание регистра накоплений КнигаУчетаДоходовИРасходов
    СтрокаТЧ = НовыйДокументПереводаПроцентовИНачисленияНДФЛ.ТаблицаРегистровНакопления.Добавить();
    СтрокаТЧ.Имя = "КнигаУчетаДоходовИРасходов" ;
    НаборЗаписей = НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Движения.КнигаУчетаДоходовИРасходов;
    Запись = НаборЗаписей.Добавить();
    Запись.Организация = Справочники.Организации.НайтиПоРеквизиту("ИНН","2632112633");
    Запись.Период = ДатаНачисленияОперации;
    Запись.Регистратор = НовыйДокументПереводаПроцентовИНачисленияНДФЛСсылка;
    НаборЗаписей.Записать();
    //
    Проводки.Отбор.Регистратор.Значение = НовыйДокументПереводаПроцентовИНачисленияНДФЛСсылка;
    Проводки.Очистить();
    НовыйДокументПереводаПроцентовИНачисленияНДФЛ.СпособЗаполнения = "Вручную";
    Проводки.Записать(Истина);
    Проводки.Записывать = Истина;
    КПКСодействие = Справочники.Организации.НайтиПоРеквизиту("ИНН","2632112633");
    ДоговорПеревода = Справочники.ДоговорыКонтрагентов.НайтиПоРеквизиту("Номер", НомерДоговора);
    ДоговорКопилки = Справочники.ДоговорыКонтрагентов.НайтиПоРеквизиту("Номер", НомерДоговораКопилки);
    //// 1ая проводка /////////////
    Проводка1 = Проводки.Добавить();
    Проводка1.Активность = Истина;
    Проводка1.Организация = Справочники.Организации.НайтиПоРеквизиту("ИНН","2632112633");
    Проводка1.Период = ДатаНачисленияОперации;
    //Дебете 1ой проводки
    Проводка1.СчетДт =  ПланыСчетов.Хозрасчетный.НайтиПоКоду("91.02");
    СчетДт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("91.02");
    // Установка субконто для СчетаДт 1ой проводки
    Если Проводка1.СчетДт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные["ПрочиеДоходыИРасходы"]) <> Неопределено Тогда
     БухгалтерскийУчет.УстановитьСубконто(Проводка1.СчетДт, Проводка1.СубконтоДт, "ПрочиеДоходыИРасходы", Справочники.ПрочиеДоходыИРасходы.НайтиПоНаименованию("Проценты, начисленные в соответствии со статьей 269 по физ. лицам"));
    КонецЕсли;
    Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(ИмяКлиента);
    КонтрагентСсылка = Контрагент.Ссылка;
    Если Проводка1.СчетДт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные["РеализуемыеАктивы"]) <> Неопределено Тогда
     БухгалтерскийУчет.УстановитьСубконто(Проводка1.СчетДт, Проводка1.СубконтоДт, "РеализуемыеАктивы", Контрагент.Ссылка);
    КонецЕсли;
    // Кредет 1ой проводки
    Проводка1.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("66.04.1");
    СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("66.04.1");
    Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(ИмяКлиента);
    //Установить субконто для СчетаКр 1ой проводки
    Если Проводка1.СчетКт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные["Контрагенты"]) <> Неопределено Тогда
     БухгалтерскийУчет.УстановитьСубконто(Проводка1.СчетКт, Проводка1.СубконтоКт, "Контрагенты", Контрагент.Ссылка);
    КонецЕсли;
    Если Проводка1.СчетКт.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные["Договоры"]) <> Неопределено Тогда
     БухгалтерскийУчет.УстановитьСубконто(Проводка1.СчетКт, Проводка1.СубконтоКт, "Договоры", ДоговорПеревода);
    КонецЕсли;
    Проводка1.Сумма = ОбщаяСумма;
    Проводка1.СуммаНУДт = ОбщаяСумма;
    Проводка1.СуммаНУКт = ОбщаяСумма;
    Сумма1ойПроводки = ОбщаяСумма;
    //////////////////////////////////

Как сделать так чтобы сумма первой проводки попадала в первый раздел КУДИР?
 
 
   sodeistvie26
 
1 - 29.05.19 - 21:55
bump!
   OldCondom
 
2 - 29.05.19 - 21:58
Здесь прекрасно почти все...
   hhhh
 
3 - 30.05.19 - 00:18
(1) ну здесь
НаборЗаписей = НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Движения.КнигаУчетаДоходовИРасходов; 
    Запись = НаборЗаписей.Добавить(); 
    Запись.Организация = Справочники.Организации.НайтиПоРеквизиту("ИНН","2632112633"); 
    Запись.Период = ДатаНачисленияОперации; 
    Запись.Регистратор = НовыйДокументПереводаПроцентовИНачисленияНДФЛСсылка; 
    НаборЗаписей.Записать(); 

только период и регистратор у вас. А все остальные поля? Вася Пупкин будет заполнять?

и лучше так

Запись.Организация = НовыйДокументПереводаПроцентовИНачисленияНДФЛ.Организация;

десять раз искать организацию по реквизиту - это невероятный дебилизм, согласитесь.
   sodeistvie26
 
4 - 30.05.19 - 08:16
(2) Руки из ..опы у меня. Говнокодил на коленках.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.