Вход | Регистрация
 

Загрузка результата запроса в таблицу значений

Загрузка результата запроса в таблицу значений
Я
   falselight
 
29.05.19 - 09:38
Обработка на управляемых формах.
Можно ли на форме обработки расположить таблицу, без полей.
И выполняя запрос, выгружать его значение в эту таблицу?
Или нужно создавать всегда структуру таблицы под результат запроса?
 
 
   formista2000
 
1 - 29.05.19 - 09:48
можно
   falselight
 
2 - 29.05.19 - 09:50
(1) Как? Что должно быть у таблицы? Какая колонка?
Иначе она не появляется на форме.
    Запрос.УстановитьПараметр("НачДата", Период.ДатаНачала);
    Запрос.УстановитьПараметр("КонДата", Период.ДатаОкончания);    
    ТЗДляВыгрузки.Загрузить(Запрос.Выполнить().Выгрузить());
    //Рез = Запрос.Выполнить();

    //Если Не Рез.Пустой() Тогда

    //    Выборка = Рез.Выбрать();

    //КонецЕсли;

КонецПроцедуры
   Ifkerri
 
3 - 29.05.19 - 09:50
Ответы по тексту:

Можно ли на форме обработки расположить таблицу, без полей. ----- Можно
И выполняя запрос, выгружать его значение в эту таблицу? Ага, ----- так тоже можно
Или нужно создавать всегда структуру таблицы под результат запроса? ----- Нужно обязательно
   ДенисЧ
 
4 - 29.05.19 - 09:51
Элементы.ТвояТаблица.СоздатьКолонки() не пробовал?
   fisher
 
5 - 29.05.19 - 09:56
(0) Можно. Но придется программно создавать и реквизит формы и элемент управления.
   bvb
 
6 - 29.05.19 - 10:05
Может методологически правильней использовать динамический список ?
   fisher
 
7 - 29.05.19 - 10:07
   falselight
 
8 - 29.05.19 - 10:08
(4)

    ТЗДляВыгрузки.Загрузить(Запрос.Выполнить().Выгрузить());
    Элементы.ТЗДляВыгрузки.СоздатьКолонки() 

Пишет объект не обнаружен создать колонки.
   falselight
 
9 - 29.05.19 - 10:09
(6) Может я вот и хочу узнать как. Правильнее.
   bvb
 
10 - 29.05.19 - 10:11
(9)Использование ТЗ в УФ налагает ограничения на использование пиктограмм раскраски ячеек и отображения полей как текста.
Динамический в этом случае гибче
   falselight
 
11 - 29.05.19 - 10:13
(7) То есть нужно все программно создавать?
   falselight
 
12 - 29.05.19 - 10:14
(11+) Просто загрузить не получится?
   Mankubus
 
13 - 29.05.19 - 10:16
(11) да (12) не получится
   palsergeich
 
14 - 29.05.19 - 10:16
Нет правильного ответа.
Иногда правильно разместить ТЗ с динамическими колонками.
Иногда правильно ДС.
 (12) да
   fisher
 
15 - 29.05.19 - 10:17
(11) Колонки - да. Нужно пересоздавать программно и для таблицы как реквизита формы и для элемента формы, который ее отображает.
"Просто загрузить не получится?" - а что такое "просто загрузить"? Один раз пишешь это маленькой процедуркой и используешь на здоровье. Как по мне - это достаточно просто.
   palsergeich
 
16 - 29.05.19 - 10:20
Если количество таких случаев конечно и невелико то можно их все сверстать заранее и при помощи страниц отображать необходимую. Вполне жизнеспособный вариант.
   FIXXXL
 
17 - 29.05.19 - 10:24
   falselight
 
18 - 29.05.19 - 10:48
(15) То есть разбираться с методом что в (7) ?
   fisher
 
19 - 29.05.19 - 11:02
(18) Да что там разбираться-то, господи? Загляни еще в (17) - там те же яйца, вид сбоку.
   falselight
 
20 - 29.05.19 - 11:02
А если у таблицы сделать источник данных динамический список
то как туда значения параметров передавать?
   hhhh
 
21 - 29.05.19 - 11:10
(20) Параметры.Вставить("ИмяПараметра", ЗначениеПараметра);
   falselight
 
22 - 29.05.19 - 11:10
Ок, понял

    ТЗДляВыгрузки.Параметры.УстановитьЗначениеПараметра("НачДата", Период.ДатаНачала);    
    ТЗДляВыгрузки.Параметры.УстановитьЗначениеПараметра("КонДата", Период.ДатаОкончания);
   falselight
 
23 - 29.05.19 - 11:13
То есть открывая обработку с динамическим списком он всегда будет заполненным?
Иначе будет ругаться на незаполненные параметры?

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ТЗДляВыгрузки.Параметры.УстановитьЗначениеПараметра("НачДата", Период.ДатаНачала);    
    ТЗДляВыгрузки.Параметры.УстановитьЗначениеПараметра("КонДата", Период.ДатаОкончания);    
КонецПроцедуры
   falselight
 
24 - 29.05.19 - 11:22
В динамическом списке этот запрос, почему на форме таблица
с иной очередностью следования полей????


ВЫБРАТЬ
    ТоварыОрганизацийОбороты.Период КАК Период,
    ТоварыОрганизацийОбороты.Регистратор.Номер КАК РегистраторНомер,
    ТоварыОрганизацийОбороты.Регистратор КАК Регистратор,
    ТоварыОрганизацийОбороты.Организация КАК Организация,
    ТоварыОрганизацийОбороты.ВидЗапасов КАК ВидЗапасов,
    ТоварыОрганизацийОбороты.АналитикаУчетаНоменклатуры.Склад КАК Склад,
    ТоварыОрганизацийОбороты.АналитикаУчетаНоменклатуры.Ссылка КАК КлючАналитики,
    ТоварыОрганизацийОбороты.АналитикаУчетаНоменклатуры.Номенклатура КАК Номенклатура,
    ТоварыОрганизацийОбороты.АналитикаУчетаНоменклатуры.Характеристика КАК Характеристика,
    ТоварыОрганизацийОбороты.АналитикаУчетаНоменклатуры.Серия КАК Серия,
    ТоварыОрганизацийОбороты.КоличествоОборот КАК КоличествоОборот,
    ТоварыОрганизацийОбороты.КоличествоРасход КАК КоличествоРасход,
    ТоварыОрганизацийОбороты.НомерГТД КАК НомерГТД
ИЗ
    РегистрНакопления.ТоварыОрганизаций.Обороты(&НачДата, &КонДата, Регистратор, ) КАК ТоварыОрганизацийОбороты
ГДЕ
    ТоварыОрганизацийОбороты.Регистратор ССЫЛКА Документ.РеализацияТоваровУслуг

УПОРЯДОЧИТЬ ПО
    Период
   falselight
 
25 - 29.05.19 - 11:25
(24) Понял, это нужно в таблице устанавливать очередность колонок.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.