Вход | Регистрация
 

есть ли какая функция на БСП, для того чтобы получить ставку НДС в БП 3.0

есть ли какая функция на БСП, для того чтобы получить ставку НДС в БП 3.0
Я
   inkvizitr
 
29.05.19 - 09:15
подскажите как она называется и где располагается?
 
 
   Cyberhawk
 
1 - 29.05.19 - 09:16
Сам искал?
   inkvizitr
 
2 - 29.05.19 - 09:16
она называется Функция ПолучитьСтавкуНДС(СтавкаНДС, ПрименяютсяСтавки4и2 = Ложь) Экспорт в модуле УчетНДСКлиентПереопределяемый
   inkvizitr
 
3 - 29.05.19 - 09:17
да только начал
   inkvizitr
 
4 - 29.05.19 - 09:17
(2) вроде похожа
   inkvizitr
 
5 - 29.05.19 - 09:37
Функция ПолучитьСтавкуНДС(СтавкаНДС, ПрименяютсяСтавки4и2 = Ложь) оказалось не то, в карточке номенклатура указывается перечисления типа Общее и т. д. а мне нужно возвращать цифры в виде 20% и т. д.
   Aleksey
 
6 - 29.05.19 - 09:37
(5) смотри модуль перечисления
   inkvizitr
 
7 - 29.05.19 - 09:39
(6) щас гляну
   inkvizitr
 
8 - 29.05.19 - 09:39
(6) точно походу что надо
   kzot
 
9 - 29.05.19 - 09:40
(0) а скажи, что делает учет по НДС в БСП, где у тебя логика ?
   inkvizitr
 
10 - 29.05.19 - 09:44
(6) спасибо тебе огромное
   inkvizitr
 
11 - 29.05.19 - 09:44
(9) ты прав
   Айвонттубифри
 
12 - 29.05.19 - 10:19
(0) Функция СтавкаНДС(ВидСтавки, Период) Экспорт
    
    Если ВидСтавки = Перечисления.ВидыСтавокНДС.Общая Тогда
        Возврат УчетНДСКлиентСервер.ОбщаяСтавкаНДС(Период);
    ИначеЕсли ВидСтавки = Перечисления.ВидыСтавокНДС.ОбщаяРасчетная Тогда
        Возврат УчетНДСКлиентСервер.ОбщаяРасчетнаяСтавкаНДС(Период);
    ИначеЕсли ВидСтавки = Перечисления.ВидыСтавокНДС.Пониженная Тогда
        Возврат Перечисления.СтавкиНДС.НДС10;
    ИначеЕсли ВидСтавки = Перечисления.ВидыСтавокНДС.ПониженнаяРасчетная Тогда
        Возврат Перечисления.СтавкиНДС.НДС10_110;
    ИначеЕсли ВидСтавки = Перечисления.ВидыСтавокНДС.Нулевая Тогда
        Возврат Перечисления.СтавкиНДС.НДС0;
    ИначеЕсли ВидСтавки = Перечисления.ВидыСтавокНДС.БезНДС Тогда
        Возврат Перечисления.СтавкиНДС.БезНДС;
    Иначе
        Возврат Перечисления.СтавкиНДС.ПустаяСсылка();
    КонецЕсли;
    
КонецФункции
   Айвонттубифри
 
13 - 29.05.19 - 10:21
Еще вот так можно (смотря какая задача у вас стоит):

Функция ОбщаяСтавкаНДС(Период) Экспорт
    
    Если Период < '20190101' Тогда
        Возврат ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС18");
    Иначе
        Возврат ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС20");
    КонецЕсли;
    
КонецФункции
   Айвонттубифри
 
14 - 29.05.19 - 10:22
Ну и последний, третий вариант:

Объект.СтавкаНДС = ?(ТекущаяДата() >= Дата(2019, 1, 1), Перечисления.СтавкиНДС.НДС20, Перечисления.СтавкиНДС.НДС18);

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.