Вход | Регистрация
 

Не заполняются параметры печатной формы (программно)

Не заполняются параметры печатной формы (программно)
Я
   Programmer145
 
28.05.19 - 15:07
Вот такой вот код, {v8 Факторы} и {v8 ДопФакторы} параметры в печатной форме и они не заполняются в чем причина?
                Запрос = Новый Запрос;
        Запрос.Текст =     "ВЫБРАТЬ РАЗРЕШЕННЫЕ
                           |    КлассыУсловийТрудаПоДолжностямСрезПоследних.КлассУсловийТруда КАК КлассУсловийТруда
                           |ИЗ
                           |    РегистрСведений.КадроваяИсторияСотрудников.СрезПоследних(&Период, ) КАК КадроваяИсторияСотрудниковСрезПоследних
                           |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КлассыУсловийТрудаПоДолжностям.СрезПоследних(&Период, ) КАК КлассыУсловийТрудаПоДолжностямСрезПоследних
                           |        ПО (КлассыУсловийТрудаПоДолжностямСрезПоследних.Должность = КадроваяИсторияСотрудниковСрезПоследних.Должность)
                           |ГДЕ
                           |    КадроваяИсторияСотрудниковСрезПоследних.Сотрудник = &Сотрудник";
        
        Запрос.УстановитьПараметр("Сотрудник",ТекущийЭлемент);
        Запрос.УстановитьПараметр("Период",ДатаДокумента);
        
        РезультатЗапроса = Запрос.Выполнить();
        
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

        ДанныеОбъекта = Новый Структура;
        если ВыборкаДетальныеЗаписи.Следующий() тогда            
            ДанныеОбъекта.Вставить("Факторы", "    какие люди  " +
            строка(ВыборкаДетальныеЗаписи.КлассУсловийТруда));
            УсловияТрудаЗаполнены = Истина;
        иначе
            ДанныеОбъекта.Свойство("Факторы","");
            
            УсловияТрудаЗаполнены = Ложь;            
        КонецЕсли;
                ПереченьФакторов = ПЛ_КадровыйУчет.ПолучитьДопФакторыУсловийТруда(ТаблицаКД[0].Должность);
        ПерваяЗапись = 1;
        ДополнительныеФакторы = "";
        Для Каждого Фактор Из  ПереченьФакторов Цикл
            Если ПерваяЗапись Тогда
                ДополнительныеФакторы = ?(УсловияТрудаЗаполнены,Символы.ПС,"") + "привет" + Символы.ПС +
                "- " + НРег(Фактор.Ключ) + " – класс " + Фактор.Значение;
                ПерваяЗапись = 0;
            Иначе
                ДополнительныеФакторы = ДополнительныеФакторы + Символы.ПС + "- " + НРег(Фактор.Ключ) + " – класс " + Фактор.Значение;
            КонецЕсли;                  
        КонецЦикла;
        
        ДанныеОбъекта.Вставить("ДопФакторы",ДополнительныеФакторы);
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.