Вход | Регистрация
 

Выбранное значение в списке значений на форме

Выбранное значение в списке значений на форме
Я
   falselight
 
28.05.19 - 15:04
УФ. На форме расположен реквизит Список значений.
Установлен режим выбора из списка.
Как в коде получать выбранное значение в списке?
Как программно устанавливать выбранное значение?
 
 
   falselight
 
1 - 28.05.19 - 15:30
Кто нибудь работал со списком значений на форме.
   falselight
 
2 - 28.05.19 - 15:37
ХМ!
   falselight
 
3 - 28.05.19 - 15:45
Только так что ли???

Элементы.ТипВыбора.ТекстРедактирования
   falselight
 
4 - 28.05.19 - 16:26
Up!
   falselight
 
5 - 28.05.19 - 16:32
Как при открытии мне туда установить значение?
При открытии обработки.
    ТипВыбора = ТипВыбора[1];
   RomanYS
 
6 - 28.05.19 - 16:34
(0) Ничего не понятно. У тебя поле со списком выбора или список выведен на форму?
   Скиурус
 
7 - 28.05.19 - 16:36
Для Каждого Эл Из МойСписокЗначений Цикл
  Если Эл.Пометка Тогда
    Сообщить(Эл.Значение);
  КонецЕсли;
КонецЦикла;
   falselight
 
8 - 28.05.19 - 16:41
(6) На форме обработке реквизит типа список значений.
Стоит галка РежимВыбораИзСписка

Я хочу при открытии обработки задать ему значение.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ДиалогВыбораКаталога = "<<<Путь к каталогу>>>"; 
    ДиалогВыбораФайла    = "<<<Путь к файлу>>>";
    // 

    //ТипВыбора.Добавить("Каталог");

    //ТипВыбора.Добавить("Файл");

    //

    Элементы.ТипВыбора.СписокВыбора.Добавить("Каталог","Каталог");
    Элементы.ТипВыбора.СписокВыбора.Добавить("Файл",   "Файл");
    
    //

    ФорматВыбираемогоФайла.Добавить("Таблицы dbf(*.dbf)|*.dbf|");
    ФорматВыбираемогоФайла.Добавить("Текстовый файл (*.txt)|*.txt|");
    ФорматВыбираемогоФайла.Добавить("Документ Excel (*.xls, *.xlsx)|*.xls;*.xlsx|");
    ФорматВыбираемогоФайла.Добавить("Табличный документ(*.xls);Табличный документ(*.xlsx)|*.xls;*.xlsx");
    //

    ТипВыбора = ТипВыбора[1];
    ТипВыбора = Элементы.ТипВыбора.СписокВыбора[1];
    Элементы.ТипВыбора = Элементы.ТипВыбора.СписокВыбора[1];
КонецПроцедуры
//
   falselight
 
9 - 28.05.19 - 16:42
Как что бы при открытии в списке ТипВыбора стояло значение ?
   falselight
 
10 - 28.05.19 - 16:48
так не получается

    ТипВыбора = Элементы.ТипВыбора.СписокВыбора[1].Представление;
КонецПроцедуры
   falselight
 
11 - 28.05.19 - 16:52
вот так работает!
    ТипВыбора = Элементы.ТипВыбора.СписокВыбора[1].Значение;
   RomanYS
 
12 - 28.05.19 - 16:52
(8) У тебя реквизит типа СЗ. Соответственно в каждом значении списка выбора должен быть СЗ.

Скорей всего тебе нужно поле ввода с простым значением (не СЗ) и списком выбора.
   falselight
 
13 - 28.05.19 - 17:00
почему в списках значения по 2 раза?
ТипВыбора
ФорматВыбираемогоФайла


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ДиалогВыбораКаталога = "<<<Путь к каталогу>>>"; 
    ДиалогВыбораФайла    = "<<<Путь к файлу>>>";
    // 

    Элементы.ТипВыбора.СписокВыбора.Добавить("Каталог","Каталог");
    Элементы.ТипВыбора.СписокВыбора.Добавить("Файл",   "Файл");
    //

    Элементы.ФорматВыбираемогоФайла.СписокВыбора.Добавить("Таблицы dbf(*.dbf)|*.dbf|");
    Элементы.ФорматВыбираемогоФайла.СписокВыбора.Добавить("Текстовый файл (*.txt)|*.txt|");
    Элементы.ФорматВыбираемогоФайла.СписокВыбора.Добавить("Текстовый файл (*.csv)|*.csv|");
    Элементы.ФорматВыбираемогоФайла.СписокВыбора.Добавить("Документ Excel (*.xls, *.xlsx)|*.xls;*.xlsx|");
    Элементы.ФорматВыбираемогоФайла.СписокВыбора.Добавить("Табличный документ(*.xls);Табличный документ(*.xlsx)|*.xls;*.xlsx");
    //

    ТипВыбора                                     = Элементы.ТипВыбора.СписокВыбора[1].Значение;
    ФорматВыбираемогоФайла                        = Элементы.ФорматВыбираемогоФайла.СписокВыбора[1].Значение;
    Элементы.ФорматВыбираемогоФайла.Доступность = Истина;
КонецПроцедуры
//
   falselight
 
14 - 28.05.19 - 17:01
(12) В каждом значении списка выбора должен быть список значений?
   RomanYS
 
15 - 28.05.19 - 17:03
(14) Да. Только зачем тебе реквизит-СЗ не понятно совсем.
   RomanYS
 
16 - 28.05.19 - 17:04
(15)
Реквизит-СЗ и реквизит со списком выбора это две большие разницы
   falselight
 
17 - 28.05.19 - 17:15
(15) Да просто из списка на форме хочу выбрать значения.
Из выпадающего списка.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.