Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ПриОкончанииРедактирования

ПриОкончанииРедактирования
Я
   Vitev777
 
26.05.19 - 15:17
Вопрос такой я ученик, делаю большую сам работу где условие такое, есть документ продажа товаров на его основании если сумма дока больше 1000 делаем заявку на дранспорт документ, и  вывести сообщение "возможна бесплатная доставка". Я сделал с помощью ПриОкончанииРедактирования форма дока продажа товаров в таб части товары. код такой:
&НаКлиенте
Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
        Если Объект.СуммаДокумента > 1000 Тогда
      ПоказатьПредупреждение(, "Возможна бесплатная доставка", 10,);
   КонецЕсли;
    
КонецПроцедуры


Сообщение выводит, но почему-то только при редактировании документа готового уже проведенного, а при создании нового даже когда проводиш нет этого сообщения.
Может как-то сделать чтоб сумма дока пересчитывалась еще при создании документа, тогда и сработает событие.
Есть идеи?
 
 
   palsergeich
 
1 - 26.05.19 - 15:19
(0) Скорее всего потому что при изменении строки сумма документа не пересчитывается
   palsergeich
 
2 - 26.05.19 - 15:20
(0) Объект.СуммаДокумента Вот эта штука сама себя при редактировании строки не заполнит.
   palsergeich
 
3 - 26.05.19 - 15:21
(0)
Должно быть так:
&НаКлиенте
Процедура ТоварыПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования) 
     Объект.СуммаДокумента = объект.Товары.Итог("Сумма");   
Если Объект.СуммаДокумента > 1000 Тогда 
ПоказатьПредупреждение(, "Возможна бесплатная доставка", 10,); 
КонецЕсли;
   Vitev777
 
4 - 26.05.19 - 15:30
palsergeich Спасибо да действительно так, с готовым при редактировании работало так как уже было заполнено, а с новым нет пусто. Спасибо еще раз, буду дальше потеть)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.