Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обращение к реквизиту ТЧ

Обращение к реквизиту ТЧ
Я
   Nzzzz
 
23.05.19 - 15:29
Как обратиться к реквизиту ТЧ? Есть документ, в нем ТЧ: Сотрудники, вот в Этой ТЧ реквизиты, мне нужен реквизит Подразделение
Обычные формы ЗУП
 
 
   FIXXXL
 
1 - 23.05.19 - 15:37
(0) для начала нужна строкаТЧ
   kda26
 
2 - 23.05.19 - 15:39
   Nzzzz
 
3 - 23.05.19 - 15:46
(1) а я хотел : Подразделение = СсылкаНаОбъект.
   Nzzzz
 
4 - 23.05.19 - 15:52
Так и не понятно ничего
   memogolik
 
5 - 23.05.19 - 15:56
Для Каждого Врем ИЗ Док.ТЧ Цикл
 Перем = Врем.РеквизитТЧ;
КонецЦикла
   Nzzzz
 
6 - 23.05.19 - 16:01
(5) ТЧ не обнаружена пишет
Не видит он мою ТЧ Сотрудники
   memogolik
 
7 - 23.05.19 - 16:04
Ну если в документе ТЧ называется Сотрудники, то
//Док - ваш документ


Для Каждого Врем ИЗ Док.Сотрудники Цикл
 ЗначениеПодразделенияСтрокиДокумента = Врем.Подразделение;
КонецЦикла
   Nzzzz
 
8 - 23.05.19 - 16:13
(7) так же:Поле объекта не обнаружено (Сотрудники)
   ColonelAp4u
 
9 - 23.05.19 - 16:27
(8) а ваша тч сотрудники чисто на форме? в самом объекте есть такая тч?
   Nzzzz
 
10 - 23.05.19 - 16:37
(9) В самом объекте есть ТЧ работники организаций и там есть подразделение
   Nzzzz
 
11 - 23.05.19 - 16:40
Подразделение = СсылкаНаОбъект.РаботникиОрганизации.Подразделение;
не находит подраздление, ТЧ РаботникиОрганизации понимает,а подразделение поле не обнаружено
   Rie
 
12 - 23.05.19 - 16:41
(11) Естественно, не понимает! К какой _строке_ табличной части Вы обращаетесь?
(Табличная часть состоит из _строк табличной части_. И реквизит Подразделение есть у _строки_, а не у табличной части в целом).
   Nzzzz
 
13 - 23.05.19 - 16:43
(12) Да были бы упр формы, было бы легче. Обычные вообще не понимаю
   Nzzzz
 
14 - 23.05.19 - 16:47
(12) По индексу что ли как то надо сделать?
   ColonelAp4u
 
15 - 23.05.19 - 16:47
(13) дело в том что если реквизит будь то подразделение или работник или сумма какая нибудь находится в тч документа, то хоть оф хоть уф обращаться к данным реквизитам придется одинаково через строку табличной части.
   ColonelAp4u
 
16 - 23.05.19 - 16:48
или индекс, но это бред.
   Eg0rkas
 
17 - 23.05.19 - 16:50
Может так:
Для каждого Стр из СсылкаНаОбъект.РаботникиОрганизации Цикл
Подразделение = Стр.Подразделение;
КонецЦикла;
   Nzzzz
 
18 - 23.05.19 - 16:52
(17) Поле объекта не обнаружено (Подразделение)
   kda26
 
19 - 23.05.19 - 16:55
Так ТЧ Сотрудники или РаботникиОрганизации?
   kda26
 
20 - 23.05.19 - 16:57
Отладчиком посмотри в ПриВыводеСтроки() что у тебя в Текущих данных.
   Eg0rkas
 
21 - 23.05.19 - 16:58
Или напиши, как называются реквизиты ТЧ
   Nzzzz
 
22 - 23.05.19 - 16:59
(19) На форме есть 2 закладки. Одна из них сотрудники, в ней колонка подразделение
   kda26
 
23 - 23.05.19 - 17:01
(22) И что с ней нужно сделать?
   Nzzzz
 
24 - 24.05.19 - 11:24
(23) Обратиться к подразделению
   Nzzzz
 
25 - 24.05.19 - 11:33
Народ помогите
   Nzzzz
 
26 - 24.05.19 - 11:34
Мне нужно обратиться к подразделению, чтобы узнать изменилось оно у данного сотрудника, если да, то будут выполняться некие условия


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.