Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос по конвертации(Строка в перечисление)

Вопрос по конвертации(Строка в перечисление)
Я
   serg-lom89
 
23.05.19 - 09:07
Добрый день
Столкнулся с конвертацией.
В базе источник есть документ РТУ и базе приемник есть РТУ.
В базе источник у документа есть реквизит -Тип составной(строка,перечисление).
в базе приемник -тип (перечисление).

Вопрос
Как мне и ГДЕ прописать что если у базы источника в документе у реквизита тип строка и какое то значение тогда будет такое перечисление в базе приемник

Если РеквизитИсточник= "ТТ" Тогда
РеквизитПриемник = перечисление.мое.Значение1;
КонецЕсли;
 
 
   Aleksey
 
1 - 23.05.19 - 09:09
Значение = "Значение1";
   serg-lom89
 
2 - 23.05.19 - 09:17
(1) а где это прописывается?
https://ibb.co/XStr5Qq прописал тут..при загрузке ругается
   serg-lom89
 
3 - 23.05.19 - 09:18
текст ошибки


Ошибка при загрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(638)}: Поле объекта не обнаружено (ТТ)
   olegves
 
4 - 23.05.19 - 09:20
(0) ПередЗагрузкой для твоего документа проверяй типЗнч
   serg-lom89
 
5 - 23.05.19 - 09:25
(4)
проверил я сразу на значение
Если Источник.ТипБСО = "ТТ" Тогда
    Значение = перечисления.SW_ТипыБСО.ТН_2    ;
КонецЕсли;

Все равно ошибка
   Йохохо
 
6 - 23.05.19 - 09:31
(5) этот код исполняется в источнике, Значение = "SW_ТипыБСО.ТН_2", вроде так
   Йохохо
 
7 - 23.05.19 - 09:31
Значение = "ТН_2"
   serg-lom89
 
8 - 23.05.19 - 09:32
(7) а где это прописывать то ,передЗагрузкой моего документа?
   olegves
 
9 - 23.05.19 - 09:33
(8) КД2
   Йохохо
 
10 - 23.05.19 - 09:42
(8) при выгрузке, что то Вы мудрите
   Жан Пердежон
 
11 - 23.05.19 - 11:29
(8) в источнике - это там, где выгрузка идет
   serg-lom89
 
12 - 23.05.19 - 11:45
решено

в конвертации свойств указал такой код в процедуре переВыгрузкой
Если Источник.ТипБСО = "ТН" Тогда
    
    Значение = перечисления.SW_ТипыБСО.ТН_2;
    
ИначеЕсли Источник.ТипБСО = "ТТН" Тогда
    
    Значение = перечисления.SW_ТипыБСО.ТТН_1;
    
КонецЕсли;
   mikecool
 
13 - 23.05.19 - 11:47
(12) а если тип источника будет перечисление?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.