Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Теряется фокус модального окна в УФ

Теряется фокус модального окна в УФ
Я
   егаис
 
23.05.19 - 07:47
Розница 2.2 Для документа Реализация создал метод авторизации продавца.

    Если Объект.Ссылка.Пустая() Тогда //новый документ
        //вызов системы авторизации для рабочего места с признаком РМК
        Если РабочееМестоЯвляетсяРМК Тогда
            ОткрытьФорму("Документ.РеализацияТоваров.Форма.ФормаВводаШК",,,,,,
                Новый ОписаниеОповещения("ПослеВводаШК", ЭтотОбъект),
                РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
        КонецЕсли;    
    КонецЕсли;    

Код размещен в конце Процедуры ПриОткрытии()
Окно открывается, но почему-то фокус уходит на документ, как решить, подскажите, плиз
 
 
   RomaH
 
1 - 23.05.19 - 07:52
только просмотр на владаельца и обработчик ожидания по которому открывать форму авторизации ПОСЛЕ открытия владельца
   егаис
 
2 - 23.05.19 - 08:05
(1) не совсем понял
Что значит ПОСЛЕ открытия владельца?
   Сияющий в темноте
 
3 - 23.05.19 - 08:22
В рознице и в типовой такая фигня есть-уходит фокус с модального окна.
Форма,активизировать должно спасти в обработке ожидания(если вводдоступен проверить)
   егаис
 
4 - 23.05.19 - 08:23
&НаКлиенте
Процедура ПриОткрытии(Отказ)
...
мояпроцедура()
КонецПроцедуры

&НаКлиенте
Процедура мояпроцедура(Отказ)
   Если Объект.Ссылка.Пустая() Тогда//новый документ 

        //вызов системы авторизации для рабочего места с признаком РМК 

        Если РабочееМестоЯвляетсяРМК Тогда 
            ОткрытьФорму("Документ.РеализацияТоваров.Форма.ФормаВводаШК",,,,,, 
                Новый ОписаниеОповещения("ПослеВводаШК", ЭтотОбъект), 
                РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс); 
        КонецЕсли;     
    КонецЕсли;  
КонецПроцедуры


ничего не меняет
   RomaH
 
5 - 23.05.19 - 08:54
При открытии - работает ДО открытия формы

ты ДО открытия формы (до конца процедуры) открываешь другую форму

другая форма открылась - потом открывается основная форма ...
платформа в шоке - блокировать владельца, но владелец еще не открыт

открывай после открытия - в при открытии - обработчик ожидания запусти

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.