Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не работает подбор, не добавляются записи в таблицу документа

Не работает подбор, не добавляются записи в таблицу документа
Я
   antipod13
 
23.05.19 - 07:08
В форме подбора все работает, после нажатия кнопки перенести в документ, форма закрывается, но ничего не переноситься.

Код команды переноса

&НаКлиенте
Процедура ПеренестиВДокумент(Команда)
     // Передаем в родительский элемент формы "Товары" данные выбора - таблицу "Подобранные товары"
     ОповеститьОВыборе(ПодобранныеТовары);
КонецПроцедуры

Код свойства формы документа ОбработкаВыбора

Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
     // Заполняем таблицу документа подобранными товарами
     Для Каждого Стр Из ВыбранноеЗначение Цикл
             РезультатПоиска = Объект.Товары.НайтиСтроки(Новый Структура("Товар", Стр.Товар));
             Если РезультатПоиска.Количество() = 0 Тогда
                   НовСтр = Объект.Товары.Добавить();
                   НовСтр.Товар = Стр.Товар;
             Иначе
                   НовСтр = РезультатПоиска[0];
             КонецЕсли;
             НовСтр.Количество = НовСтр.Количество + Стр.Количество;
             НовСтр.Сумма = НовСтр.Сумма + Стр.Сумма;
       КонецЦикла;
КонецПроцедуры

Все вроде правильно.
 
 
   shuhard
 
1 - 23.05.19 - 07:18
(0)[ перенести в документ, форма закрывается, но ничего не переноситься.]
дык позырь отладчиком чё в Объект.Товары в конце цикла
   antipod13
 
2 - 23.05.19 - 07:24
событие ОбработкаВыбора не наступает
   antipod13
 
3 - 23.05.19 - 07:40
Код открытия формы

ОткрытьФорму("Справочник.Товары.Форма.ФормаПодбора", , Элементы.Товары, УникальныйИдентификатор);
   antipod13
 
4 - 23.05.19 - 07:58
Разобрался, не у того объекта обработчик прописал, написал у формы, а надо было у списка

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.