Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запуск начальной страницы с изменением внешн. вида (состав), от роли, ошибка.

Запуск начальной страницы с изменением внешн. вида (состав), от роли, ошибка.
Я
   SkillUp
 
22.05.19 - 13:04
Изменяю, перед запуском системы, внешний вид(состав) начальной страницы... Не пойму, из-за чего не срабатывает...

Ошибка: Ошибка инициализации модуля: МодульУправляемогоПриложения
по причине:
{МодульУправляемогоПриложения(109,31)}: Тип не определен (НастройкиНачальнойСтраницы)
            ВременныеНастройки = Новый <<?>>НастройкиНачальнойСтраницы;

УФ

Процедура ПередНачаломРаботыСистемы(Отказ)
    
    Если ДопМодульДоработки.ПроверкаРоли("РольИнтрфейсПеремещение") Тогда
        СоставФорм = ПользовательскаяНастройкаНС.ПолучитьСоставФорм();
        СоставФорм.ЛеваяКолонка.Очистить();
        СоставФорм.ЛеваяКолонка.Добавить("Документ.ПеремещениеТоваров.Форма.ФормаСпискаУправляемая");
        
        ВременныеНастройки = ХранилищеСистемныхНастроек.Загрузить("Общее/НастройкиНачальнойСтраницы");
        Если ВременныеНастройки = Неопределено Тогда
            ВременныеНастройки = Новый НастройкиНачальнойСтраницы;
        КонецЕсли;
        ВременныеНастройки.УстановитьСоставФорм(СоставФорм);
        
        ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы", , ВременныеНастройки)    
    КонецЕсли;
    
КонецПроцедуры
 
 
   SkillUp
 
1 - 22.05.19 - 14:46
Все, разобрался, всем СПАСИБО!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.