Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

в 1С версия ФФД 1.0 в ККТ версия ФФД 1.05

в 1С версия ФФД 1.0 в ККТ версия ФФД 1.05
Я
   Vovhik
 
21.05.19 - 10:05
Всем доброго времени суток. Ситуация следующая, при печати тестового чека из самого ККТ и в программах по настройке ККТ версия ФФД 1.05, при печати чека из 1С в окне предпросмотра показывает версию ФФД 1.0 и соответственно не печатает признаки способа расчета и остальные необходимые реквизиты для формата ФФД 1.05. Может кто нибудь подсказать куда копать?

Конфа КА 2, ККТ Атол 30Ф.
 
 
   Garykom
 
1 - 21.05.19 - 10:08
>при печати чека из 1С в окне предпросмотра показывает версию ФФД 1.0

Покажи картинку что это еще за "окне предпросмотра"
   garantNo4x
 
2 - 21.05.19 - 10:11
да, ладно ...1с формат из кассы получает.
   Vovhik
 
3 - 21.05.19 - 10:12
   Vovhik
 
4 - 21.05.19 - 10:13
   garantNo4x
 
5 - 21.05.19 - 10:14
а можно скрин того что на кассе установлен 1.05
   Vovhik
 
6 - 21.05.19 - 10:20
   Garykom
 
7 - 21.05.19 - 10:20
(4) Из тест драйвера попробуйте пробить чек с признаком и способом расчета
   Garykom
 
8 - 21.05.19 - 10:21
Имхается что БПО старая в старой КА
   Vovhik
 
9 - 21.05.19 - 10:33
(7) Признак способа расчета печатает, а вот в случае предоплаты, сумму неправильно печатает, но возможно я что то не так делаю
(8) Как можно проверить?
   Garykom
 
10 - 21.05.19 - 10:34
(9) Посмотреть какая у вас версия КА и сравнить с актуальной, как давно обновлялись?
   garantNo4x
 
11 - 21.05.19 - 10:35
печатает он то что в таблице перед глазами.
   Vovhik
 
12 - 21.05.19 - 10:40
(10) у нас версия 2.4.6.189 от 27.12.2018, последняя версия 2.4.7.151 от 25.04.2019. Впринципе не такая и старая.
   garantNo4x
 
13 - 21.05.19 - 10:41
посмотрел по коду - он там конечно очень заумный .. но так или иначе на самой настройке кассы имеет смысл еще проверить ..
а так там только.
   garantNo4x
 
14 - 21.05.19 - 10:43
Если ТипЗнч(ПодключенноеОборудование.ККТ) = Тип("Массив") Тогда
        
        Для Каждого ЭлементМассива Из ПодключенноеОборудование.ККТ Цикл
            
            ОборудованиеККТ = ЭлементМассива;
            ВерсияФФД = ДобавитьВТаблицуОборудования(ОборудованиеККТ);
            
        КонецЦикла;
        
        Элементы.ККТ.ТолькоПросмотр = (Элементы.ККТ.СписокВыбора.Количество() = 1);
        
    Иначе
        
        ОборудованиеККТ = ПодключенноеОборудование.ККТ;
        ВерсияФФД = ДобавитьВТаблицуОборудования(ОборудованиеККТ);
        
    КонецЕсли;

вот так он ее актуализирует .. и есть подохрение что если есть касса с ф 1.0 то  .. она может выскочить
   garantNo4x
 
15 - 21.05.19 - 10:45
а внутри есть вот такой код 

Если ПараметрыРегистрацииУстройства.ЕстьДанные Тогда
            ЗначениеВерсияФФД = ПараметрыРегистрацииУстройства.ВерсияФФДККТ;
        Иначе
            ЗначениеВерсияФФД = ВерсияФФДПоУмолчанию();
        КонецЕсли;

а версия по умолчанию это 1.0 
а вот что такое . ЕстьДанные ХЗ
   Vovhik
 
16 - 21.05.19 - 10:46
(14) Ну это уже что то, может стоит попробовать сменить версию по умолчанию на 1.05?
   Vovhik
 
17 - 21.05.19 - 10:48
(13) Сейчас еще покопаю драйвер, но в настройках при считывании с устройства  показывает версию 1.05
   garantNo4x
 
18 - 21.05.19 - 10:48
не, это как раз не надо делать .. надо найти почему она решает упасть на нее а не на конкретное оборудование
ПараметрыРегистрацииУстройства.ЕстьДанные  я не знаю что вот это такое
и не очень понимаю что будет если у вас там несколько касс
   Vovhik
 
19 - 21.05.19 - 10:52
(18) Касс несколько, все работают с ФФД 1.05, в данный момент к 1С не подключены, моя задача как раз и стоит их заставить работать из 1С.
   garantNo4x
 
20 - 21.05.19 - 10:57
Ну настройка то подключения в оборудовании ведь есть ? Я так поникаю что она оттуда тянет .. впрочем может она снюхивается с оборудованием и что-то не получает от него .. но тогда насколько я помню не открылась бы вся эта чухня просмотра чека.
Нет ли в настройках кассы в ФФД 1.0 ?
   Vovhik
 
21 - 21.05.19 - 10:59
(20) Нашел константу которая разрешает в окне предпросмотра выбирать версию ФФД, при выборе версии, ругается что ККТ не поддерживает 1.05, похоже все таки проблема в драйвере. Покапаю драйвер, как найду что нибудь, отпишусь.
   garantNo4x
 
22 - 21.05.19 - 11:22
драйвер вообще то 10 0 должен быть .. иначе тоска будет .. впрочем я гоню лажу на 9 0, но у нас на эти кассы все болт положили и я в том числе.
   garantNo4x
 
23 - 21.05.19 - 11:23
Жду когда придут и оштрафуют ) Мстительно надеюсь что всех включая самого главного.
   bolero
 
24 - 21.05.19 - 12:01
(23) я тут давече заходил в один ФГУП услуги оплатить. Карточку приложил - мне выдают слип по операции по карте, а кассовый чек - хрен. Я говорю - кассовый чек гони с регистрационным номером ККТ, одного слипа по 54-ФЗ недостаточно. Мне ж потом "квитанцию об оплате" в разные заинтересованные места предъявлять. В ответ круглейшие глаза, и бормотание "кассовых у нас нет, щас я тебе товарный чек нарисую". На услугу, ага. Товарный чек. ну-ну.

Короче, чтобы штрафанули, я пока не знаю, что надо делать. Придти в налоговую и начать там пирожками в коридоре торговать не с тем ФФД.
   garantNo4x
 
25 - 21.05.19 - 12:05
(24) ну, да .. но я верю в чудо , и карательные отряды в июле ))
   Vovhik
 
26 - 21.05.19 - 12:29
(23)(24)(25) Весело))))
(21) В итоге при печати чека из ПКО ругается на не ту версию, но печатает правильный чек со всеми реквизитами, что очень хорошо(подозреваю что дело в том что ККТ не зарегестрирован в ФНС, именно этот аппарат использую для тестов). Есть мысль попробовать уже зарегестрированный ККТ зацепить к 1С и распечатать реальный чек(думаю ругаться не будет). Ну а так как печать чеков будет вызываться из полностью не типового функционала, то думаю необходимые параметры при вызове окна предпросмотра будет не проблема добавить.
Всем спасибо за помощь и потраченное время, особенно garantNo4x. Если будут новые нюансы обязательно отпишусь.
   garantNo4x
 
27 - 21.05.19 - 12:31
скорее всего .. лет


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.