Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Расширения. Отладчик не заходит в модуль объекта &Перед

Расширения. Отладчик не заходит в модуль объекта &Перед
Я
   AlvlSpb
 
20.05.19 - 22:39
Сделал расширение. Надо кое-что поправить в модуле объекта ОбработкаПроверкиЗаполнения
&Перед("ОбработкаПроверкиЗаполнения")
Процедура РасшЗНП_ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
Не заходит, хоть застрелись. Платформа 8.3.13.1806 и 8.3.14.1630 одинаковый результат
Есть мысли в чем может быть дело?
 
 
   palsergeich
 
1 - 20.05.19 - 22:41
1) чисти кеш.
2) Адаптация должна быть одна на конфу
   palsergeich
 
2 - 20.05.19 - 22:41
3) А сама обработка заполнения основная работает?
   Фрэнки
 
3 - 20.05.19 - 22:44
тс хочет сказать, что ОбработкаПроверкиЗаполнения работает и он это видит в отладчике, а &Перед("ОбработкаПроверкиЗаполнения") никак не срабатывает?
   palsergeich
 
4 - 20.05.19 - 22:46
(3) Ну первое что я в таком случае делаю - удаляю базу из списка и добавляю снова.
в 90% помогает.
Остальные 10% - косячный код в расширении и его неприменение
   AlvlSpb
 
5 - 20.05.19 - 22:50
(1) кэш чистил, Адаптация в ед числе 
(2) Работает
(3) Да. Именно так В стандартный обработчик заходит в Перед никак
   palsergeich
 
6 - 20.05.19 - 22:52
(5) безопасный режим и тд поснимал?
закомментируй свой код и напиши а=1; и посмотри, остановится или нет
   palsergeich
 
7 - 20.05.19 - 22:54
режим совместимости обработки и расширения совпадает? В пользовательском режиме расширение отображается как активное?
   AlvlSpb
 
8 - 20.05.19 - 22:56
(6) Безопасный режим снят изначально, код именно такой а = 0; с точкой останова
Расширения активны в пользовательском режиме
   AlvlSpb
 
9 - 20.05.19 - 22:57
(1) Вопрос. Почему Адаптация только одна возможна? Нишде не читал об этом. В конфе 5 расширений 1 Адаптация, 1 Исправление и три Дополнение. Может это как-то влиять? Та что глючит - дополнение
   palsergeich
 
10 - 20.05.19 - 22:57
(8) Хотел бы помочь, но я с таким не сталкивался.
   AlvlSpb
 
11 - 20.05.19 - 23:00
(10) Сам н сталкивался. Написано десятков 7-8 расширений. Задолбался с этим
   palsergeich
 
12 - 20.05.19 - 23:05
(11) А только отладчик не отрабатывает или вообще не работает, попробуй через запись в ЖР глянь чокак
   Фрэнки
 
13 - 20.05.19 - 23:06
У меня не настолько много одновременных расширений. Я стараюсь не злоупотреблять их количеством - сворачиваю в одно.
   AlvlSpb
 
14 - 20.05.19 - 23:11
(12) Нет. Эта часть точно не отрабатывает
(13) Оч много изменений в конфе. Все перевожу на расширения. В одно запихнуть - неверно. Делю по подсистемам.
   AlvlSpb
 
15 - 20.05.19 - 23:14
(13) )) Нет в одной конфе всего 5 расширений. )))
   AlvlSpb
 
16 - 20.05.19 - 23:18
Проверил. Переписал Перед на После. Тоже не заходит. Честно, ничего не понимаю
   palsergeich
 
17 - 20.05.19 - 23:25
(16) Может быть все таки в расширении косяку и оно в момент выполнения отключается и перестает приниматься в этом сеансе?
Сделай прям новое только на этот обработчик
   AlvlSpb
 
18 - 20.05.19 - 23:29
(17) Попробую. Пока удалил все расширения кроме этого. Не заходит
   palsergeich
 
19 - 20.05.19 - 23:31
(18) Ну оно и понятно, что проблема в нем, только где?
   ГдеСобакаЗарыта
 
20 - 20.05.19 - 23:38
Добавлял через кнопку процедуры или руками? Если кнопку процедуры нажать там типовая в доступных есть?
   Aleksandr N
 
21 - 20.05.19 - 23:41
(0) в другие модули расширения заходит отладка?
   AlvlSpb
 
22 - 20.05.19 - 23:45
(21) Это УНФ. В расширении два дока ЗаказНаПроизводство и Сборка. В Сборку в модуль объекта заходит без проблем, а вот в ЗаказНаПроизводство похоже не идет в модуль объекта. Сейчас пооверяю. пока не уверен
   Aleksandr N
 
23 - 20.05.19 - 23:46
(22) попробуйте 13-й пост отсюда:
8.3.6+ Отладка расширений
   AlvlSpb
 
24 - 20.05.19 - 23:51
(23) Спасибо, но именно так и делаю с самого начала
   Aleksandr N
 
25 - 20.05.19 - 23:53
(24) отладка на сервере включена?
   Aleksandr N
 
26 - 20.05.19 - 23:54
(25) извините, тупой вопрос. в 22-м посте же было. у меня больше идей нет.
   palsergeich
 
27 - 21.05.19 - 00:02
(22) Ты новое расширение только для этой штуки создал?
Остальные отключил?
Все равно проблемы?
   AlvlSpb
 
28 - 21.05.19 - 00:04
(27) Там два документа, но изменений много. Доп таблица, доб расчеты, оприходование обрезков и много еще чего
   AlvlSpb
 
29 - 21.05.19 - 00:07
(27) Нашел!!! Удалил Заказ на производство из расширения и снова добавил. Теперь заходит. Но почему рабочее расширение (а оно работало, именно это расширение) вдруг накрылось?
   palsergeich
 
30 - 21.05.19 - 00:08
(29) Ну какой нибудь кеш, как обычно)
 
 
   AlvlSpb
 
31 - 21.05.19 - 01:12
(30) В том-то и дело, что не кэш. И чистил кэш и удалял базу и снова добавлял. Не помогало
   seevkik
 
32 - 21.05.19 - 09:30
(31) Серверная?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.