Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ККТ не пробивает ПКО

ККТ не пробивает ПКО
Я
   John83
 
19.05.19 - 15:13
УТ 11.4
АТОЛ 30Ф
Пробовал и 9ые и 10ые дрова.
Обычный чек нормально пробивает, а на ПКО пишет

{Справочник.ПодключаемоеОборудование.МодульМенеджера(70)}: Cannot convert value to Boolean
            РезультатОперации.ПризнакАвтономногоРежима = Булево(ДанныеХранения.ПризнакАвтономногоРежима);
Куда копать? Чего смотреть?
 
 
   John83
 
1 - 19.05.19 - 15:19
до этого была win7 и проблем не знали, а тут решили win10 поставить
   Garykom
 
2 - 19.05.19 - 15:25
Что такое "ДанныеХранения" ? Может как обычно в ТЧ строчки не хватает?
   Garykom
 
3 - 19.05.19 - 15:31
Ыыы косячники

        Если ДанныеХранения.Свойство("ПризнакАвтономногоРежима") И НЕ ПустаяСтрока(ДанныеХранения.ПризнакАвтономногоРежима) Тогда
            РезультатОперации.ПризнакАвтономногоРежима = Булево(ДанныеХранения.ПризнакАвтономногоРежима); 
        КонецЕсли;
        Если ДанныеХранения.Свойство("ПризнакШифрованиеДанных") И НЕ ПустаяСтрока(ДанныеХранения.ПризнакШифрованиеДанных) Тогда
            РезультатОперации.ПризнакШифрованиеДанных = Булево(ДанныеХранения.ПризнакШифрованиеДанных); 
        КонецЕсли;
        Если ДанныеХранения.Свойство("ПризнакРасчетовЗаУслуги") И НЕ ПустаяСтрока(ДанныеХранения.ПризнакРасчетовЗаУслуги) Тогда
            РезультатОперации.ПризнакАвтономногоРежима = Булево(ДанныеХранения.ПризнакАвтономногоРежима); 
        КонецЕсли;
   Garykom
 
4 - 19.05.19 - 15:34
Справочник.ПодключаемоеОборудование.ПараметрыРегистрации

Шерсти "Справочник.ПодключаемоеОборудование", сделай туды в ТЧ "ПараметрыРегистрации" строчку с "НаименованиеПараметра" = "ПризнакАвтономногоРежима" со "ЗначениеПараметра" = "0" или нечто вроде
   Garykom
 
5 - 19.05.19 - 15:35
Ну или конфу правь на ошибку или пиши в саппорт и жди ответа
   John83
 
6 - 19.05.19 - 15:55
(5) это можно попробовать, вот только совсем непонятно, почему на другом компе с 7кой, все замечательно работает?
   John83
 
7 - 19.05.19 - 15:56
+6 с такой же кассой
   Garykom
 
8 - 19.05.19 - 16:04
(6) А ты глянь справочник ПодключаемоеОборудование то ))
   Garykom
 
9 - 19.05.19 - 16:06
Спорим что там оборудование на новой версии уже конфы создавали, а тут ты старую настройку подцепил.

Короче когда то все нужные строчки-параметры автоматом не создавались при добавлении оборудования и глюки.

В Розница 2 тоже самое
   John83
 
10 - 19.05.19 - 16:17
(9) ладно, попробую
спасибо!
   John83
 
11 - 20.05.19 - 09:25
в итоге админ установил какие-то дрова USB2Serial и все заработало без изменения конфы
   John83
 
12 - 20.05.19 - 09:35
правда ошибка все равно появляется, но при этом норм работает
пока оставлю так
   ObmanOZ
 
13 - 09.06.19 - 15:19
(12) Добрый день! Сегодня столкнулся с такой же ошибкой, подскажите, нашли ли Вы решение которое полностью убирает ошибку?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.