Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Сборка мобильного приложения на новой платформе под старые версии android

Сборка мобильного приложения на новой платформе под старые версии android
Я
   Garykom
 
18.05.19 - 23:04
Собственно подскажите как?

Мне надо собрать МП под "Android 4.0.3 (API level 15)"

Какие версии мобильной платформы можно использовать?
И как собрать чтобы не получить при попытке установки "При синтаксическом анализе пакета возникла неполадка"?
 
 
   Garykom
 
1 - 19.05.19 - 02:11
Опытным путем разобрался что мобильная платформа 8.3.13 еще пашет (на android 4.0.3), а вот 8.3.14 уже нет.
   Garykom
 
2 - 19.05.19 - 02:18
(1)+ Хотя ошибся, оно не пашет.

Точнее запускается но половина часть интерфейса не работает, по табличными вкладкам не переходит например.
Но документы и справочники открывает и записывает.
   Garykom
 
3 - 19.05.19 - 16:55
У кого есть база/наработки для каких версий android (от 4 до 8) какую лучше версию мобильной платформы применять?
   seevkik
 
4 - 19.05.19 - 17:29
Мобильная платформа? Андроид 4? Сейчас точно 2к19?)
   Garykom
 
5 - 19.05.19 - 17:44
(4) ТСД на Android 4.4 еще дохрена, я же хотел и древние планшеты на 4.0.3 чтобы тоже поддерживались.
   Garykom
 
6 - 19.05.19 - 17:47
(5)+ И да я понимаю что это изврат, но вот надо.
Проблема в том что старая мобильная платформа не пашет на новых android, придется делать кучу разных версий.
Вот и пытаюсь понять какие версии платформы брать для каких версий андроида.
   Cyberhawk
 
7 - 20.05.19 - 08:37
Вроде не выше 8.3.9
   Cyberhawk
 
8 - 20.05.19 - 08:38
Еще там фишка в смене сборщика, понадобится как минимум два разных хоста, т.к. на одном подружить это дело вроде никак нельзя (по крайней мере через конфу "Сборщик МП")
   Garykom
 
9 - 20.05.19 - 09:42
(8) Последний сборщик любые умеет собирать, там два SDK только надо разных в разных каталогах
   Cyberhawk
 
10 - 20.05.19 - 10:06
(9) "Последний сборщик любые умеет собирать" // Конечно же это не так. Он умеет собирать только то, что сами разрабы на нем собирают. Под Андроид 4 он умеет собирать чуть более чем никак.
   Cyberhawk
 
11 - 20.05.19 - 10:06
Я говорю по факту, а не по заявленной и ожидаемой функциональности. В настройках конечно же это есть.
   ejikbeznojek
 
12 - 20.05.19 - 15:29
Я ниже 8.3.11.57 не использую. Но у меня 4.2 самый младший андроид.
Там с JSON какие-то проблемы были в 8.3.9 и с открытием фоток из галереи на некоторых телефонах. И что-то ещё.
   Garykom
 
13 - 20.05.19 - 15:47
(12) Да глянул я как в реале этот изврат тормозит на 4.0.3 и понял что пусть покупают новые планшеты/ТСД.
   Garykom
 
14 - 31.05.19 - 00:28
Вопрос снова актуален, уже для iOS.

Какая версия мобильной платформы 1С какую версию iOS требует для компиляции и работы?

Например последняя
[info] Версия сборщика            : 2.0.9.49
[info] Версия мобильной платформы : 8.3.14.53

При попытке собрать в последней xcode 10.2.1 выдает что то про хочу под 7 а у тебя 8-12
warning: The iOS deployment target is set to 7.0, but the range of supported deployment target versions for this platform is 8.0 to 12.2.99. (in target '1cem')
   Asmody
 
15 - 31.05.19 - 00:30
(0) А 8.3.14 под XP вам запустить не надо?
   Garykom
 
16 - 31.05.19 - 01:25
(15) Пока нет :)
А что не будет работать? Странно тут обратное http://v8.1c.ru/requirements/

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.