Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БСП 2.4 Печать в списке.

БСП 2.4 Печать в списке.
Я
   Raxla
 
17.05.19 - 16:33
Народ, пятница вечер, надо добавить по быстрому кнопку для печати в форму списка и свалить. Но не выходит каменный цветок.
Из мануалов вычитано, что в саму форму группу "Печать" добавлять не нужно. Через БСП команда печати добавлена в саму форму документа и работает, то есть, в общих модулях объект заргистрирован.
Далее:

Модуль менеджера:
КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Представление = "Печать комплекта документов.";
..
КомандаПечати.СписокФорм = "ФормаДокумента, ФормаСписка";

Модуль ФормыСписка:
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
  ВспомогательныеФункцииСервер.ПроверитьНаличиеПодменюПечать(ЭтотОбъект);//не знаю что это за херня, в мануле не нашёл.
  ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
..


&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
  ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект);

Процедура Подключаемый_ВыполнитьКоманду(Команда)
    ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.Список);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
    ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.Список, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
    ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.Список);
КонецПроцедуры

Таблица Список.ССылка на форме: использовать всегда.
 
 
   Raxla
 
1 - 17.05.19 - 16:37
В форме документа группа печать есть в конфигураторе, но вроде как проба добавить группу уже была, правда с переназначением, и не особо помогло.
   Raxla
 
2 - 17.05.19 - 17:06
Кое-что начинает проясняться. Закоменнтил эту строку (Названия форм точные):
КомандаПечати.СписокФорм = "ФормаДокумента, ФормаСписка";
Комманда печати появилась в форме списка, причём, без подменю и пропала в форме документа, вместе со всем меню.
Значит формасписка вообще не при чём.
   Raxla
 
3 - 17.05.19 - 17:09
Вру, не пропала, меню на месте (не тот тип документа был)
   Raxla
 
4 - 20.05.19 - 11:30
Новые данные, при добавлении двух комманд, первая из них подменяется на "ГруппаПечатьОбычное_Авто_EA5..". Пробовал задать КомандаПечати.Идентификатор, не помогло.
   Raxla
 
5 - 20.05.19 - 12:07
Ошибочка в названии: "ПодменюПечатьОбычное_Авто_..", это какая-то внутриБСПшная хрень, которая не должна показываться. По коду что-то такое помню (ПечатьОбычное, ПечатьВажное, ПечатьСмТакже..), то что, меню не отображалось связано с этим Авто - дублировался его идентификатор на новую комманду. Сейчас же, показвыается две комманды: Авто и нужная. Что с этим делать - не понятно.
   Raxla
 
6 - 22.05.19 - 13:53
После проведения запланированного обновления платформы, подобное поведение больше не воспроизводится, всё стало работать как и должно. Старая платформа была 8.3.11.2899

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.