Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Не доступный реквизит

v7: Не доступный реквизит
Я
   Asia2016
 
17.05.19 - 15:48
Создаю новый документ. Один из реквизитов не доступен к редактированию. Не могу понять где косяк.
 
 
   Asia2016
 
1 - 17.05.19 - 15:50
В шапке реквизит Контрагент и Основание
   Asia2016
 
2 - 17.05.19 - 15:51
Основание связано с контрагентом
Процедура глПриВыбореДоговора(Контрагент, Договор) Экспорт
    Если Договор.Выбран() = 1 Тогда
        Если Договор.Владелец <> Контрагент Тогда
            Контрагент = Договор.Владелец;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры  //глПриВыбореДоговора
   ZDenis
 
3 - 17.05.19 - 16:01
(0) Мало информации, где-то "Доступность()" устанавливается
   Карст
 
4 - 17.05.19 - 16:30
реквизит в шапке и реквизит на форме - не всегда одинаковые вещи
   HawkEye
 
5 - 17.05.19 - 17:09
(0) как создаешь, программно? интерактивно?
что значит не доступен - пишет ошибку? на форме его не видно, на форме его видно но его нельзя редактировать?
   Asia2016
 
6 - 18.05.19 - 07:10
ошибку не пишет. контрагента выбирает без проблем. основание вообще не реагирует на кнопку вызова. как будто есть запрет на редактирование. но программно запрета нет
   Asia2016
 
7 - 18.05.19 - 07:11
т.е. до указанной процедуры дело не доходит
   Asia2016
 
8 - 18.05.19 - 07:13
подскажите как залить картинку ?
   DrZombi
 
9 - 18.05.19 - 08:17
   DrZombi
 
10 - 18.05.19 - 08:17
   DrZombi
 
11 - 18.05.19 - 08:17
   HawkEye
 
12 - 18.05.19 - 08:40
(6) понятно.. с ответами на вопросы - туго...
из этого набора слов, делаем вывод, что все-таки интерактивно...
так-же понятно, что есть какая-то кнопка выбора, на которую ничего не реагирует...

теперь !!!внимательно!!! тебе надо ответить, один или два:

один: если кнопка нажимается но ничего не происходит
два: если кнопка не нажимается (т.е. она не доступна)

какой вариант твой?
   Asia2016
 
13 - 18.05.19 - 09:45
   Asia2016
 
14 - 18.05.19 - 09:45
(12) два
   Asia2016
 
15 - 18.05.19 - 09:59
Извините, всем спасибо. случайно в модуле закомент НазначитьТип("Основание
   HawkEye
 
16 - 18.05.19 - 10:22
(15) обращайся...
   Asia2016
 
17 - 18.05.19 - 12:28
Можно еще вопрос по тому же документу
   Asia2016
 
18 - 18.05.19 - 12:31
Процедура ОбработкаПроведения()

    Операция.НоваяПроводка(); 
    Операция.АвторПроводки=Пользователь;
    Операция.Дебет.Счет = Счет;
    Операция.Дебет.Контрагенты = Контрагент2;
    Операция.Дебет.Основание   = Основание2;
    Операция.Кредит.Счет = Счет;
    Операция.Кредит.Контрагенты= Контрагент1;
    Операция.Кредит.Основание  = Основание1;
    Операция.Сумма = ОсновнойДолг; 
    Операция.Содержание = "Основной долг"+Основание2;
    Операция.НомерЖурнала            = "ТВ";
        Операция.Записать();
КонецПроцедуры
   Asia2016
 
19 - 18.05.19 - 12:32
   Asia2016
 
20 - 18.05.19 - 12:33
   Asia2016
 
21 - 18.05.19 - 12:36
в режиме отладка Основной долг  = 0 ?
https://ibb.co/ssHdWP9
   Asia2016
 
22 - 18.05.19 - 12:44
и содержание проводки не дает
   HawkEye
 
23 - 18.05.19 - 13:08
(21) ОсновнойДолг - реквизит табличной части, как программа должна понять, из какой строки надо взять сумму?

(22) содержание проводки это реквизит СодержаниеПроводки, ты его не заполняешь, поэтому и "не дает"....
   Looking
 
24 - 18.05.19 - 13:18
+(23)если проводка нужна по каждой строке, то цикл делайте по строкам ТЧ через ВыбратьСтроки() Пока ПолучитьСтроку()=1 Цикл. Если проводка нужна одна по итоговой сумме ТЧ, то Итог("ОсновнойДолг")


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.