Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Узнать значение флажка

Узнать значение флажка
Я
   alexodel
 
17.05.19 - 11:49
Привет! я не проф и не спец... помогите пожалуйста!!! СРОЧНО...(((
Нужна значение флажка формы т.е. нужно узнать стоит ли галочка на этом документе или нет...
Написал внешку печатную форму, и обращаюсь к другому документу, но почему то ... ответа нет... даже хотел с сообщением узнать что там в этой переменной...

представляю код...

МассивНСОДляЗапрос = Новый Массив;
    МассивНСОДляЗапрос.Добавить(ПараметрОтПервогоЗапросаКакСчетНаОплату);
    
    ЗапросСчетНаОплату = Новый Запрос;
    ЗапросСчетНаОплату.УстановитьПараметр("МассивНСОДляЗапрос", МассивНСОДляЗапрос);
    ЗапросСчетНаОплату.Текст =
    "ВЫБРАТЬ
    |    СчетНаОплату.Номер КАК Номер,
    |    СчетНаОплату.Дата КАК Дата,
    |    СчетНаОплату.Проведен КАК Проведен,
    |    СчетНаОплату.СуммаДокумента КАК СуммаДокумента,
    |    СчетНаОплату.ВалютаДокумента КАК ВалютаДокумента,
    |    СчетНаОплату.ДополнительныеРеквизиты.(
    |        Ссылка КАК Ссылка,
    |        НомерСтроки КАК НомерСтроки,
    |        Свойство КАК Свойство,
    |        Значение КАК Значение,
    |        ТекстоваяСтрока КАК ТекстоваяСтрока
    |    ) КАК ДополнительныеРеквизиты,
    |    СчетНаОплату.Ссылка КАК Ссылка
    |ИЗ
    |    Документ.СчетНаОплату КАК СчетНаОплату
    |ГДЕ
    |    СчетНаОплату.Ссылка В(&МассивНСОДляЗапрос)
    |
    |УПОРЯДОЧИТЬ ПО
    |    СчетНаОплату.Ссылка";
    
    
    РезультатЗапросаСчетНаОплату = ЗапросСчетНаОплату.Выполнить().Выбрать(); //ИзДокументаПоступлениеНаСчет
    
    Пока РезультатЗапросаСчетНаОплату.Следующий() цикл
        
        ЗаказПокупателяНаОснованииСчетНаОплату = РезультатЗапросаСчетНаОплату.Ссылка;
        ДанныеПечати.Вставить("ЗаказПокупателяНаОснованииСчетНаОплату", ЗаказПокупателяНаОснованииСчетНаОплату);
        
        ЗаказПокупателяНаОснованииСчетНаОплатуСуммаДокумента = РезультатЗапросаСчетНаОплату.СуммаДокумента;
        ЗаказПокупателяНаОснованииСчетНаОплатуСуммаВалюта = РезультатЗапросаСчетНаОплату.ВалютаДокумента;
        
        ДанныеПечати.Вставить("СуммаИВалютаДокумента", СтрШаблон(НСтр("ru ='%1  %2'"), ЗаказПокупателяНаОснованииСчетНаОплатуСуммаДокумента, ЗаказПокупателяНаОснованииСчетНаОплатуСуммаВалюта));
        
        
        
        ОригиналСчетаНаОплатувБухгалтерии = ПолучитьЗначенияЛогСчетаНаОплатуВБухгалтерии(РезультатЗапросаСчетНаОплату.Ссылка);//Подразделение
        
        ДанныеПечати.Вставить("ОригиналСчетаНаОплатувБухгалтерии", ОригиналСчетаНаОплатувБухгалтерии);
        
        
        
    КонецЦикла;


Функция ПолучитьЗначенияЛогСчетаНаОплатуВБухгалтерии(СчетНаОпл)
    Для каждого стрДР из СчетНаОпл.ДополнительныеРеквизиты Цикл
             ИИ = "ОригиналДокументаВБухгалтерии_8f6b7451c4104aaf82656a6521318a74";
        Если ИИ Тогда
            Реквизит = 1;
        Иначе
            Реквизит = 0;
        КонецЕсли;
    КонецЦикла;
    
    Возврат Реквизит;
    //Сообщить("Реквизит функции = "+Реквизит);
КонецФункции
 
 
   Галахад
 
1 - 17.05.19 - 11:52
Это чего?
ИИ = "ОригиналДокументаВБухгалтерии_8f6b7451c4104aaf82656a6521318a74";
   alexodel
 
2 - 17.05.19 - 12:06
(1) Это пользовательские переменные в управляемой форме
   catena
 
3 - 17.05.19 - 12:36
(2)А что такое тогда:
   Если ИИ Тогда
   catena
 
4 - 17.05.19 - 12:37
(2)А вообще, надо пользоваться существующими механизмами, там целые модули отдельные для общения с доп.реквизитами.
   Жан Пердежон
 
5 - 17.05.19 - 12:53
Это доп.реквизит что ли?
   НЕА123
 
6 - 17.05.19 - 12:57
эта ветка шутка юмора?
или мой рассудок того...
   Franchiser
 
7 - 17.05.19 - 13:00
Запусти отладчик
   Franchiser
 
8 - 17.05.19 - 13:02
ИИ = "ОригиналДокументаВБухгалтерии_8f6b7451c4104aaf82656a6521318a74";
        Если ИИ Тогда 
            Реквизит = 1; 
        Иначе 
            Реквизит = 0; 
        КонецЕсли; 

Тут Реквизит всегда 0
   seevkik
 
9 - 17.05.19 - 13:21
Есть такой отличный общий модуль - управление свойствами, пошарься там
   alexodel
 
10 - 22.05.19 - 13:22
СПАСИБО ВСЕМ! ПОМОГЛИ, ТАКЖЕ Я ТОЖЕ СТАРАЛСЯ И НАШЕЛ!
   seevkik
 
11 - 22.05.19 - 13:24
А ты скор

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.