Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как выбрать документы входящие в журнал

v7: Как выбрать документы входящие в журнал
Я
   gugolovski
 
17.05.19 - 04:38
Похоже это должно мне вернуть список документов:

Метаданные.Журнал("СкладскиеДокументы").Состав

но эта конструкция возвращает нечто: МетаданныеСсылки.
Непонятно как из этого получить, нечто осязаемое.
 
 
   gugolovski
 
1 - 17.05.19 - 05:34
Вижу есть 2 метода: Количество() и Получить()

вместо строкового "СкладскиеДокументы", подставлял числовой идентификатор.

,но:
Метаданные.Журнал("СкладскиеДокументы").Состав.Количество()
Метаданные.Журнал(13).Состав.Количество()
..возвращает 0. Хотя документы в журнале есть
   МимохожийОднако
 
2 - 17.05.19 - 07:05
Если получил количество, то его можно перебрать в цикле.
   Rie
 
3 - 17.05.19 - 07:10
(0) Что такое "осязаемое"? Нужны сами документы? Или их метаданные (например, виды документов)?

// если сами документы, то что-то вроде

Запрос = "
ВЫБРАТЬ
|    СкладскиеДокументы.Ссылка КАК Ссылка
|ИЗ
|    ЖурналДокументов.СкладскиеДокументы КАК СкладскиеДокументы";
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
    ТекДок = Выборка.Ссылка;// и делай с ним, что душа пожелает

КонецЦикла;

// если виды документов

Для каждого метаДок из Метаданные.Журналы.СкладскиеДокументы.Состав Цикл
    Сообщить(метаДок.Имя+" входит в журнал!");
КонецЦикла;

(1) А если не методом глубоко научного тыка, а документацию почитать?
И да, это точно 7.7? :-)
   vcv
 
4 - 17.05.19 - 07:12
Для Номер = 1 По Метаданные.Документ() Цикл
Если Метаданные.Документ(Номер).Журнал.Идентификатор = "СкладскиеДокументы" Тогда
...
КонецЕсли;
КонецЦикла;
   vcv
 
5 - 17.05.19 - 07:14
Из описания:

Замечание 1
  Согласно принятым в 1Ц правилам документ м.б. только в одном обычном журнале. Для составления списка доков, которые показываются в ОБЫЧНОМ журнале, нужно перетряхнуть все доки и опросить в них поле ЖУРНАЛ. Если там указан идентификатор требуемого журнала, тогда его можно занести в формируемый список доков обычного журнала.
Замечание 2
  Список СОСТАВ содержит информацию только в том случае, если тип журнала - Дополнительный. В этом списке перечислены все документы, которые показываются в дополнительном журнале.
   МимохожийОднако
 
6 - 17.05.19 - 07:15
У документов есть
ИспользоватьЖурнал(<?>,);
Синтаксис:
ИспользоватьЖурнал(<Журнал>,<ФлагОгрПросм>)
Назначение:
Использовать журнал для отбора документов и доступа к графам.
Параметры:
<Журнал> - идентификатор журнала, который предполагается использовать для отбора документов и доступа к графам.
<ФлагОгрПросм> - необязательный параметр. Число: 1 - если выборка ограничивается документами, входящими в указанный журнал; 0 - если метод используется только для использования граф методом Графа. Значение по умолчанию 1.
   gugolovski
 
7 - 17.05.19 - 07:19
(3) да, 7.7. а "для каждого из" это же вроде для 8-ки. Нужны виды документов. У меня две книжки "описание встроенного языка". Не смог там найти ничего про этот ".состав")
   gugolovski
 
8 - 17.05.19 - 07:20
у журнала складских документов, тип "обычный"
   gugolovski
 
9 - 17.05.19 - 07:28
(4) спасибо
   gugolovski
 
10 - 17.05.19 - 07:30
(5) можете ссылку дать на ресурс, где это описание есть? если не сложно
   vcv
 
11 - 17.05.19 - 07:45
(10) Ресурса не знаю 
У меня файл Meta.als, "Метаданные-ред 2.2 (24/07/02) Моисеенко"
   МимохожийОднако
 
12 - 17.05.19 - 08:17
(10) Ctrl-F1
   BalBess
 
13 - 20.05.19 - 06:43
(0) Это зависит от типа журнала
Если Дополнительный то через Состав
Если Обычный, то перебором всех документов и сравнением журнала документа с нужным тебе журналом
Если Общий, то через графы
сам недавно заморачивался этим, если будет нужно могу код скинуть

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.