Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Добавление в тз значений

v7: Добавление в тз значений
Я
   JuixyJes
 
16.05.19 - 15:19
Здравствуйте, умники и умницы форума mista .
Помогите пожалуйста, мне нужно добавить в ТЗ конкретное значение при условии и продолжить заполнять ТЗ. То что помечено "//" это то что нужно добавить при выполнении условия.




    Пока спрдети.ПолучитьЭлемент()=1  Цикл
        возраст = (РабочаяДата() - спрдети.ТекущийЭлемент().ФизЛицо.ДатаРождения)/365;
        если (возраст > 18) и ((Строка( ТЗ.ПолучитьЗначение(стр,2))="Сын")или( Строка(ТЗ.ПолучитьЗначение(стр,2))="Дочь"))  тогда
        Если (( Строка(ТЗ.ПолучитьЗначение(стр,2))="Сын")или(Строка( ТЗ.ПолучитьЗначение(стр,2))="Дочь")) тогда
        ТЗ2.НоваяСтрока();
        //ТЗ2.ФИО= кл.ФизЛицо;
        //ТЗ2.РодственнаяСвязь=кл.ФизЛицо.Родств;
        
        ТЗ2.ФИО=спрдети.ТекущийЭлемент().ФизЛицо;    
        ТЗ2.РодственнаяСвязь=спрдети.ТекущийЭлемент().Принадлежность;
    КонецЕсли;
    КонецЕсли;
    КонецЦикла
 
 
   NikVars
 
1 - 16.05.19 - 15:23
Я не понял чему равно стр из приведенного кода.
   Ёпрст
 
2 - 16.05.19 - 15:25
(0) всё в топку
   Birmingem
 
3 - 16.05.19 - 15:26
И в чем проблема? Что именно не получается?
   ZDenis
 
4 - 16.05.19 - 15:27
(0)
ТЗ2.НоваяСтрока();
Если твоеУсловие Тогда 
  ТЗ2.ФИО= кл.ФизЛицо; 
  ТЗ2.РодственнаяСвязь=кл.ФизЛицо.Родств; 
Иначе
  ТЗ2.ФИО=спрдети.ТекущийЭлемент().ФизЛицо;
  ТЗ2.РодственнаяСвязь=спрдети.ТекущийЭлемент().Принадлежность;
КонецЕсли;


Или в другом вопрос?
   Rie
 
5 - 16.05.19 - 15:33
(0) "Сын" и "Дочь" - это точно строковые значения? А то есть подозрение, что это может быть перечислением - а элемент перечисления строке ну никак равен не будет.
Ну а ежели Принадлежность - это перечисление, то условие _никогда_ не выполнится, и ни одной строки в таблицу не вставится.

(И зачем вечно вставлять .ТекущийЭлемент()? Толку с него - как с козла молока. Да и неэстетично).
   Масянька
 
6 - 16.05.19 - 15:36
А это не falselight переименовался?
   Эльниньо
 
7 - 23.05.19 - 11:44
Ёпрст сказал "в топку", значит в топку

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.