Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1С 8.3 УПП Перемещение ОС (Доработка)

1С 8.3 УПП Перемещение ОС (Доработка)
Я
   jojojoba2
 
16.05.19 - 13:46
Добрый день!

Помогите начинающему разработчику 1С. Есть документ Перемещение ОС. В нем нужно добавить поле с вожможностью вода данных ,на ком или какому  складе(МОЛ) принадлежит ОС(Тоесть чтобы было поле "Тот кто здал" и "Тот кто принял". При создании нового документа Перемещение ОС, при добавлении Основного средства необходимо чтобы данные на ком(на каком складе) оно числится добавлялись в созданное поле автоматически.

Подскажите метод или пример кода автоматического заполнения. Я Пытаюсь через обработку формы при изменении документа "Перемещение ОС"
подставить в новое поле (созданное мною "на ком числиться") данные из документа "Основные Средства" вкладка "бух учет" из поля "МОЛБУ",но это не реквизит , а переменная в Процедура ЗаполнитьОписания() формы элемента. Как сделать ссылку на конкретный элемент формы другого документа.

Процедура ОСОсновноеСредствоПриИзменении(Элемент)
    
СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные;
СтрокаТабличнойЧасти.м =Справочники.ОсновныеСредства.ФормаЭлемента. ???????????

КонецПроцедуры

Направте на путь истинный.

Спасибо.
 
 
   Гипервизор
 
1 - 16.05.19 - 14:02
Поле "Тот кто принял" уже есть. Зачем вводить руками "тот кто здал", если эти данные есть в регистре Местонахождение ОС? Регистратором которого, кстати, и является документ Перемещение ОС. Создайте на форме поле и при открытии подтягивайте в него данные из регистра.
   shuhard
 
2 - 16.05.19 - 14:12
(0)[Тот кто здал]
нет в русском языке здал, есть сдал
   jojojoba2
 
3 - 16.05.19 - 15:37
"Поле "Тот кто принял" уже есть. Зачем вводить руками "тот кто здал", если эти данные есть в регистре Местонахождение ОС? Регистратором которого, кстати, и является документ Перемещение ОС. Создайте на форме поле и при открытии подтягивайте в него данные из регистра."

Можете подсказать примеры  написания или литературу?
   jojojoba2
 
4 - 16.05.19 - 16:51
Написал код, вставляет значение в мое созданное поле но значение одно и тоже для всех основных средств

Функция ПолучитьДанныеИзРС(ОС) 

Запрос = Новый Запрос ; 
Запрос.УстановитьПараметр("ОС",ОС); 
Запрос.Текст = "ВЫБРАТЬ 

|    МестонахождениеОС.МОЛ 
|ИЗ 
|    РегистрСведений.МестонахождениеОС КАК МестонахождениеОС "; 


// получение данных по конкретному ОС 


Выборка = Запрос.Выполнить().Выбрать(); 
Выборка.Следующий(); 

Возврат Выборка.МОЛ; 

КонецФункции 



Процедура ОСОсновноеСредствоПриИзменении(Элемент) 

СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные; 
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОсновноеСредство); 

КонецПроцедуры
   jojojoba2
 
5 - 17.05.19 - 14:33
Всем спасибо!
Вставляю рабочий код, может кому то пригодиться 

Функция ПолучитьДанныеИзРС(ОС) 

Запрос = Новый Запрос ; 
Запрос.УстановитьПараметр("ОС",ОС); 
Запрос.УстановитьПараметр("Дата",Дата); 
Запрос.Текст = "ВЫБРАТЬ 
|    МестонахождениеОСБухгалтерскийУчет.МОЛ 
|ИЗ 
| РегистрСведений.МестонахождениеОСБухгалтерскийУчет.СрезПоследних(&Дата,ОсновноеСредство = &ОС) КАК МестонахождениеОСБухгалтерскийУчет"; 

// получение данных по конкретному ОС 


Выборка = Запрос.Выполнить().Выбрать(); 
Выборка.Следующий(); 

Возврат Выборка.МОЛ; 

КонецФункции 

Процедура ОСОсновноеСредствоПриИзменении(Элемент) 

СтрокаТабличнойЧасти = ЭлементыФормы.ос.ТекущиеДанные; 
СтрокаТабличнойЧасти.М = ПолучитьДанныеИзРС(СтрокаТабличнойЧасти.ОсновноеСредство); 

КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.