Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Мобильный клиент,отладка работает только на серверных процедурах, на клиентских ни как.

Мобильный клиент,отладка работает только на серверных процедурах, на клиентских ни как.
Я
   SkillUp
 
16.05.19 - 09:28
Здр., столкнулся с проблемой, после установки мобильного клиента, выяснилось что отладка работает только на серверных процедурах, на клиентских ни как. Как исправить эту ситуацию?

Настройки конфигуратора:
https://drive.google.com/open?id=1xn0yLZGBykFcrhESd8RN8-NoJBtuDK5G
https://drive.google.com/open?id=144csR1J6y8hEyvjUXxiaBzDBojG0mnrR
https://drive.google.com/open?id=1mBm0yx0vfpP_5nDoalyId35k44OGGcNm
 
 
   Cyberhawk
 
1 - 16.05.19 - 09:29
Ну так в свойствах инфобазы в МП надо отладку-то разрешить
   SkillUp
 
2 - 16.05.19 - 09:33
(1) Та, (в МП), отладка разрешена!
   Cyberhawk
 
3 - 16.05.19 - 09:35
Если это так, то при старте отладки из конфигуратора приложение само должно запускаться на МП, если стартер там открыт - это происходит?
   Cyberhawk
 
4 - 16.05.19 - 09:35
"при старте отладки из конфигуратора" = запускаешь пункт отладки клиента мобильного приложения
   SkillUp
 
5 - 16.05.19 - 09:36
(4) 1 мин.
   SkillUp
 
6 - 16.05.19 - 09:41
(1) (3) (4) Что-то голова не варит, пож., укажи где конкретно это делается, не могу найти...
   SkillUp
 
7 - 16.05.19 - 09:42
(1) (3) (4) Если при запуске мобильного приложения с планшета, то Отладка там - Разрешена!
   SkillUp
 
8 - 16.05.19 - 09:45
(1) (3) (4) Кажись нашел, у меня обычное приложение, из-за этого, многих пунктов не было видно. После переключения на УФ, эти пункты появились ,но сейчас проверю, 1 мин.
   SkillUp
 
9 - 16.05.19 - 09:48
(1) (3) (4)  Блин, что-то опять не так, жду ответа, что-то не могу врубится, из-за чего клиент так и не работает...
   Cyberhawk
 
10 - 16.05.19 - 09:49
На третьей картинке из (0) пропиши имя базы "DefAlias", т.е. поменяй радиокнопку
   Cyberhawk
 
11 - 16.05.19 - 09:49
Ну и адреса сервера отладки в МП и в конфигураторе должны совпадать, поэтому и адрес сервера отладки пропиши в конфигураторе вручную, а не кластерный используй
   SkillUp
 
12 - 16.05.19 - 09:53
(11) Пробую...
   Cyberhawk
 
13 - 16.05.19 - 09:55
Также учитывай, что локальный хттп-сервер отладки при указании вручную иногда может "повисать" из-за занятого порта. В этом случае надо в настройках конфигураторка и МП указывать другой порт, либо добиваться освобождения уже указанного там порта.
   SkillUp
 
14 - 16.05.19 - 09:57
(13) ОООО, а это вполне возможно!!!! Я же пытаюсь все на один порт!!! ЩА, попробую!
   Cyberhawk
 
15 - 16.05.19 - 10:09
Ну и порт хоста, на котором открывается конфигуратор, должен быть доступен с мобильного устройства. Виндовый файрвол такое точно режет, если он включен.
   SkillUp
 
16 - 16.05.19 - 10:55
(15) Спасибо!
   Cyberhawk
 
17 - 16.05.19 - 10:56
Ну что, хоть что-нибудь из перечисленного помогло?
   SkillUp
 
18 - 16.05.19 - 11:02
(17) Пока не заработало, но я еще не все перепробовал. Срочно переключили меня на другую задачу, эту пока отложить на потом, как только освобожусь продолжу... И обязательно отпишусь! Еще раз, большое СПАСИБО за уделенное время! Из всего перечисленного должно заработать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.