Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

8,2 Ут10 Удаление дублей предопределенных элементов планов видов характеристик.

8,2  Ут10 Удаление дублей предопределенных элементов планов видов характеристик.
Я
   Azmarika
 
15.05.19 - 12:52
Доброе время суток, уважаемые форумчане. Возникла следующая ситуация: при обмене через обработку "Выгрузка и загрузка данных XML", задвоились элементы.
При попытки удалить, выдается что объект не доступен для записи. Буду благодарна за помощь.


Процедура КнопкаВыполнитьНажатие(Кнопка)
Запрос=ПланыВидовХарактеристик.ПраваПользователей.Выбрать( ,, "Наименование Возр");
//ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура
    //Спр=Объект.ПолучитьОбъект();
    СпрПервый="";
    Пока Запрос.Следующий() Цикл
        Если Запрос.Ссылка.Наименование<>СпрПервый тогда
            СпрПервый=Запрос.Ссылка.Наименование;
            Продолжить;
        Иначе
            Объект=Запрос.ссылка.ПолучитьОбъект();
            Объект.Предопределенный=Ложь;
            Объект.Наименование    ="";
            Объект.ПометитьНаУдаление=Истина;
            Если Объект <> Неопределено Тогда
                
                Если Не ЗначениеЗаполнено(Объект.Наименование) Тогда
                    Объект.Наименование = Объект.ИмяПредопределенныхДанных;
                КонецЕсли;
                
                Объект.ИмяПредопределенныхДанных = "";
                Объект.ПометкаУдаления = Истина;
                Объект.Записать();
                ВыполненоУспешно = Истина;
            КонецЕсли;
    
        КонецЕсли;    
    КонецЦикла;    
КонецПроцедуры
 
 
   vtolga
 
1 - 15.05.19 - 16:24
Замени слово "Объект" на, например, "Объект1". "Объект" - это зарезервированное слово, его нельзя в качестве переменной использовать.
   Azmarika
 
2 - 16.05.19 - 08:00
Спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.