Вход | Регистрация
 

Не работает проверка

Не работает проверка
Я
   rapashocker
 
15.05.19 - 10:50
Привет всем, делаю проверку для записи и проведения, надо что бы при записи и при проведении он записывал в регистр сведений записи, при записи должен записывать ПовкладкеМТСС , а при проведении ПовкладкеТовары, сейчас в итоге он пишет в регистр, но при записи и при проведении он записывает в регистр любое подставленное значение:
Процедура РегистрУведомленияORDRSP(ТипЗаполнения)
Если ПолучитьЗаказEDI() = Неопределено тогда
Возврат
КонецЕсли;
Если НетЗаписейУведомленияORDRSP(Ссылка) тогда
запись = РегистрыСведений.УведомленияORDRSP.СоздатьМенеджерЗаписи();
Если ТипЗаполнения = "Запись" тогда
Запись.ВариантЗаполнения = Перечисления.ВариантыЗаполненияORDRSP.ПовкладкеМТСС;
иначеесли ТипЗаполнения = "Проведение" тогда
Запись.ВариантЗаполнения = Перечисления.ВариантыЗаполненияORDRSP.ПовкладкеТовары;
КонецЕсли;
запись.ЗаказПокупателя = Ссылка;
запись.ЗаказEDI = ПолучитьЗаказEDI();
запись.УникальныйИдентификатор = новый УникальныйИдентификатор();
запись.ОтправленВРучную = Ложь;
запись.Состояние = Перечисления.СостоянияORDRSP.Ожидает;
запись.ДатаПостановки = ТекущаяДата();
запись.Записать();
КонецЕсли;
КонецПроцедуры


Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
//Проверка--151321
Если (ТорговаяТочка.АвтоматическаяОтправкаORDRSP и Контрагент.АвтоматическаяОтправкаORDRSP)= Истина
и торговаяточка.ВариантОтправкиORDRSP = Перечисления.ВариантыОтправкиORDRSP.ПриКаждомИзменении
и торговаяточка.ВариантЗаполненияORDRSP = Перечисления.ВариантыЗаполненияORDRSP.ПовкладкеМТСС
и НЕ (ТоварыSFA = ссылка.ТоварыSFA)Тогда
РегистрУведомленияORDRSP("Запись");
КонецЕсли;


Процедура ОбработкаПроведения(Отказ, РежимПроведения)
Перем ДеревоПолейЗапросаПоШапке;
//Проверка--151321
Если (ТорговаяТочка.АвтоматическаяОтправкаORDRSP и Контрагент.АвтоматическаяОтправкаORDRSP)= Истина
и торговаяточка.ВариантОтправкиORDRSP = Перечисления.ВариантыОтправкиORDRSP.ПриКаждомИзменении
и торговаяточка.ВариантЗаполненияORDRSP = Перечисления.ВариантыЗаполненияORDRSP.ПовкладкеТовары Тогда
РегистрУведомленияORDRSP("Проведение");
КонецЕсли;


Помогите понять в чем проблема, передаю параметры и строки, что бы было понятно где запись, где проведение, где подставлять какое значение
 
 
   chelentano
 
1 - 15.05.19 - 11:05
(0) Если я верно понял, то кури РежимЗаписи в процедуре ПередЗаписью
   rapashocker
 
2 - 15.05.19 - 11:48
(1) что вы имеете ввиду?
   Галахад
 
3 - 15.05.19 - 12:00
На редкость непонятный топик.
   hhhh
 
4 - 15.05.19 - 12:01
(0) от торговой точки зависит.
и торговаяточка.ВариантЗаполненияORDRSP = Перечисления.ВариантыЗаполненияORDRSP.ПовкладкеМТСС

тогда проведение по любому ведь не запишется.
   rapashocker
 
5 - 15.05.19 - 12:06
(4) Ну если я ставлю ПовкладкеТовары, жму запись, записывает, если ставлю ПовкладкеМТСС , проводит и записывает
   rapashocker
 
6 - 15.05.19 - 12:06
(4) То есть он запишет любое значение, которое я подставлю что при записи что при проведении.
   hhhh
 
7 - 15.05.19 - 12:15
(6) а почему он не должен записать любое значение? так и должен.
   hhhh
 
8 - 15.05.19 - 12:18
то что есть в торговаяточка.ВариантЗаполненияORDRSP, он это и запишет. Тут без вариантов.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.