Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

сохранить данные в регистр сведений при записи

сохранить данные в регистр сведений при записи
Я
   somn74
 
14.05.19 - 11:47
есть регистр сведений ХранилищеФайловДокументов. измерение Документ, ресурс ДанныеЗагруженогоФайла (ХранилищеЗначений).
на форме записи регистра сведений загружаю файл документа через ДиалогВыбораФайла.
как при записи новой строки регистра сведений сохранить значение двоичных данных файла в ресурс ДанныеЗагруженогоФайла?
ДвоичныеДанные = ЗагружаемыйФйал.ПолучитьДвоичныеДанные();
ДанныеЗагруженогоФайла = Новый ХранилищеЗначения(ДвоичныеДанные);
 
 
   Cyberhawk
 
1 - 14.05.19 - 11:52
Не все свойства основного реквизита формы уходят в объект.
Делай перед записью на сервере.
   somn74
 
2 - 14.05.19 - 11:59
(1) так? ничего не сохраняет

&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

    ПередЗаписьюНаСервере(ПараметрыЗаписи);

КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(ПараметрыЗаписи)
    
    ДвоичныеДанные = ЗагружаемыйФйал.ПолучитьДвоичныеДанные(); 
    ДанныеЗагруженогоФайла = Новый ХранилищеЗначения(ДвоичныеДанные);

    ПараметрыЗаписи.Вставить("Документ", Документ);
    ПараметрыЗаписи.Вставить("ДанныеЗагруженогоФайла", ДанныеЗагруженогоФайла);

КонецПроцедуры
   Cyberhawk
 
3 - 14.05.19 - 12:02
Так ты ТекущийОбъект изменяй, а не ПараметрыЗаписи, лол
   Cyberhawk
 
4 - 14.05.19 - 12:02
Создай обработчик события формы через конструктор (лупу) в свойствх формы
   somn74
 
5 - 14.05.19 - 12:12
вообще ничего не происходит

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
    
    ДвоичныеДанные = ЗагружаемыйФйал.ПолучитьДвоичныеДанные(); 
    ДанныеЗагруженогоФайла = Новый ХранилищеЗначения(ДвоичныеДанные);
    
    ТекущийОбъект.Документ = Документ;
    ТекущийОбъект.ДанныеЗагруженогоФайла = ДанныеЗагруженогоФайла;
    
КонецПроцедуры
   somn74
 
6 - 14.05.19 - 14:02
что делаю не так?
   sqr4
 
7 - 14.05.19 - 14:07
в (4) Прямой намек на то, что в событии не указан обработчик, это проверено или проигнорированно?
   somn74
 
8 - 14.05.19 - 16:27
(7) нет, проблема оказалось в том, что двочиные данные были пустые
СПАСИБО

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.