Вход | Регистрация
 

Право Удаление неприменимо к РегистрСведений.КурсыВалют

Право Удаление неприменимо к РегистрСведений.КурсыВалют
Я
   falselight
 
13.05.19 - 07:57
При запуске обработки MD83Exp.epf, выходит ошибка,  -
Права стоят все. Как это исправить, и из за чего она?


{ВнешняяОбработка.УниверсальныйОбменДаннымиXML.Форма.УправляемаяФорма.Форма(864)}: Ошибка при вызове метода контекста (ПравоДоступа)
        Если Не ПравоДоступа("Удаление", ОбъектМД) Тогда
по причине:
Право Удаление неприменимо к РегистрСведений.КурсыВалют
 
 
   falselight
 
1 - 13.05.19 - 07:58
(0+) При запуске вот этой обработки идет ошибка V8Exchan83.epf
Опечатался (
   falselight
 
2 - 13.05.19 - 07:59
У роли права стоят вообще все.
   catena
 
3 - 13.05.19 - 08:04
Нет у регистров сведений такого права.
   falselight
 
4 - 13.05.19 - 08:07
(3) Обработка же типовая, из КД 2.1  http://joxi.ru/Q2KbdNVCLvWJRm

Я открываю её в приемнике, не должно быть никаких ошибок.
От чего она?
   falselight
 
5 - 13.05.19 - 08:09
Что делать? Все типовое!
   catena
 
7 - 13.05.19 - 08:13
Сторно, действительно есть такой цикл))
   hhhh
 
8 - 13.05.19 - 08:17
(5) закоммкнтируй это место
   falselight
 
9 - 13.05.19 - 08:21
(8) Ну так в прочих конфигурациях же открывалось без проблем всегда?!
Что с этой не так?
   falselight
 
10 - 13.05.19 - 08:25
(8) Если чт ото там комментировать, то может что то не пойти.
Там же все настроено на работу
   catena
 
11 - 13.05.19 - 08:27
в релизе платформы 8.3.10 изменилось поведение метода ПравоДоступа():

Цитировать
При вызове метода ПравоДоступа() генерируется исключение, если проверяемое право доступа не может быть применено к объекту метаданных.
В режиме совместимости с версией 8.3.9 поведение не изменилось.

Для устранения ошибки можно включить либо включить режим совместимости в 8.3.9 в свойствах конфигурации, либо добавить в код обработку исключения
   catena
 
12 - 13.05.19 - 08:28
(10)Это проверка на то, что запускающему дозволено удалять, на настройки работы не влияет. Если ты себе доверяешь, можешь смело комментировать эту строчку.
   falselight
 
13 - 13.05.19 - 08:31
(12) Закомментировать в смысле цикл?!


    //Для каждого ОбъектМД Из Метаданные.РегистрыСведений Цикл

    //    Если Не ПравоДоступа("Удаление", ОбъектМД) Тогда

    //        Продолжить;

    //    КонецЕсли;

    //    Подчинен = (ОбъектМД.РежимЗаписи = Метаданные.СвойстваОбъектов.РежимЗаписиРегистра.ПодчинениеРегистратору);

    //    Если Подчинен Тогда Продолжить КонецЕсли;

    //    СтрокаМД = СтрокаДерева.Строки.Добавить();

    //    СтрокаМД.Представление = ОбъектМД.Имя;

    //    СтрокаМД.Метаданные = "РегистрСведенийЗапись." + ОбъектМД.Имя;

    //КонецЦикла;
   falselight
 
14 - 13.05.19 - 08:32
(12) Если его комментировать, то обработка открываться. Ошибки нет.
Но не испортит ли это что?
   catena
 
15 - 13.05.19 - 08:33
Только вот это, остальное можно оставить:

    //    Если Не ПравоДоступа("Удаление", ОбъектМД) Тогда


    //        Продолжить;


    //    КонецЕсли;
   falselight
 
16 - 13.05.19 - 08:35
(15) Понял. А то идет потом ошибка не понятная, ->

http://joxi.ru/BA08ePMCMp4RXA
   falselight
 
17 - 13.05.19 - 08:38
(16+) Эта ошибка все равно идет. А её не должно быть!
Из за чего она?
   falselight
 
18 - 13.05.19 - 08:39
(17+) Понял, не те методанные гружу. Разбираюсь.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.