Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КА2.4/ERP: Закрытие месяца: Исправление отрицательных остатков товаров организаций

КА2.4/ERP: Закрытие месяца: Исправление отрицательных остатков товаров организаций
Я
   Mikhail Volkov
 
12.05.19 - 09:36
Ситуация такая: все работают в Альфа-Авто, для бух. учета документы выгружаются в КА. Пока работают в КА1.1 (для каждой организации своя база КА), но для одной организации (попроще, без производства, автосервис, оказание услуг и продажа запчастей) создал КА2.4. Перегружаю из Альфа-Авто документы пока транзитом через КА1.1. Отрицательных остатков нет в принципе, контролируются на этапе обмена. Резервов нет, для бух. учета не нужны, из Альфа-Авто не выгружаются.
Понадобилась сверка остатков по суммарным остаткам с Альфа-Авто, в КА1.1 нет детализации по складам и номенклатуре (группам - иерархии) - крайне затруднительно (первые вопросы по этой проблеме в КА1: Нет списания сумм со счета 41). Решил посмотреть суммарные остатки в КА2.4. А их нет, расчет себестоимости в ней ни разу не делал. Запустил Закрытие месяца (самого 1-го, когда начались документы загружаться), и получил: Обнаружены отрицательные остатки товаров организации... большой список ошибок. Для примера: Результаты проверки https://jpegshare.net/21/e8/21e8d59ffc2360e1a2a245917b6572f8.jpg.html - откуда она (проверка) их берет? Если их в принципе нет:
Ведомость по товарам организаций https://jpegshare.net/fd/93/fd93f4c66defc961f7af013b7ca5acdf.jpg.html
Ведомость по товарам на складах https://jpegshare.net/ba/2c/ba2cce7c0d3c89e355894091e1eecb16.jpg.html
 
 
   ДНН
 
1 - 12.05.19 - 10:06
(0) Посмотри в консоли запросов остатки в разрезе всех измерений, или свой отчет на СКД набросай. У меня такое было с аналитикой учета по номенклатуре. Было 2 аналитики, одна без связи с регистром сведений.
   Mikhail Volkov
 
2 - 12.05.19 - 10:12
(1) > Было 2 аналитики, одна без связи с регистром сведений.
С каким РС? Опыта работы с КА2.4 нет (вообще с УФ), только начинаю работать...
   Mikhail Volkov
 
3 - 12.05.19 - 10:37
(1) > ...или свой отчет на СКД набросай.
Стал делать свою обработку https://jpegshare.net/f5/09/f509e1b3ab3c989f8131d91c9c75baa0.jpg.html

&НаСервере
Процедура ВыполнитьНаСервере()
    Счетчик = 0;
    НачалоПериода = НачалоМесяца(Объект.ПериодРегистрации);
    КонецПериода  = КонецМесяца(Объект.ПериодРегистрации);
КонецПериода, СтатусСообщения.Информация);
    Запрос = Новый Запрос;
    Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    Если ЗначениеЗаполнено(АналитикаУчетаНоменклатуры) Тогда
        Запрос.Текст = ЗапросОтрицательныеОстаткиТоваровОрганизаций();
        Запрос.УстановитьПараметр("АналитикаУчетаНоменклатуры",    АналитикаУчетаНоменклатуры);
    Иначе
        Запрос.Текст = ЗакрытиеМесяцаСервер.ЗапросОтрицательныеОстаткиТоваровОрганизаций();
        Запрос.Текст = СтрЗаменить(Запрос.Текст, "ПОМЕСТИТЬ ОтрицательныеОстатки", "");
    КонецЕсли;
    Запрос.УстановитьПараметр("ГраницаКонецПредыдущегоПериода",    Новый Граница(НачалоПериода - 1, ВидГраницы.Включая));
    Запрос.УстановитьПараметр("ГраницаКонецПериода",              Новый Граница(КонецПериода, ВидГраницы.Включая));
    Запрос.УстановитьПараметр("МассивОрганизаций",                Объект.МассивОрганизаций);
    Результат = Запрос.Выполнить();
    Если Результат.Пустой() Тогда
        Сообщить("Пустой результат", СтатусСообщения.Информация);
        Возврат;
    КонецЕсли;
    Выборка = Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
        Счетчик = Счетчик + 1;
        НоваяСтрока = РезультатыПроверки.Добавить();
        НоваяСтрока.Период                        = Выборка.Период;
        НоваяСтрока.АналитикаУчетаНоменклатуры    = Выборка.АналитикаУчетаНоменклатуры;
        НоваяСтрока.ВидЗапасов                    = Выборка.ВидЗапасов;
        НоваяСтрока.НомерГТД                    = Выборка.НомерГТД;
        НоваяСтрока.Организация                    = Выборка.Организация;
        НоваяСтрока.Оборот                        = Выборка.Оборот;
        НоваяСтрока.Количество                    = Выборка.Количество;
    КонецЦикла;
    Сообщить(?(Счетчик = 0, "Нет", "Всего выведено: " + Счетчик) + " результатов", СтатусСообщения.Информация);
КонецПроцедуры

Добавил в отбор АналитикаУчетаНоменклатуры, чтобы результат проверки по конкретной АналитикаУчетаНоменклатуры развернуть по документам-регистраторам. Запрос ЗакрытиеМесяцаСервер.ЗапросОтрицательныеОстаткиТоваровОрганизаций() для этого случая (когда заполнена АналитикаУчетаНоменклатуры) упростил:

&НаСервере
Функция ЗапросОтрицательныеОстаткиТоваровОрганизаций()
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    |    ТоварыОрганизаций.Организация КАК Организация,
    |    ТоварыОрганизаций.АналитикаУчетаНоменклатуры КАК АналитикаУчетаНоменклатуры,
    |    ТоварыОрганизаций.ВидЗапасов КАК ВидЗапасов,
    |    ТоварыОрганизаций.НомерГТД КАК НомерГТД,
    |    ТоварыОрганизаций.Период КАК Период,
//    |    ТоварыОрганизаций.Регистратор КАК Регистратор,

    |    ТоварыОрганизаций.КоличествоОборот КАК КоличествоОборот,
    |    ТоварыОрганизаций.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток
    |ИЗ
    |    РегистрНакопления.ТоварыОрганизаций(
    |            &ГраницаКонецПредыдущегоПериода,
    |            &ГраницаКонецПериода,
    |            Месяц,
    |            ,
    |            АналитикаУчетаНоменклатуры = &АналитикаУчетаНоменклатуры
    |                И Организация В (&МассивОрганизаций)
    |                И ВидЗапасов.ТипЗапасов <> ЗНАЧЕНИЕ(Перечисление.ТипыЗапасов.ТоварТребующийПодтвержденияВыпуска)
    |            ) КАК ТоварыОрганизаций"
    ;
    Возврат ТекстЗапроса;

КонецФункции

Но как в него Регистратор вставить, чтобы результат развернуть по документам-регистраторам, и чтоб оборот и остаток в нем остались?
   Marik1274
 
4 - 12.05.19 - 11:35
Консоль запросов плюс таблица остатки и обороты тебе в помощь. Периодичность -регистратор. Разверни по всем измерениям и смотри где разьехалось. Скорее всего по ключам аналитики. Возможно отмена проведения и проведение документа проблемного тебя спасет. Если разьезжается по видам запасов, тогда можно смотреть отчет ведомость по товарам организаций с аналитикой по видам запасов. Также отмена проведения и проведение возможно спасет. Просто перепроведение не поможет.
   Mikhail Volkov
 
5 - 12.05.19 - 11:47
(4) В консоль написал запрос:
ВЫБРАТЬ
    ТоварыОрганизацийОстаткиИОбороты.АналитикаУчетаНоменклатуры КАК АналитикаУчетаНоменклатуры,
    ТоварыОрганизацийОстаткиИОбороты.Организация КАК Организация,
    ТоварыОрганизацийОстаткиИОбороты.ВидЗапасов КАК ВидЗапасов,
    ТоварыОрганизацийОстаткиИОбороты.НомерГТД КАК НомерГТД,
    ТоварыОрганизацийОстаткиИОбороты.КоличествоОборот КАК КоличествоОборот,
    ТоварыОрганизацийОстаткиИОбороты.КоличествоКонечныйОстаток КАК КоличествоКонечныйОстаток
ИЗ
    РегистрНакопления.ТоварыОрганизаций.ОстаткиИОбороты КАК ТоварыОрганизацийОстаткиИОбороты
ГДЕ
    ТоварыОрганизацийОстаткиИОбороты.АналитикаУчетаНоменклатуры = &АналитикаУчетаНоменклатуры

Оказывается разъехалось по ВидЗапасов, у меня их 2: просто "Собственный товар" и "Собственный товар; Организация...", который просто "Собственный товар" в поле Дубль стоит Да. Мне объединить их надо в "Собственный товар; Организация..."?
   Marik1274
 
6 - 12.05.19 - 11:50
(5) Да.
   Mikhail Volkov
 
7 - 12.05.19 - 12:15
Что-то долго обработка ПоискИУдалениеДублей его удаляет... И как этот дубль создался? Чтобы впредь не создавался...
   Marik1274
 
8 - 12.05.19 - 12:56
Потом не забудь удаление помеченных на удаление объектов сделать.
   Фрэнки
 
9 - 12.05.19 - 15:44
з.ы. Оказывается в "итеративной эволюции" некоторая полезность имеется

:-)
   Mikhail Volkov
 
10 - 12.05.19 - 20:42
(8) Странно, раньше этого не надо было делать... Все дубли схлопывались в один!? Сделал, теперь нет ошибок: Обнаружены отрицательные остатки товаров организации... Появились новые: Обнаружены не распределенные на производство материалы (работы) организации... - с этим завтра буду разбираться...
Кстати, моя обработка тоже показывает различные ВидЗапасов (сперва не заметил, поле было узким), в варианте без разворота по документам-регистраторам. Но все же хотелось, чтобы разворачивалось...
 
 Рекламное место пустует
   Mikhail Volkov
 
11 - 13.05.19 - 06:25
Итак новые ошибки: Обнаружены не распределенные на производство материалы (работы) организации... во всех Подразделение: "Производство автомобилей", и Номенклатура: тип "Услуга", вид "Услуга (б/х)" (например: "Фургон-сварочные работы"). Наша АК занимается изготовлением спецтехники (закупает шасси, заказывает на заводы платформы: краны, вышки, эвакуаторы... комплектует и устанавливает), но не в этой организации. В этой только автосервис, вся номенклатура из справочника работ Альфа-Авто.
Даже не знаю где, что смотреть, подскажите..!?
   Marik1274
 
12 - 13.05.19 - 07:18
(11) Теперь отправляйтесь в распределение материалов и работ в подсистеме Производство/Внутрицеховой учет.
   Mikhail Volkov
 
13 - 13.05.19 - 07:42
(12) В этой организации нет производства, какой Внутрицеховой учет!? Подскажи, что смотреть, какой РН? Откуда-то эти ошибки формируются, откуда? Гугл ничего не нашел по этому вопросу...
Кстати, была ошибка: Обнаружены дубли видов запасов. Требуется выполнить замену дублей и удалить помеченные виды запасов. Рядом "Исправить" оформлена как гиперссылка. Давил на нее, давил... ничего не происходило, бросил давить. Это так и должно (Данные операции требуется выполнить вручную), или не так давил?
   Marik1274
 
14 - 13.05.19 - 07:47
(13) Можешь начать с просмотра РС "Задания к расчету с/с". Может, что найдешь интересное.
   Mikhail Volkov
 
15 - 13.05.19 - 11:42
Когда искал откуда формируется ошибки: Обнаружены отрицательные остатки товаров организации... вышел на
Процедура ПроверкаОтрицательныхОстатковТоваровОрганизаций(ПараметрыПроверки) Экспорт
    
    СписокПолей = Новый СписокЗначений;
    СписокПолей.Добавить("Организация");
    СписокПолей.Добавить("АналитикаУчетаНоменклатуры", НСтр("ru='Аналитика номенклатуры'"));
    СписокПолей.Добавить("ВидЗапасов",                    НСтр("ru='Вид запасов'"));
    СписокПолей.Добавить("НомерГТД",                    НСтр("ru='Номер ГТД'"));
    СписокПолей.Добавить("Количество",                    НСтр("ru='Количество'"));
    
    ПараметрыРегистрации = ИнициализироватьПараметрыРегистрацииПроблемПроверки(
        "ОтрицательныеОстатки",
        НСтр("ru='Обнаружены отрицательные остатки товаров организации ""%1"" на конец периода %2'"),
        СписокПолей);
    
    ЗарегистрироватьПроблемыВыполненияПроверки(
         ПараметрыПроверки,
        ПараметрыРегистрации,
        ЗапросОтрицательныеОстаткиТоваровОрганизаций());
    
КонецПроцедуры

В ней указан текст: ЗапросОтрицательныеОстаткиТоваровОрганизаций(), так вышел на РН ТоваровОрганизаций. А в этом случае:
Процедура ПроверкаНеобходимостиРаспределенияМатериаловИРаботНаСебестоимостьПродукции21(ПараметрыПроверки) Экспорт
    
    Если НЕ ПроверкаВыполняетсяМеханизмомЗакрытияМесяца(ПараметрыПроверки) Тогда
        Возврат;
    КонецЕсли;
    
    СписокПолей = Новый СписокЗначений;
    СписокПолей.Добавить("Организация");
    СписокПолей.Добавить("Подразделение",     НСтр("ru='Подразделение'"));
    СписокПолей.Добавить("Номенклатура",     НСтр("ru='Номенклатура'"));
    СписокПолей.Добавить("Характеристика",     НСтр("ru='Характеристика'"));
    СписокПолей.Добавить("Серия",             НСтр("ru='Серия'"));
    СписокПолей.Добавить("Количество",        НСтр("ru='Количество'"));
    
    ПараметрыРегистрации = ИнициализироватьПараметрыРегистрацииПроблемПроверки(
        "ВТНераспределенныеМатериалыИРаботы",
        НСтр("ru='Обнаружены не распределенные на производство материалы (работы) организации ""%1"" на конец периода %2'"),
        СписокПолей);
    
    ЗарегистрироватьПроблемыВыполненияПроверки(
         ПараметрыПроверки,
        ПараметрыРегистрации);
    
КонецПроцедуры

Нем такого запроса, где искать откуда формируются ошибки: Обнаружены не распределенные на производство материалы (работы) организации... не представляю!? Подскажите...
   Mikhail Volkov
 
16 - 13.05.19 - 15:51
Вроде как из ТЗ "ВТНераспределенныеМатериалыИРаботы", но где она заполняется, и чем, из каких данных? В ИнициализироватьПараметрыРегистрацииПроблемПроверки() формируется только:
    ТекстЗапросаВыборки =
    "ВЫБРАТЬ
    |    Т.Организация,
    |    Т.Подразделение,
    |    Т.Номенклатура,
    |    Т.Характеристика,
    |    Т.Серия,
    |    Т.Количество
    |Из ВТНераспределенныеМатериалыИРаботы КАК Т
    |
    |УПОРЯДОЧИТЬ ПО
    |    Т.Организация,
    |    Т.Подразделение,
    |    Т.Номенклатура,
    |    Т.Характеристика,
    |    Т.Серия,
    |    Т.Количество
    |
    |ИТОГИ ПО
    |    Организация";
А в ЗарегистрироватьПроблемыВыполненияПроверки(ПараметрыПроверки,ПараметрыРегистрации) уже из нее выбирается, и фиксируются ошибки:
Процедура ЗарегистрироватьПроблемыВыполненияПроверки(ПараметрыПроверки, ПараметрыРегистрации,
            ТекстЗапросаФормированияТаблиц = "", ДополнительныеПараметрыЗапроса = Неопределено) Экспорт
    
    ПроверкаДоРасчета    = ЗначениеДополнительногоПараметраПроверки(ПараметрыПроверки, "ПроверкаДоРасчета",    Ложь);
    ПроверкаПослеРасчета = ЗначениеДополнительногоПараметраПроверки(ПараметрыПроверки, "ПроверкаПослеРасчета", Ложь);
    
    Если ПроверкаДоРасчета ИЛИ ПроверкаПослеРасчета Тогда
        
        ПараметрыОбработчика = ИнициализироватьПараметрыОбработчикаЭтапаЗакрытияМесяцаДляПроверки(ПараметрыПроверки);
        
        Если ПроверкаДоРасчета И РасчетЭтапаНеТребуется(ПараметрыОбработчика.ДанныеЭтапа) Тогда
            Возврат;
        КонецЕсли;
        
        ПараметрыРасчета = ПараметрыОбработчика.ПараметрыРасчета;
        
    Иначе
        
        ПараметрыРасчета = ИнициализироватьПараметрыРасчетаДляПроверки(ПараметрыПроверки);
        
    КонецЕсли;
    
    МаксКоличествоОшибок = КоличествоРегистрируемыхОднотипныхОшибок();
    
    Запрос = Новый Запрос;
    
    ИнициализироватьЗапрос(
        Запрос,
        ?(ПроверкаДоРасчета ИЛИ ПроверкаПослеРасчета, ПараметрыОбработчика, ПараметрыРасчета));// получим МенеджерВременныхТаблиц

    
    ОбщегоНазначенияУТ.УстановитьПараметрыЗапроса(
        Запрос,
        ДополнительныеПараметрыЗапроса);// установим уникальные доп. параметры для проверки

    
    Если ЗначениеЗаполнено(ТекстЗапросаФормированияТаблиц) Тогда
        
        // Таблица с данными формируется не в процедуре проверки использования этапа - сформируем ее здесь.

        Запрос.Текст = ТекстЗапросаФормированияТаблиц;
        Запрос.Выполнить();
        
    КонецЕсли;
    
    Для Каждого ОписаниеРегистрации Из ПараметрыРегистрации Цикл
        
        Запрос.Текст = ОписаниеРегистрации.ТекстЗапросаВыборки;
        
        ВыборкаОрганизаций = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        
        Пока ВыборкаОрганизаций.Следующий() Цикл
            
            // Зарегистрируем проблему.

            ТекстОшибки = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                ОписаниеРегистрации.ШаблонТекстаОшибки,
                ВыборкаОрганизаций.Организация,
                ПротоколРасчетаПартийИСебестоимости.ПредставлениеПериодаРасчета(ПараметрыРасчета.ПериодРегистрации));
            
            АудитСостоянияСистемы.ДобавитьСтрокуВТаблицуВыявленныхПроблем(
                ПараметрыПроверки,
                ВыборкаОрганизаций.Организация,
                ПараметрыРасчета.ПериодРегистрации,
                ТекстОшибки);
            
            Выборка = ВыборкаОрганизаций.Выбрать();
            
            НомерОшибки = 0;
            
            Пока Выборка.Следующий() Цикл
                
                НомерОшибки = НомерОшибки + 1;
                
                Если МаксКоличествоОшибок > 0 И НомерОшибки > МаксКоличествоОшибок Тогда
                    
                    КоличествоНезарегистрированных = Выборка.Количество() - МаксКоличествоОшибок;
                    
                    ДобавитьИнформациюОНезарегистрированныхОбъектахКЗафиксированнойПроблеме(
                        ПараметрыПроверки,
                        ТекстОшибки,
                        КоличествоНезарегистрированных);
                    
                    Прервать;
                    
                КонецЕсли;
                    
                // Добавим расшифровку проблемы по объектам.

                Если ЗначениеЗаполнено(ОписаниеРегистрации.ИмяПоляОбъекта) Тогда
                    
                    ДобавитьОбъектКЗафиксированнойПроблеме(
                        ПараметрыПроверки,
                        Выборка,
                        ТекстОшибки,
                        ОписаниеРегистрации.СписокПолей,
                        ОписаниеРегистрации.ИмяПоляОбъекта);
                    
                Иначе
                    
                    ДобавитьСоставнойОбъектКЗафиксированнойПроблеме(
                        ПараметрыПроверки,
                        Выборка,
                        ТекстОшибки,
                        ОписаниеРегистрации.СписокПолей,
                        ОписаниеРегистрации.ИмяРегистраДляРасшифровки);
                    
                КонецЕсли;
                
            КонецЦикла;
            
        КонецЦикла;
        
    КонецЦикла;
    
КонецПроцедуры
   Mikhail Volkov
 
17 - 14.05.19 - 06:57
Говорят, что в КА2.4 нужно делать Распределение затрат. Что это, в КА1.1 вроде не было, или упустил?
   Фрэнки
 
18 - 14.05.19 - 08:49
(17) распределение затрат в КА 1.1 не всегда было обязательным
   Mikhail Volkov
 
19 - 14.05.19 - 09:57
(18) А в КА2.4 документ РаспределениеПроизводственныхЗатрат (Распределение материалов и работ) обязательный, даже если нет производства (для КА2.4 специально выбрал организацию ИП Автосервис без производства, оказание услуг по ремонту + продажа заменяемых запчастей)? Или в настройках подразделения, в параметрах производственного подразделения надо что-то указать? Или все равно будет создаваться документ РаспределениеПроизводственныхЗатрат, но уже автоматически? Где почитать про это? Нашел вроде https://xn----7sbabypnb5bkyfl0d.xn--p1ai/otvety-1c/raspredelenie-materialov-na-vypusk-bez-specifikaciy-v-1s-kompleksnaya-avtomatizaciya-2/, но как-то смутно...
   Mikhail Volkov
 
20 - 14.05.19 - 10:24
Наверное это: Отнесение материалов на выпуски без заказов выполняется автоматически по правилам распределения. При использовании этого способа регистрация трудозатрат по производству без распоряжений недоступно. Применяется для простых производств.
Но мне в Параметры производственного подразделения галочка "Производственное подразделение" и вкладка "Параметры производства 2.1" недоступны. Наверное в где-то в общих настойках надо указать. Но где, что?
   hhhh
 
21 - 14.05.19 - 10:29
(20) наверно, уже есть проведенные документы. Надо распровести документы, поставить галочку, а потом снова провести.
   Фрэнки
 
22 - 14.05.19 - 10:29
так 2.1 заблокировано тем, что уже перескочил на 2.4
   Mikhail Volkov
 
23 - 14.05.19 - 10:40
(21) Какие проведенные документы? документов РаспределениеПроизводственныхЗатрат вовсе нет.
(22) Ну а галочка "Производственное подразделение" почему недоступна? Вообще в верном направлении иду?
   Mikhail Volkov
 
24 - 14.05.19 - 10:51
(22) Смотрю Настройка НСИ и разделов Производство, отмечено галочкой Управление производством (версия 2.1).
   Mikhail Volkov
 
25 - 14.05.19 - 12:31
(21) Наверное все документы где используется это подразделение? Или только в новом, при создании подразделения?
Ну да, я же подразделения не руками создавал, а перетаскивал из КА1.1, а в ней нет производства. Поправил ПКО для подразделения "Производство автомобилей", поставил галочки: ПроизводственноеПодразделение и ПроизводствоБезЗаказов, теперь как надо: стоит галочка "Производственное подразделение" и вкладка "Параметры производства 2.1" доступна, на ней отмечено "По правилам распределения материалов".
Вновь запустил Закрытие месяца, все те же ошибки: Обнаружены не распределенные на производство материалы (работы) организации... Так надо делать документ РаспределениеПроизводственныхЗатрат, и как?
   Mikhail Volkov
 
26 - 14.05.19 - 12:34
Или правила распределения материалов заполнить? Где, и как?
   Mikhail Volkov
 
27 - 14.05.19 - 13:59
Найти не могу где они создаются? Наверное что-то в настройках включить надо...
   Mikhail Volkov
 
28 - 14.05.19 - 16:13
Нашел, создал https://jpegshare.net/e2/e2/e2e280e63abdbb3bd1655b91be45e9be.jpg.html по примеру https://www.ka4you.ru/index/upravlenie_zatratami/0-14 со созданной статьей калькуляции "Общепроизводственные расходы", в которой указал Тип затрат: Материальные - правильно? Но это ничего не изменило, ошибки остались...
В выше упомянутой статье (19) сказано: "Он одинаково работает в обоих версиях производства и позволяет настроить правило списания материалов на выпуск один раз и дальше оно будет работать автоматически при расчете себестоимости". Расчет себестоимости отдельно надо запускать? Не запускается при Закрытии месяца?
И в ней же упоминается: "...все списание материалов выполняется только через обработку «Распределение материалов и работ»". О какой обработке речь?
   Mikhail Volkov
 
29 - 14.05.19 - 20:52
В Альфа-Авто при выполнении сложных ремонтов иногда вынуждены к услугам сторонних организаций. Например, при изготовлении спецтехники (нового автомобиля) платформу заказывают на завод. Бывают мелкие заказы, что-то шлифовать колен-вал какой нибудь. Вроде автосервис такими услугами не пользуется, и в КА1.1 это упущено. А в КА2.4 всплыло.
   Mikhail Volkov
 
30 - 15.05.19 - 10:48
О, распровел Ввод начальных остатков переданных в производство материалов, и ошибки: Обнаружены не распределенные на производство материалы (работы) организации пропали: https://jpegshare.net/0d/60/0d60eaace8a87ced086b77e040cb689d.jpg.html
Теперь: Требуется оформление документов по учету НДС - жму Оформить, ничего не происходит!? Или пока все "Данные операции требуется выполнять вручную" не выполнишь помощник Закрытие месяца работать не будет? Помню одно время, когда не оформляли СФ частным лицам, ИП и другим, освобожденных от НДС. Наверное эти документы, но как их найти в КА2.4? Или есть какая-то процедура?
Далее: Обнаружены статьи расходов, требующих ручной настойки распределения, по организации... - опять производство, думал избавился от него!? Тут бухгалтер наверное нужен? Или можно без него обойтись?
   Marik1274
 
31 - 15.05.19 - 10:54
(30) Возможно в статье расходов статья калькуляции не указана (если распределение производственное), возможно способ распределения кривой (например нет по нему продукции). Это что касается статей расходов требующих ручной настройки. Жми подробнее и пытайся понять )
   Mikhail Volkov
 
32 - 15.05.19 - 11:37
(31) Нажал, открылось 2 Распределение расходов на себестоимость с состоянием
Требуется настройка распределения. Открыл их по очереди, нажал Провести и закрыть, состояние сменилось на Готово к распределению. Ошибки: Обнаружены статьи расходов, требующих ручной настойки распределения, по организации... исчезли!
Теперь занимаюсь ошибкой: Требуется оформление документов по учету НДС...
   Mikhail Volkov
 
33 - 15.05.19 - 12:12
Нашел обработку: ПомощникПоУчетуНДС, как раз она выдает количество Требуется оформление документов по учету НДС. С ее помощью можно найти эти документы?
 
 
   Marik1274
 
34 - 15.05.19 - 12:26
Возможно у тебя просто нет этих документов? Например не выписал с/ф. Нажми оформить и смотри, что она будет создавать.
   Buster007
 
35 - 15.05.19 - 12:49
(32) ты же вроде выше писал, что у вас там нет производства, тогда откуда взялись производственные расходы?
   Mikhail Volkov
 
36 - 15.05.19 - 12:58
(34) Куда нажать? Мне сперва найти надо документы без СФ.
(35) Вот и я недоумеваю!? Ввод начальных остатков переданных в производство материалов сформировала обработка при переносе из КА1.1 из поступлений услуг сторонних организаций при создании КА2.0. Тогда не понимал зачем... может еще что перенеслось лишнее.
   Buster007
 
37 - 15.05.19 - 13:05
(36) Ну значит косяк в переносе. В общем, если производства нет, то производственные расходы не распределятся
   shuhard
 
38 - 15.05.19 - 13:13
(37) сказочник
в ERP их можно распределить на фин.результат
   Mikhail Volkov
 
39 - 15.05.19 - 13:38
(37) В этой организации изготовления новых автомобилей нет, автосервис: только ремонты. Но при сложных ремонтах иногда вынуждены к услугам сторонних организаций (29). Это производство?

По производству пока ошибок нет, препятствующих Закрытию месяца. Сейчас надо найти документы без СФ. Напротив ошибки: Требуется оформление документов по учету НДС... кнопка Оформить для красоты, или ни так жму ее?
   Buster007
 
40 - 15.05.19 - 13:52
(39) производство - это оформление документов "Производство без заказа" или "Выпуск продукции"
   Buster007
 
41 - 15.05.19 - 13:52
+(40) ну и отчет от переработчика, не помню в КА он есть
   Фрэнки
 
42 - 15.05.19 - 14:18
(39) Производством условно считается ЛЮБАЯ деятельность, которая в терминах Бухучета ведется с использованием 20 и 21 счета.
Если Организация оказывает Услуги, по которым бухгалтера создают проводки на 20-ом - есть производство.

Это я умышленно утрирую.
   Фрэнки
 
43 - 15.05.19 - 14:22
Да и есть еще 23-счет - он тоже вполне себе настоящий производственный. Ну и 25-ый :-) от него почти никуда не денешься, после того, как заведешь Производство
   Buster007
 
44 - 15.05.19 - 14:23
(42) что там в бух учете для ерп пофиг
   Фрэнки
 
45 - 15.05.19 - 14:27
(44) вот пургу не надо плести
   Buster007
 
46 - 15.05.19 - 14:32
(45) приведи факты, что я "несу пургу"
   Mikhail Volkov
 
47 - 15.05.19 - 15:57
Ошибка: Требуется оформление документов по учету НДС (63 шт.) говорит о том, что найдено 63 документа с НДС, но без СФ - правильно понимаю?
В КА1.1 написал обработку для проверки РеализацияТоваровУслуг таких - ничего не нашла!?
Закрытие месяца эту ошибку формирует обращаясь к обработке ПомощникПоУчетуНДС:

Процедура Использование_ОформлениеСчетовФактурИТаможенныхДокументов(ПараметрыОбработчика) Экспорт
    
    ПараметрыРасчета = ПараметрыОбработчика.ПараметрыРасчета;
    
    ОрганизацииКОбработке = ОбщегоНазначенияКлиентСервер.СкопироватьМассив(ПараметрыРасчета.МассивОрганизаций);
    
    ОбщегоНазначенияКлиентСервер.УдалитьВсеВхожденияЗначенияИзМассива(
        ОрганизацииКОбработке,
        Справочники.Организации.УправленческаяОрганизация);
    
    Если ОрганизацииКОбработке.Количество() = 0 Тогда
        
        УстановитьСостояниеНеТребуется(
            ПараметрыОбработчика,
            НСтр("ru='Для управленческой организации данные документы не оформляются.'"));
        
        Возврат;
        
    КонецЕсли;
    
    ПараметрыУчетаНДС = Новый Структура;
    ПараметрыУчетаНДС.Вставить("НачалоПериода",     НачалоМесяца(ПараметрыРасчета.ПериодРегистрации));
    ПараметрыУчетаНДС.Вставить("КонецПериода",      КонецМесяца(ПараметрыРасчета.ПериодРегистрации));
    ПараметрыУчетаНДС.Вставить("МассивОрганизаций", ОрганизацииКОбработке);
    
    Результат = Обработки.ПомощникПоУчетуНДС.ОперацииПоНДСКВыполнению(ПараметрыУчетаНДС);
    
    УвеличитьКоличествоОбработанныхДанныхДляЗамера(ПараметрыОбработчика,
        Результат.НевыполненныеОперации + Результат.ОбязательныеНевыполненныеОперации);
    
    Если НЕ Результат.ЕстьОбязательныеОперацииКВыполнению Тогда
        
        УстановитьСостояниеНеТребуется(
            ПараметрыОбработчика,
            НСтр("ru='Нет неоформленных документов.'"));
        
    Иначе
        
        ТекстПояснения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
            НСтр("ru='Требуется оформление документов по учету НДС (%1 шт.)'"),
            Результат.ОбязательныеНевыполненныеОперации);
        
        УстановитьСостояниеНеВыполнен(
            ПараметрыОбработчика,
            ТекстПояснения,
            ,
            ,
            Перечисления.ВариантыВажностиПроблемыСостоянияСистемы.Ошибка);
        
    КонецЕсли;
    
КонецПроцедуры

Отладчиком сложно искать, что за документы без СФ Закрытие месяца находит, оно работает в фоновом режиме. Решил ПомощникПоУчетуНДС скопировать во внешнюю обработку, и дописать в ней поиск документов без СФ. А во внешнюю обработку не с копировался модуль менеджера, и модуль обработки пустой!?
   Mikhail Volkov
 
48 - 15.05.19 - 19:42
Дык, это СчетФактураВыданныйАванс!? У нас автосервис, с чего он решил, что мы авансы берем? Брать оплату еще за не оказанные услуги - это мошенничество.
   Mikhail Volkov
 
49 - 16.05.19 - 09:04
ПараметрыУчетнойПолитики.ПравилоОтбораАвансовДляРегистрацииСчетовФактур стоит: Исключить авансы, зачтенные в течение 5-календарных дней. У моей организации вообще не указана учетная политика. Как ее указать правильно, если патент (без НДС) на выполнение работ автосервиса, а заменяемые запчасти с НДС?
 
 Рекламное место пустует
   Mikhail Volkov
 
50 - 16.05.19 - 10:45
Создал новую с правилом отбора авансов для регистрации счетов-фактур: Исключить авансы, зачтенные до конца налогового периода, а выбрать ее в организацию не могу!?
   Mikhail Volkov
 
51 - 16.05.19 - 12:41
Но сейчас ошибки: "Требуется оформление документов по учету НДС" и все "Данные операции требуется выполнять вручную" исчезли: https://jpegshare.net/12/47/1247e508e4bb99b4f41a2091fc3d07e8.jpg.html
Что дальше, кнопки Рассчитать и Выполнить операции не действуют!? Как запустить расчет себестоимости?
   Buster007
 
52 - 16.05.19 - 13:08
(51) дата запрету сними
   Mikhail Volkov
 
53 - 16.05.19 - 14:32
(52) При переносе документов из Альфа-Авто (через КА1.1) за 2016 год перенеслись по ссылкам (в возвратах, оплатах и прочих) более ранние документы за 2015 год. Они не проведенные, но имеют записи в РС Задания к расчету себестоимости. Удалил их и процесс пошел, расчет себестоимости!
   Mikhail Volkov
 
54 - 16.05.19 - 20:01
Расчет себестоимости вроде завершился, не понял: удачно или нет? https://jpegshare.net/37/58/3758f8308fc3b98fc87da7c84bab0654.jpg.html
Дальше бухгалтер нужен счета, статьи расходов раставлять...
Смотрю Отчет по финансовому результату/Себестоимость запасов/Ведомость по партиям товаров предприятия за закрытый месяц: вроде Себестоимость заполнена в колонках прихода и расхода. Раньше только количество было.
И следующий месяц вроде запустился на закрытие... могу до текущего месяца так закрыть, или бесполезно?
   xraf
 
55 - 16.05.19 - 22:40
(54) В регистре Прочих расходов остались написано, значит они не распределились. Скорее всего дело в настройках статей.
   France
 
56 - 17.05.19 - 02:54
По организации-почти всегда из ща ндс. Тут маня давно ныл на такую организацию регистров
   Mikhail Volkov
 
57 - 17.05.19 - 12:21
(55) Да, дело в настройках статей, но я не бухгалтер... Когда бухгалтер их настроит, все по новой закрывать придется, заново расчет себестоимости за все месяца?
   Фрэнки
 
58 - 17.05.19 - 12:24
(57) а вариант ввода остатков по счетам на 31.12.2018 не собираешься рассматривать?

Т.е. "закрой" в прошлых годах все, что можно закрыть - откорректируй остатки в 31.12.2018 хотя бы даже и ручными правками операций закрытия месяца и живите спокойно уже в месяцах текущего года, не?
   Фрэнки
 
59 - 17.05.19 - 12:27
Просто не знаю, как там у вас сейчас будет получаться, но при закрытии месяца в базе с версией 1.1 и закрытием того же самого в базе с версий 2.4 суммы себестоимости в развернутой аналитике все равно выходят другие.
   Mikhail Volkov
 
60 - 17.05.19 - 14:26
(58) > а вариант ввода остатков по счетам на 31.12.2018 не собираешься рассматривать?
Это как, вручную что-ли? В правилах переноса из КА1.1 это не предусмотрено, или я упустил?
Сейчас смотрю ошибки: Формирование финансового результата: По организации ... на конец периода есть остатки по регистру прочих расходов. Открываю по Подробнее статьи доходов и расходов. Что в них заполнять: способы распределения? Их еще нет. Или Счета учета? - в счетах ни бум-бум...
Понимаю, что фин. результат пока кривой, но себестоимость придется пересчитывать, когда бухгалтер расставит статьи доходов и расходов, счета учета?
   Buster007
 
61 - 17.05.19 - 14:28
(60) не надо ничего пересчитывать.
Запустишь пункт Распределение доходов и расходов на фин. рез. и далее. Это все быстро выполняется.
   Mikhail Volkov
 
62 - 17.05.19 - 17:19
(61) Успокоил... Как бы мне автоматизировать процесс Закрытие месяца, еще 3 года закрывать? Получил зеленую галку по Расчет себестоимости, переходим к следующему месяцу...
   Mikhail Volkov
 
63 - 21.05.19 - 10:42
Рано еще на автомат Закрытие месяца ставить, некоторые месяца (а то и кварталы) перезагружать приходится. Из Альфа-Авто в КА1.1 регулярно документы перезагружаю, иногда не только документы текущего месяца, но и предыдущих, ориентируюсь по ГП в Альфа-Авто. А из КА1.1 в КА2.4 так, от случая к случаю, процесс долгий, на ночь оставляю...
С декабря КА2.4.7 потребовала обновить платформу до 8.3.13. Сейчас на сервере 8.3.10.2466 для Альфа-Авто, на более высоких она не работает https://rarus.ru/forum/messages/forum7/topic13628/message82364/#message82364. Ставить 2-й 1С-сервер (как когда-то для 8.1, 8.2) с другим диапазоном портов, отличных от стандартного 15хх - опасаюсь, что сервер ели дышит, не потянет 2-е 8.3 платформы. Да и не нужен он пока, для КА2.4.7 пока в отладке достаточно файловой. Но обе платформы 8.3, и если в параметрах базы не указан другой порт (отличный от стандартного), то 1С запускает более новую, высокую платформу. Не нарушит ли это работу пользователей Альфа-Авто?
Или если в настройках базы указать Версия 1С:Предприятия 8.3.10, то он не будет запускать 8.3.13?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует