Вход | Регистрация
    1  2  3  4  5  6  7   
1С:Предприятие :: 1С:Предприятие 8 общая

ффд 1.05 изменения 01.07.19

ффд 1.05 изменения 01.07.19
Я
   rozer76
 
11.05.19 - 11:56
привет всем, кто подскажет с 01.07.19 обязательно ли в чеке ГТД и страну выводить?
 
 
   kda26
 
401 - 01.07.19 - 10:37
(399) Читал это. Но налоговая отреагирует репрессивно.
   alex_mas
 
402 - 01.07.19 - 10:40
Смотрю описание обновлений драйверов:
10.4.0 от 04.09.2018
- Тестовое приложение

    1. На вкладку "Чек" добавлены поля для ввода новых реквизитов ФН:
        - 1227 - наименования получателя;
        - 1228 - ИНН получателя;
        - 1229 - акциз;
        - 1230 - код страны происхождения;
        - 1231 - номер таможенной декларации.

Получается в дрова поддержка этих тэгов введена давным давно.
   alex_mas
 
403 - 01.07.19 - 10:40
(399) Это их мнение. В 54-ФЗ четко обозначено требование
   rozer76
 
404 - 01.07.19 - 10:43
(396) ошибка как и была в ПолучитьПараметрыККТ..
(402) Читайте форум выше, да драйвер сам 10.4.6 отправляет все в ОФД проблема в "интеграционной компоненте" ее как раз никто и не обновил ни 1с ни атол или кто там должен ее обновить.
   rozer76
 
405 - 01.07.19 - 10:47
(392) то что 1с накрячило из БПО здесь с точки зрения ККТ в корне не поменялось ничего - только теперь при пробитии чека из ПКО вызывается модная обработка "ПредпросмотрЧека" как в ут11 а дальше объект драйвера получают все с той же "интеграционной" компоненты из внешней обработки ТО а она как была 10.4.4 так и осталась
   ЧессМастер
 
406 - 01.07.19 - 10:48
(368) Это конфа и есть Раруса
   Turku
 
407 - 01.07.19 - 10:49
Докладываю: УТэха свежая 11.4.8.73 (79 - глюкавый, да и БПО там та же 2.1.1.20). Драйвер Атол самый крайний - 10.5. Проблема в интеграц. компоненте - она лишь версии 10.4.4 (по стандарту 2.4). А чтобы эти новые реквизиты выводились, нужен стандарт 2.5.
Так что увы, не выводятся реквизиты!
   alex_mas
 
408 - 01.07.19 - 10:50
(400) Если серверная то надо включать отладку сервера. проще всего в логах драйвера посмотреть
   Kremiln
 
409 - 01.07.19 - 10:51
(407) да подсуньте компоненту из БПО свежей и будет счастье
   alex_mas
 
410 - 01.07.19 - 10:53
(407) В ДТО 10.5 лежит свежая компонента, проверьте, будет с ней бить чек?
   kda26
 
411 - 01.07.19 - 10:56
(408) Это где?
   Turku
 
412 - 01.07.19 - 10:57
Куда подсунуть-то? в ExtCOMPT копировал - без толку. А вот, если в конфигураторе загрузить этот макет атола 10 из файла, то тогда оно выдает ошибку в настройках драйвера.
   kda26
 
413 - 01.07.19 - 10:59
логи вроде как в C:\Users\[Имя пользователя]\AppData\Local\VirtualStore\Program Files\ATOL\Drivers\BIN
   alex_mas
 
414 - 01.07.19 - 11:00
(411) примерно C:\users\user111\appdata\roaming\atol\drivers\bin если win7
   alex_mas
 
415 - 01.07.19 - 11:03
(412) подключаемей оборудование - драйверы оборудования, там добавить как новый и перенастроить рабочее место, хотя наверное и через макет пойдет
   Aleksey
 
416 - 01.07.19 - 11:03
Версия 10.3.54

Торговое оборудование
Наименование и ИНН покупателя в чеках ККТ
Добавлены новые обязательные реквизиты в чеки ККТ - наименование и ИНН покупателя. Эти реквизиты заполнятся в чеке ККТ, начиная с 01.07.19, при расчетах наличными с юридическими лицами и индивидуальными предпринимателями. А также оплате по платежной карте.
Печать кода страны происхождения и номера ГТД в чеках
В чеках, пробиваемых из документа "Реализация товаров и услуг" для импортных товаров выводится код страны происхождения и номер ГТД. Страна происхождения и номер ГТД указывается при поступлении запасов.
Эти реквизиты заполнятся в чеке ККТ, начиная с 01.07.19, при расчетах за импортные товары.

Т.е. врут?
   alex_mas
 
417 - 01.07.19 - 11:06
(416) Нисколечки, поддержка в конфигурации есть, а в интеграционной компоненте нет
   rozer76
 
418 - 01.07.19 - 11:09
(407) смотрю https://its.1c.ru/db/metod8dev#content:4829:hdoc:chapter270

смотрим описание метода ПолучитьОписание (GetDescription)

ошибка в 10.3 уже в 
ОбъектДрайвера.ПолучитьОписание(НаименованиеДрайвера,
                                        ОписаниеДрайвера, 
                                        ТипОборудования, 
                                        РевизияИнтерфейса, 
                                        ИнтеграционныйКомпонент, 
                                        ОсновнойДрайверУстановлен, 
                                        URLЗагрузкиДрайвера);

все совпадает с описанием версии 2.5 но на 10.5 "интеграционной компоненте" (как я задолбался каждый раз это слово писать) ошибка 

{ОбщаяФорма.ФормаНастройкиУниверсальныйДрайвер.Форма(428)}: Значение не является значением объектного типа (ОписаниеОшибки)
        ДрайверСообщение  = РезультатВыполнения.ОписаниеОшибки;


вывод - интеграционная компонента в составе драйвера вообще ни разу не 2.5 ... она версии 3.0 што ли ?
   rozer76
 
419 - 01.07.19 - 11:10
+ (418) 

Ошибка получения описания драйвера
{ОбщийМодуль.ПодключаемоеОборудованиеУниверсальныйДрайверКлиент.Модуль(3376)}: Слишком много фактических параметров
   Turku
 
420 - 01.07.19 - 11:11
да-да, тоже ругается на Поле объекта не обнаружено (наименование), если последнюю компоненту перетащить из крайнего БПО. Но вдруг чеки будут печататься при этом. Сейчас и проверим...
   alex_mas
 
421 - 01.07.19 - 11:19
(418) А какая ревизия интерфейса передается в УТ?
   la luna llena
 
422 - 01.07.19 - 11:20
Ночью сегодня на УПП выложили 123 релиз с печатью ИНН и Названия
   kda26
 
423 - 01.07.19 - 11:27
(422) Так они и для УТ 10.3 выложили, только вот теги 1227 и 1228 не передаются.
   Turku
 
424 - 01.07.19 - 11:28
Ура!
>>10.5.0.0/10.5.0.0 (Версия требований к разработке драйверов 3.0)
Заработали новые реквизиты!
решение - заменить макет ДрайверАТОЛККТ54ФЗ10X через сравнение с файлом cf от БПО 2.1.1.23!
   kda26
 
425 - 01.07.19 - 11:35
(424) Поделись макетом или откуда его взять.
   la luna llena
 
426 - 01.07.19 - 11:37
(423) я не успела еще весь форум прочитать и накатить изменения
но у меня 1.05, я считаю, что не нужно, а бухи считают, что нужно печатать эти 1227 и 1228 ((
   rozer76
 
427 - 01.07.19 - 11:38
(425) да, пофик на макет - он у тебя в дровах 10.5 у него просто УТ11 а у тебя 10.3, вроде напал на след

там в БПО 


Попытка
            // Получаем описание драйвера

            ОбъектДрайвера.ПолучитьОписание(НаименованиеДрайвера, 
            ОписаниеДрайвера, 
            ТипОборудования, 
            РевизияИнтерфейса, 
            ИнтеграционныйКомпонент, 
            ОсновнойДрайверУстановлен, 
            URLЗагрузкиДрайвера);
            
        Исключение
            Попытка
                ОписаниеДрайвера = "";
                ОбъектДрайвера.ПолучитьОписание(ОписаниеДрайвера);
                ОписаниеДрайвераПараметры = МенеджерОборудованияВызовСервера.ПолучитьОписаниеДрайвера(ОписаниеДрайвера);
                ВерсияДрайвера            = ОписаниеДрайвераПараметры.ВерсияДрайвера;
                НаименованиеДрайвера      = ОписаниеДрайвераПараметры.НаименованиеДрайвера;
                ОписаниеДрайвера          = ОписаниеДрайвераПараметры.ОписаниеДрайвера;
                ТипОборудования           = ОписаниеДрайвераПараметры.ТипОборудования;
                ИнтеграционныйКомпонент   = ОписаниеДрайвераПараметры.ИнтеграционныйКомпонент;
                ОсновнойДрайверУстановлен = ОписаниеДрайвераПараметры.ОсновнойДрайверУстановлен;
                URLЗагрузкиДрайвера       = ОписаниеДрайвераПараметры.URLЗагрузкиДрайвера;
                // Получаем ревизию интерфейса драйвера.

                РевизияИнтерфейса = ОбъектДрайвера.ПолучитьРевизиюИнтерфейса();
            Исключение
                ВызватьИсключение ОписаниеОшибки();
            КонецПопытки;
            
        КонецПопытки;
   rozer76
 
428 - 01.07.19 - 11:40
т.е. в ОписаниеДрайвера - xml и оттуда по форматы 3.0 выдирают
   Turku
 
429 - 01.07.19 - 11:44
(425) Из БПО 2.1.1.23
В ОФД все новые реквизиты уходят. А вот гтд и код страны на чеке не печатаются. Может быть, в тесте драйвера какая галочка для этого есть?
   kda26
 
430 - 01.07.19 - 11:45
(428) Да драйвер Атол 10.5 и компонента из него подгруженная в макет последней AtolKKT.epf не дружат:

Ошибка вызова метода <ОбъектДрайвера.ПолучитьОписание>.
{ОбщийМодуль.ПодключаемоеОборудованиеУниверсальныйДрайверКлиент.Модуль(55)}: Слишком много фактических параметров
 
 Рекламное место пустует
   alex_mas
 
431 - 01.07.19 - 11:50
(430) В последней БПО
ОбъектДрайвера.НачатьВызовПолучитьОписание(ОповещениеМетода, НаименованиеДрайвера, ОписаниеДрайвера, ТипОборудования, РевизияИнтерфейса, 
ИнтеграционныйКомпонент, ОсновнойДрайверУстановлен, URLЗагрузкиДрайвера);

Т.е. кол-во параметров такое же. Как же тогда там работает?
   alex_mas
 
432 - 01.07.19 - 11:53
(430) Единственная разница, Ревизия интерфейса 2005 в новой бпо. Может ее нужно подсунуть?
   kda26
 
433 - 01.07.19 - 11:59
(431) У меня ругается на получить описание
Попытка
    // Получаем описание драйвера

    ОбъектДрайвера.ПолучитьОписание(НаименованиеДрайвера, ОписаниеДрайвера, ТипОборудования, РевизияИнтерфейса, 
                                        ИнтеграционныйКомпонент, ОсновнойДрайверУстановлен, 
       URLЗагрузкиДрайвера);
       ПараметрыПодключения.Вставить("РевизияИнтерфейса", РевизияИнтерфейса);
Исключение
   alex_mas
 
434 - 01.07.19 - 12:06
(433) Там просто асинхронно работает, это то же самое
   kda26
 
435 - 01.07.19 - 12:08
С интеграционной компонентой от 1С ошибок нет и тегов нет ) Как быть-то...
   alex_mas
 
436 - 01.07.19 - 12:10
Проморгал, все обернуто в попытка-исключение, в (427) это же написал
        Попытка
            НоваяАрхитектура          = Ложь;
            НаименованиеДрайвера      = "";
            ОписаниеДрайвера          = "";
            ТипОборудования           = "";
            ИнтеграционныйКомпонент   = Ложь;
            ОсновнойДрайверУстановлен = Ложь;
            РевизияИнтерфейса         = МенеджерОборудованияКлиентПовтИсп.РевизияИнтерфейсаДрайверов();
            URLЗагрузкиДрайвера       = "";
            ОповещениеМетода = Новый ОписаниеОповещения("ПолучитьОписаниеЗавершение", ЭтотОбъект);
            ОбъектДрайвера.НачатьВызовПолучитьОписание(ОповещениеМетода, НаименованиеДрайвера, ОписаниеДрайвера, ТипОборудования, РевизияИнтерфейса, 
                                            ИнтеграционныйКомпонент, ОсновнойДрайверУстановлен, URLЗагрузкиДрайвера);
        Исключение
            // Получаем описание драйвера по новому стандарту

            ОписаниеДрайвера = "";
            ОповещениеМетода = Новый ОписаниеОповещения("ПолучитьОписаниеНовыйЗавершение", ЭтотОбъект, ОбъектДрайвера);
            ОбъектДрайвера.НачатьВызовПолучитьОписание(ОповещениеМетода, ОписаниеДрайвера);
        КонецПопытки;

Т.е. теперь передается 1 параметр!!!
   vladmenleo
 
437 - 01.07.19 - 12:50
(415) У меня заработало через подключение внешнего драйвера от атола версии 10.5. Но! При установке внешнего драйвера в тесте оборудования все равно показывает версию 10.4.6. Чтобы подхватились драйвера пришлось в профиле, в папке Roaming\1C\1cv8\ExtCompT удалить все драйвера ккт кроме fptr10_1c_win32_10_5_0_0.dll. Такое впечатление, что если раньше на рабочем месте стояло подключенное оборудование, то 1с брала первый по алфавиту драйвер :)
   rozer76
 
438 - 01.07.19 - 12:52
(437) и толку - я подключил к 10.3 дрова 10.5 а теперь сижу и ручками из БПО переношу ОткрытьСмену, ЗакрытьСмену и т.д. ибо в типоваой нет кода для ревизииинтерфейса >3003
   kda26
 
439 - 01.07.19 - 12:54
(438) Какой релиз УТ 10.3 используешь?
   rozer76
 
440 - 01.07.19 - 13:00
(439) крайний, см в ПодключаемоеОборудованиеУниверсальныйДрайверКлиент  - ОткрытьСмену там все только для ПараметрыПодключения.РевизияИнтерфейса > 2001
   rozer76
 
441 - 01.07.19 - 13:01
пока переделал подкл. драйвера, открытие смены надо еще закрытиесмены, фискализировать чек, x и z отчеты и так по мелочи ...
   vladmenleo
 
442 - 01.07.19 - 13:02
(438) У нас Ут 11.4
   kda26
 
443 - 01.07.19 - 13:13
(441) Т.е. ты допиливаешь крайний релиз УТ 10.3.54.1, чтобы оно работало с интеграционной компонентой от атолла?
   rozer76
 
444 - 01.07.19 - 13:22
(443) да, если бы знач что 1с не разродится к 01.07 уже две недели назад надо было из БПО переносить
   rozer76
 
445 - 01.07.19 - 13:23
(443) на самом деле у нас типо древняя 10.3 я взять чистую УТ 10.3.54.1 и уже думаю за 5 мин перенесу и... фиг...
   alex_mas
 
446 - 01.07.19 - 13:25
(441) Из какой БПО берете код?
По сути изменения копеешные, но надо все внимательно делать. Тоже пока только подключение драйвера переделал.
   rozer76
 
447 - 01.07.19 - 13:29
(446) 2.1.1.23
   rozer76
 
448 - 01.07.19 - 13:30
+ (447) есть варианты ? ))
   Turku
 
449 - 01.07.19 - 13:35
Ребят, есть все-таки идеи, почему на печать не выводятся код страны и гтд? В ОФД все ок. Если в ОФД реквизиты есть, значит из 1С оно в драйвер ККМ приходит. Галочки "выводить гтд на пеечать" в тесте драйвера не обнаружил...
   kda26
 
450 - 01.07.19 - 13:37
(449) У нас все отечественное ГТД не используем.
   rozer76
 
451 - 01.07.19 - 13:40
(449) в ЦТО набери - в штрихе в таблице 17 это а в атоле хз
   alex_mas
 
452 - 01.07.19 - 13:40
(448) Просто она зараза асинхронно написана
   alex_mas
 
453 - 01.07.19 - 13:41
(449) Может они и не должны в бумажном чеке быть, как например ИНН кассира
   rozer76
 
454 - 01.07.19 - 13:42
(452) это не при чем, посмотри (440+) и сравни с 10.3
   rozer76
 
455 - 01.07.19 - 13:42
(449) а вообще законы читайте даже для ффд1.1 это обязательно только в электроне
   alex_mas
 
456 - 01.07.19 - 13:44
(454) А, я на этот метод наткнулся ОбъектДрайвера.НачатьВызовПолучитьОписание и подумал что все так сделано))
   kda26
 
457 - 01.07.19 - 13:45
(445) Хм. У нас тоже далеко не свежак 10.3.50.2, думал впилю заполнение тегов 1227, 1228 и вуаля. Нехотелось с обновлением морочиться. Тем более, что последний релиз от 30.06.2019, т.е. вчера. И он тоже как показывает жизнь с компонентой от 1С не того...
   kda26
 
458 - 01.07.19 - 13:52
Резюмируя.
1. Обновляемся на крайний релиз 10.3.54.1 (а). Ну там по сути подсистема ТО нас интересует.
2. Берем компоненту из поставки драйвера атолл (что в папке 1С) , зипуем в архив, загоняем ее в макет обработки AtolKKT.epf
3. Перепиливаем типовую по подобию БПО 2.1.1.23
4. Ловим и отлаживам баги.
   dimension71
 
459 - 01.07.19 - 13:52
Тем временем у АТОЛа на форуме появилось:
    
Компонента 1С для БПО 2.5
с поддержкой тэгов 1227, 1228, 1229, 1230, 1231
http://forum.atol.ru/index.php?showtopic=34345

только это под десятые дрова, а что делать кто на УТ 10.3 под девятыми?
   karpik666
 
460 - 01.07.19 - 13:52
(457) не хотите заморачиваться с обновлением - не надо, воспользуйтесь обработкой http://catalog.mista.ru/public/590993/?ref=1050 , я уже заморочился за вас=)
   karpik666
 
461 - 01.07.19 - 13:54
(460) Поддерживает передачу новых тего для оборудования АТОЛ, ШтрихМ и Веб-сервера АТОЛ.
   kda26
 
462 - 01.07.19 - 13:56
(459) Спасибо за инфу. Попробую ее прикрутить.
   Йохохо
 
463 - 01.07.19 - 14:01
(459) это у них теперь ТАКОЙ канал распространения? с фс.атол.ру нифига не скачать
   kda26
 
464 - 01.07.19 - 14:01
(459) Стоп. Что это за БПО 2.5. Текущая актуальная 2.1.1.23, далее в плане 3.
   alex_mas
 
465 - 01.07.19 - 14:03
(464) опечатка наверное. Зачем она,без поддержки конфой
   kda26
 
466 - 01.07.19 - 14:08
(465) Подумал, что это под версию обработки 2.5
 
 Рекламное место пустует
   karpik666
 
467 - 01.07.19 - 14:17
а у всех отображается в этой компоненте в поле версия "0.0.0-237-ge854872-alpha"
   Inco
 
468 - 01.07.19 - 14:24
(467) да
   kda26
 
469 - 01.07.19 - 14:31
(465) А ведь компонента подключалась без ошибок как в (430), щас попробую открыть смену и пробить чек.
   kda26
 
470 - 01.07.19 - 14:36
(467) это плохо?  о_О
   alex_mas
 
471 - 01.07.19 - 14:36
(469) внутри другая компонента fptr10_1c_win32_0_0_0_237.dll, интересно
   alex_mas
 
472 - 01.07.19 - 14:42
(469) Получилось что-нибудь?
   kda26
 
473 - 01.07.19 - 14:50
(472) Смена открылась без ошибок. Щас бухи чек подготовят на физлицо, а не на юрика. По результату отпишусь.
   karpik666
 
474 - 01.07.19 - 14:52
(473) у себя проверил, все работает.
   alex_mas
 
475 - 01.07.19 - 14:52
(474) А если юрик, выводит ИНН?
   kda26
 
476 - 01.07.19 - 14:54
При пробитии чека...
Ошибка программирования реквизита 1228 (Недопустимый РНМ и/или ИНН)
Не удалось распечатать чек Чек ККМ ИК000004412 от 01.07.2019 14:48:28! Чек помечен на удаление!
Не удалось провести и распечатать весь список чеков! Повторите процедуру для необработанных документов!
Ну там и правда ИНН 1111111111
Ну то есть тег прихватился. Что обнадеживает.
   karpik666
 
477 - 01.07.19 - 14:56
(475) также нормально, сейчас проверял у клиента с выводом информации о получателе
   kda26
 
478 - 01.07.19 - 14:56
(475) Юрика еще не били. Осторожничаем. Как по минному полю )
   alex_mas
 
479 - 01.07.19 - 15:00
(477) А, так это из вашей обработки?
   kda26
 
480 - 01.07.19 - 15:01
(475) Все ОК. Юрик и его ИНН отразились в чеке. Пошел за вискарем)
   karpik666
 
481 - 01.07.19 - 15:03
(479) ну да, но значит компонента поддерживает эту передачу
   kda26
 
482 - 01.07.19 - 15:03
В ОФД тоже прилетело.
   kda26
 
483 - 01.07.19 - 15:05
Короче берите компоненту из (459) спасибо доброму человеку. Зипуйте и загоняйте в макет обработки.
   kda26
 
484 - 01.07.19 - 15:12
Ну и еще по коду в ПолучитьXMLПакетДляФискализацияЧека_ТО и ПолучитьXMLПакетДляФискализацияЧека
добавить строки

    Если Не ПустаяСтрока(ОбщиеПараметры.Получатель) Тогда
        ЗаписьXML.ЗаписатьАтрибут("CustomerInfo", XMLСтрока(ОбщиеПараметры.Получатель));
    КонецЕсли;
    Если Не ПустаяСтрока(ОбщиеПараметры.ПолучательИНН) Тогда
        ЗаписьXML.ЗаписатьАтрибут("CustomerINN", XMLСтрока(ОбщиеПараметры.ПолучательИНН));
    КонецЕсли;

В модуле дока ЧекККМ 
Процедура ПодготовитьДанныеДляФискализацииЧека(ЧекККМ, ОбщиеПараметры, ДопДанные, ТО)

 ОрганизацияЧека = ЧекККМ.КассаККМ.Владелец;
 КонтрагентЧека = ЧекККМ.Контрагент;
 ...
    ОбщиеПараметры.ОрганизацияИНН = ОрганизацияЧека.ИНН;
    ОбщиеПараметры.ОрганизацияКПП = ОрганизацияЧека.КПП;

    ОбщиеПараметры.Получатель = КонтрагентЧека.Наименование;
    ОбщиеПараметры.ПолучательИНН = КонтрагентЧека.ИНН;


Собственно и всё.
   alex_mas
 
485 - 01.07.19 - 15:16
(480) Поздравляю!!! Я уже собрался переписывать все)))
   rozer76
 
486 - 01.07.19 - 15:52
(458) ха, переписал как в БПО и СформироватьXMLПакетДляФискализацияЧека родная - (484) не надо

Все получилось с родной интеграционной компонентой от 10.5
 

да и к (484) еще гтд и страну добавить надо 

Если ТекущаяПозиция.Свойство("КодСтраныПроисхожденияТовара") И НЕ ПустаяСтрока(ТекущаяПозиция.КодСтраныПроисхожденияТовара) Тогда
                        ЗаписьXML.ЗаписатьАтрибут("CountryOfOrigin", XMLСтрока(ТекущаяПозиция.КодСтраныПроисхожденияТовара));
                    КонецЕсли;
                    Если ТекущаяПозиция.Свойство("НомерТаможеннойДекларации") И НЕ ПустаяСтрока(ТекущаяПозиция.НомерТаможеннойДекларации) Тогда
                        ЗаписьXML.ЗаписатьАтрибут("CustomsDeclaration", XMLСтрока(ТекущаяПозиция.НомерТаможеннойДекларации));
                    КонецЕсли;
   rozer76
 
487 - 01.07.19 - 15:52
ну а за (459) респект атолу конечно
   karpik666
 
488 - 01.07.19 - 15:58
(487) за что спасибо? за то что они выпустили неработающую компоненту для 3000 ревизии, спасибо конечно, что-то Штрих выпустили свою компоненту в срок, и слова плохого не услышал.
   rozer76
 
489 - 01.07.19 - 16:04
(488) компонента рабочая для 3000 ревизии - если взять код из БПО все ок
   rozer76
 
490 - 01.07.19 - 16:05
+ (489) дело не в атоле а в 1с (как бы я ее не уважал)
   Йохохо
 
491 - 01.07.19 - 16:24
(483) спасибо, с подменой из (459) ругается, но чеки бьет. 5 чеков в месяц даже с поддержки не буду снимать
   karpik666
 
492 - 01.07.19 - 16:33
(489) просто вы с ними не сталкивались,
например, неправильно возвращается статус смены, нельзя сформировать x отчет, внесение и выемку.
   alex_mas
 
493 - 01.07.19 - 16:45
(486) А Вы переписали каким образом, все в блоке:
Если РевизияИнтерфейса >= 2002 Тогда
без отсутствия совместимости со старым драйвером?
или так же ветвили
Если РевизияИнтерфейса >= 3000 Тогда// Версия стандарта 3.0 (ОФД 1.1)


просто не понял какую ревизию вернет драйвер
   rozer76
 
494 - 01.07.19 - 16:56
(493) взял код из БПО

например ЗакрытьСмену


Функция ЗакрытьСмену(ОбъектДрайвера, Параметры, ПараметрыПодключения, ВходныеПараметры, ВыходныеПараметры)
    
    Результат = Истина;
    РезультатСостояние = Ложь;
    Кассир = ?(ВходныеПараметры <> Неопределено И ВходныеПараметры.Свойство("Кассир"), ВходныеПараметры.Кассир, НСтр("ru='Администратор'"));
    НомерСмены     = 0;
    НомерДокумента = 0;
    СтатусСмены    = 0;
    ФискальныеДанныеСтруктура = Неопределено;
    ПараметрыСостояния = Неопределено;
    ПараметрыОперации = МенеджерОборудованияВызовСервера.ПолучитьXMLПакетДляОперации(ВходныеПараметры);
    РевизияИнтерфейса  = ПараметрыПодключения.РевизияИнтерфейса;
    
    Попытка
        Если РевизияИнтерфейса >= 3000 Тогда// Версия стандарта 3.0 (ОФД 1.1)

            Результат = ОбъектДрайвера.ЗакрытьСмену(ПараметрыПодключения.ИДУстройства, ПараметрыОперации, ПараметрыСостояния);
            Если Результат Тогда
                ФискальныеДанныеСтруктура = МенеджерОборудованияВызовСервера.ПолучитьПараметрыСменыИзXMLПакета(ПараметрыСостояния, РевизияИнтерфейса);
                НомерСмены     = ФискальныеДанныеСтруктура.НомерСменыККТ;
                НомерДокумента = ФискальныеДанныеСтруктура.НомерЧекаККТ;
            КонецЕсли;
        Иначе
            Если РевизияИнтерфейса >= 2002 Тогда// Версия стандарта 2.2 (ОФД 1.0.5)

                Результат = ОбъектДрайвера.ЗакрытьСмену(ПараметрыПодключения.ИДУстройства, ПараметрыОперации, ПараметрыСостояния, НомерСмены, НомерДокумента);
                Если Результат Тогда
                    ФискальныеДанныеСтруктура = МенеджерОборудованияВызовСервера.ПолучитьПараметрыСменыИзXMLПакета(ПараметрыСостояния);
                    ФискальныеДанныеСтруктура.НомерСменыККТ = НомерСмены;
                    ФискальныеДанныеСтруктура.СтатусСмены   = 1;// Открыта

                КонецЕсли;
            Иначе
                Кассир = ?(ВходныеПараметры <> Неопределено И ВходныеПараметры.Свойство("Кассир"), ВходныеПараметры.Кассир, НСтр("ru='Администратор'"));
                Результат = ОбъектДрайвера.ЗакрытьСмену(ПараметрыПодключения.ИДУстройства, Кассир, НомерСмены, НомерДокумента);
                Если Результат Тогда
                    ФискальныеДанныеСтруктура = МенеджерОборудованияВызовСервера.ПолучитьПараметрыСменыИзXMLПакета(ПараметрыСостояния);
                    ФискальныеДанныеСтруктура.НомерСменыККТ = НомерСмены;
                    ФискальныеДанныеСтруктура.СтатусСмены   = 1;// Открыта

                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    Исключение
        Результат = Ложь;
        ВыходныеПараметры.Очистить();
        ВыходныеПараметры.Добавить(999);
        ВыходныеПараметры.Добавить(НСтр("ru='Ошибка вызова метода <ОбъектДрайвера.ЗакрытьСмену>.'") + Символы.ПС + ОписаниеОшибки());
        Возврат Результат;
    КонецПопытки;
    
    Если Результат Тогда
        // Заполнение выходных параметров.

        ВыходныеПараметры.Очистить();
        ВыходныеПараметры.Добавить(НомерСмены);
        ВыходныеПараметры.Добавить(НомерДокумента);
        ВыходныеПараметры.Добавить(1);// 1 - Закрыта - Состояние смены  

        ВыходныеПараметры.Добавить(ТекущаяДата());
        ВыходныеПараметры.Добавить(ФискальныеДанныеСтруктура);
        ВыходныеПараметры.Добавить(ПараметрыСостояния);
    Иначе
        ВыходныеПараметры.Очистить();
        ВыходныеПараметры.Добавить(999);
        ВыходныеПараметры.Добавить("");
        ОбъектДрайвера.ПолучитьОшибку(ВыходныеПараметры[1]);
    КонецЕсли;
    
    Возврат Результат;

КонецФункции
   rozer76
 
495 - 01.07.19 - 17:08
в драйвере нашел что глючит ShiftState смены и всегда "1" типо закрыта
   rozer76
 
496 - 01.07.19 - 17:20
+ (495) правда это на МГМ, посмотрите что у вас возвращает при команде "ПолучитьТекущееСостояние"
   alex_mas
 
497 - 01.07.19 - 17:36
(496) РевизияИнтерфейса  = ПараметрыПодключения.РевизияИнтерфейса
у вас какую ревизию возращает?  Это сама компонента выдает или драйвер кассы?
   rozer76
 
498 - 01.07.19 - 18:21
(497) 3003
   rozer76
 
499 - 01.07.19 - 18:22
(497) это родная компонента 3.0 от дров 10.5
   alex_mas
 
500 - 01.07.19 - 18:23
(499) А, все теперь понял, благодарю
  1  2  3  4  5  6  7   

Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.