Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: запрет/разрешение доступа к реквизиту формы

v7: запрет/разрешение доступа к реквизиту формы
Я
   alpha78
 
11.05.19 - 09:49
здравствуйте, создаю обработку в 77 положил на форму флаг
нужно при включении флага чтоб включался доступ к реквизиту, а при снятии птички - доступ запрещался
вот код, только при включении - выключении птички ничего не работает постоянный запрет редактирования
модуль внешней обработки:
//*******************************************
Перем ДляЗаписи;
Функция Запись()
  
    Если ДляЗаписи=1
    Тогда
        Форма.Контра.Доступность(1);
    Иначе Форма.Контра.Доступность(0);
    КонецЕсли;
    
КонецФункции    

Процедура Сформировать()

КонецПроцедуры
                  
// по умолчанию запись запрещена
Форма.Контра.Доступность(0);
 
 
   Slypower
 
1 - 11.05.19 - 10:00
Так функцию нужно прописывать на флаг
   Slypower
 
2 - 11.05.19 - 10:00
и достаточно процедуры
   Злопчинский
 
3 - 11.05.19 - 10:54
Какой смысл в запрещении если это запрещение в любой момент сам юзер может обойти поставив или сняв галку?
   Rie
 
4 - 11.05.19 - 11:16
(0) Вообще не нужна никакая функция. В формуле для флага написать
Форма.Контра.Доступность(ДляЗаписи)

(3) Может, чтобы случайно чего не поправил? Ткнул, не глядя, нажал клавишу, опять же, не глядя, а при закрытии формы - машинально ответил "Да"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует