Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: вычисление функции во внешнем отчете ert в 1с77

v7: вычисление функции во внешнем отчете ert в 1с77
Я
   alpha78
 
09.05.19 - 07:54
Добрый день, такая проблема - создал внешний отчет для вычисления функции Факториал
на форму положил 2 текстовых поля с числовыми значениями Число1 - число , факториал которого нужно вычислить и Число2 - результат
Расчет должен производиться по кнопке Сформировать.
вот ее код:

Функция Факториал(Чис)  
           Если Чис = 0
                   Тогда Возврат 0
           КонецЕсли;    
        Возврат Чис * Факториал(Чис-1);           
КонецФункции

Процедура Сформировать()                      
    Число2= Факториал(Число1);  
КонецПроцедуры

при запуске обработки в 1с результат 0 не вычисляет, что я не то делаю, помоги те новичку спасибо
 
 
   Rie
 
1 - 09.05.19 - 08:02
(0) Вообще-то 0! = 1. А никак не 0.
Зато 0 * ЧтоУгодно = 0.
Вот и...
   МимохожийОднако
 
2 - 09.05.19 - 08:12
ОФФ: Где это может пригодится для учёта?
Если поступить по-индусски, то достаточно загнать готовую таблицу в функцию )
   alpha78
 
3 - 09.05.19 - 08:30
согласен спасибо
   Rie
 
4 - 09.05.19 - 08:36
(3) И не надо вычислять факториал рекурсивной функцией.
Рекурсия - замечательная вещь. Но только тогда, когда она уместна. В данном случае ей лучше не пользоваться.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.