Вход | Регистрация
    1  2   

{(1)}: Ошибка при вызове метода контекста (НайтиПоНаименованию)

{(1)}: Ошибка при вызове метода контекста (НайтиПоНаименованию)
Я
   falselight
 
08.05.19 - 14:09
Ошибка выдается вот на эту строку

Справочники.Номенклатура.НайтиПоНаименованию("Хлеб",1)

Из за чего это?
 
 
   butterbean
 
1 - 08.05.19 - 14:10
дык та же написано что за ошибка, хотя и так видно, что кривой второй параметр
   falselight
 
2 - 08.05.19 - 14:13
(1) Второй параметр, истина или 1 может же быть?!
   1Сергей
 
3 - 08.05.19 - 14:14
(2) CTRL+F1
   falselight
 
4 - 08.05.19 - 14:20
(3) И что там? Всегдя так пользовался.

Разбираюсь. Гружу большой файл.
   sqr4
 
5 - 08.05.19 - 14:22
(4) вместо булево число пихал?
   butterbean
 
6 - 08.05.19 - 14:23
(4) ты бы хоть описание ошибки озвучил, там же все написано
   falselight
 
7 - 08.05.19 - 14:23
(5) Булево эквивалент 1, 0
   falselight
 
8 - 08.05.19 - 14:24
(6) не тот индекс сувал видимо, гружу далее
   Tonik992
 
9 - 08.05.19 - 14:26
(7) Если сигнатура метода предполагает определенный тип переменной, то он должен быть именно таким.
Не надо искать какие-то другие доводы.
   falselight
 
10 - 08.05.19 - 14:27
Реально ругается!!!! То находит то нет!!!!!!
 
 Рекламное место пустует
   falselight
 
11 - 08.05.19 - 14:28
(9) На это такая же ошибка!!!

Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию(МассивКолонок[4], Истина)
   sqr4
 
12 - 08.05.19 - 14:29
(9) а чему будет равно (не 1)
А (не 0) ?
   sqr4
 
13 - 08.05.19 - 14:29
(11) похоже не строка в наименование идет?
   sqr4
 
14 - 08.05.19 - 14:30
Остановка по ошибке все как надо показывает?
   falselight
 
15 - 08.05.19 - 14:31
Вот проверяю

НайденнаяБазоваяЕдиницаИзмерения = Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию(МассивКолонок[4], 1); 

Все находит. И идет строка "шт"

И находится элемент. Но на одном месте ломается ((((

Отладчик показывает что так же идет строка "шт"

И там, на родителе тоже.
   Tonik992
 
16 - 08.05.19 - 14:32
(12) Есть сигнатура метода. Лучше придерживаться её.
   mikecool
 
17 - 08.05.19 - 14:32
сборище телепатов
   falselight
 
18 - 08.05.19 - 14:33
(16) Не имеет значения. Дело не в этом. Если писать истина, такая же ошибка.
Я пытаюсь понять в чем причина?!
   Tonik992
 
19 - 08.05.19 - 14:37
(18) такая же, это какая? скрин давайте сюда
   mikecool
 
20 - 08.05.19 - 14:38
(19) не спугни, пусть найдет
   sqr4
 
21 - 08.05.19 - 14:38
(15) кроме как неограниченной строки не могу ничего предположить
   falselight
 
22 - 08.05.19 - 14:41
Гружу файл. Просмотрел как грузятся проблемные места все нормально.
Находятся элементы и прописываются.
Отлавливаю проблему.
Когда функция просто не отрабатывает, поиска по наименованию (((
Хотя так же все нормально передается туда для поиска.
   palsergeich
 
23 - 08.05.19 - 14:42
Потому что может быть не "хлеб"
А "хлеб "
Визуально одно и тоже, но при поиске по полному соответствию это не одно и то же.
Вариантов невидимых символов достаточно много, причем некоторые могут крашить сеанс
   falselight
 
24 - 08.05.19 - 14:44
(23) Я их отлавливаю. Должно быть все нормально, без пробелов!
   falselight
 
25 - 08.05.19 - 14:45
Вот сломалось, -

МассивКолонок[4] = "шт"   - как и всегда

Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию(МассивКолонок[4], 1) = Ошибка при вызове метода контекста (НайтиПоНаименованию)

Почему? И на родителе так же.
   palsergeich
 
26 - 08.05.19 - 14:45
А может быть что часть символов не в том языке.
Постоянно такое с буквой с
   falselight
 
27 - 08.05.19 - 14:46
(26) Ну так найдена была бы пустая ссылка, но не ошибка.
То работает то нет. Так же строка передается!
   palsergeich
 
28 - 08.05.19 - 14:47
(27) а там для подчинённых справочников разве не надо владельца указывать?
   falselight
 
29 - 08.05.19 - 14:48
БазовыеЕдиницыИзмерения - независимый справочник!
   falselight
 
30 - 08.05.19 - 14:49
И тут ошибка

                Если МассивКолонок[23] <> "" Тогда
                    ЭлементНоменклатуры.Родитель = Справочники.Номенклатура.НайтиПоНаименованию(МассивКолонок[23], 1);
                КонецЕсли;


МассивКолонок[23] = "СЫР" , все должно работать. Или находит элемент или пустую ссылку.
Веть до работало.

А на 2991 элементе ломается!
   palsergeich
 
31 - 08.05.19 - 14:49
Глупый вопрос: зачем тогда для каждой строки делать поиск для справочника?
Сделай соответствие символьного представления и ссылки
   falselight
 
32 - 08.05.19 - 14:50
(31)  Это перегрузка. Для каждой строки свои данные. Вопрос не в этом.
   sqr4
 
33 - 08.05.19 - 14:51
(24) все же сомнения терзают, там не пробел будет, а нечитаемый неправильный вызывающий ошибку символ, который СОКРЛП не отловит и СТРЗаменить
 
 
   falselight
 
34 - 08.05.19 - 14:52
На этой строке ломается. Ну и что тут не так?
"Эл.","00000968","Набор для приготовления Адыгейского сыра","","шт","0","Товар (пр. ТМЦ)","","0","0","","шт","","Набор для приготовления Адыгейского сыра","Без НДС","Без налога","","","","0","","","0","СЫР","00000975"
   falselight
 
35 - 08.05.19 - 14:52
Все как нужно!
   falselight
 
36 - 08.05.19 - 14:52
(33) "шт" - тут какой может быть пробел?
   palsergeich
 
37 - 08.05.19 - 14:53
(32) Да посрать что это)
Один раз шт. создал, во второй ее точно создавать не будешь. Ну и закешируй.
Это хотя бы с точки зрения оптимизации очевидное решение.
А так как телепатические митохондрии на сегодня у меня устали могу сказать одно.
Или делай устойчивый пример с ошибкой, которую можно воспроизвести на демо, или иди на v8@1c.ru
   palsergeich
 
38 - 08.05.19 - 14:54
(34) Да понятия не имею.
Без кода, без возможности воспроизвести - это шоу "Экстрасенсы"
   mikecool
 
39 - 08.05.19 - 14:54
надо больше восклицательных знаков и меньше рассказывать о проблеме!!!
   falselight
 
40 - 08.05.19 - 14:55
(38)  

                Если МассивКолонок[4] <> "" Тогда
                    НайденнаяБазоваяЕдиницаИзмерения = Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию(МассивКолонок[4], 1); 
                    Если НайденнаяБазоваяЕдиницаИзмерения <> Справочники.БазовыеЕдиницыИзмерения.ПустаяСсылка() Тогда
                        ЭлементНоменклатуры.ЕдиницаИзмерения = НайденнаяБазоваяЕдиницаИзмерения;
                    КонецЕсли;
                КонецЕсли;
   НЕА123
 
41 - 08.05.19 - 14:57
а мне нравится ветка. настоящая пятница.
   palsergeich
 
42 - 08.05.19 - 14:57
(40) И что?
Может У тебя СТРРАЗДЕЛИТЬ(Строка,",",Истина)
   falselight
 
43 - 08.05.19 - 14:58
(37) Шт есть в справочнике, не создавал, а просто нахожу
   palsergeich
 
44 - 08.05.19 - 14:58
(42) Ой Может У тебя СТРРАЗДЕЛИТЬ(Строка,",",ЛОЖЬ)
Баз кода полного и нормального примера иди на v8@1c.ru
   falselight
 
45 - 08.05.19 - 14:59
(44) Сейчас отлаживаю эту процедуру, по нажатию кнопке. Ошибки в ней.


&НаСервере
Процедура ЗагрузитьНоменклатуруНаСервере()
    СчЭл  = 1;
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать(ИмяФайлаЗагрузкиНоменклатуры);
    НачатьТранзакцию();
    Для НомерСтроки = 1 по Текст.КоличествоСтрок() Цикл
        Строка        = Текст.ПолучитьСтроку(НомерСтроки);
        МассивКолонок = РазложитьСтрокуВМассивПодстрок(Строка, Разделитель);
        //

        Для Индекс = 0 По МассивКолонок.Количество() - 1 Цикл
            МассивКолонок[Индекс] = СтрЗаменить( МассивКолонок[Индекс], """", "" );
        КонецЦикла;
        //

        Если МассивКолонок[0] = "Гр." Тогда
            //

            // Группа                  // 1.  [0]

            // Код                     // 2.  [1]

            // Наименование            // 3.  [2]

            //

            // Артикул                // 4.  [3]

            // БазоваяЕдиница         // 5.  [4]

            // Весовой                // 6.  [5]

            // ВидНоменклатуры        // 7.  [6]

            // Комментарий            // 8.  [7]

            // МинОстаток             // 9.  [8]

            // НеВключатьВпрайс       // 10. [9]

            // НомерГТД               // 11. [10]

            // ОсновнаяЕдиница        // 12. [11]

            // ОсновноеСвойство       // 13. [12]

            // ПолнНаименование       // 14. [13]

            // СтавкаНДС              // 15. [14]

            // СтавкаНП               // 16. [15]

            // СтранаПроисхождения    // 17. [16]

            // Производитель          // 18. [17]

            // Импортер               // 19. [18]

            // АлкогольнаяПродукция   // 20. [19]

            // ВидПродукции           // 21. [20]

            // ВидЛицензии            // 22. [21]

            // КоэффПересчетаДал      // 23. [22]

            //                               

            // Родитель.Наименование  // 24. [23]        

            // Родитель.Код           // 25. [24]        

            //

            НайденнаяГруппа = Справочники.Номенклатура.НайтиПоНаименованию(МассивКолонок[2],1);
            Если НайденнаяГруппа = Справочники.Номенклатура.ПустаяСсылка() Тогда 
                ГруппаНоменклатуры                       = Справочники.Номенклатура.СоздатьГруппу();
                ГруппаНоменклатуры.Наименование       = МассивКолонок[2];
                //ГруппаКонтрагентов.НаименованиеПолное = МассивКолонок[2];

                //ГруппаНоменклатуры.Наименование       = СтрЗаменить( МассивКолонок[2], """", "" );

                Если МассивКолонок[11] <> "" Тогда
                    ГруппаНоменклатуры.Родитель = Справочники.Номенклатура.НайтиПоНаименованию(МассивКолонок[23], 1);
                КонецЕсли;
                ГруппаНоменклатуры.Записать();
                Сообщить("Создана группа " + ГруппаНоменклатуры.Наименование);
            Иначе
                Сообщить("Пропущена группа " + МассивКолонок[2]);
            КонецЕсли;
        ИначеЕсли МассивКолонок[0] = "Эл." Тогда
            //

            // Элемент                  // 1.  [0]

            // Код                     // 2.  [1]

            // Наименование            // 3.  [2]

            //

            // Артикул                // 4.  [3]

            // БазоваяЕдиница         // 5.  [4]

            // Весовой                // 6.  [5]

            // ВидНоменклатуры        // 7.  [6]

            // Комментарий            // 8.  [7]

            // МинОстаток             // 9.  [8]

            // НеВключатьВпрайс       // 10. [9]

            // НомерГТД               // 11. [10]

            // ОсновнаяЕдиница        // 12. [11]

            // ОсновноеСвойство       // 13. [12]

            // ПолнНаименование       // 14. [13]

            // СтавкаНДС              // 15. [14]

            // СтавкаНП               // 16. [15]

            // СтранаПроисхождения    // 17. [16]

            // Производитель          // 18. [17]

            // Импортер               // 19. [18]

            // АлкогольнаяПродукция   // 20. [19]

            // ВидПродукции           // 21. [20]

            // ВидЛицензии            // 22. [21]

            // КоэффПересчетаДал      // 23. [22]

            //                               

            // Родитель.Наименование  // 24. [23]        

            // Родитель.Код           // 25. [24]        

            //

            НайденныйЭлемент = Справочники.Номенклатура.НайтиПоНаименованию(МассивКолонок[2],1);
            Если НайденныйЭлемент = Справочники.Номенклатура.ПустаяСсылка() Тогда
                ЭлементНоменклатуры              = Справочники.Номенклатура.СоздатьЭлемент();
                // Наименование            // 3.  [2]

                ЭлементНоменклатуры.Наименование = МассивКолонок[2];
                // Артикул                // 4.  [3]

                Если МассивКолонок[3] <> "" Тогда
                    ЭлементНоменклатуры.Артикул = МассивКолонок[3];
                КонецЕсли;
                // БазоваяЕдиница         // 5.  [4]

                Если МассивКолонок[4] <> "" Тогда
                    НайденнаяБазоваяЕдиницаИзмерения = Справочники.БазовыеЕдиницыИзмерения.НайтиПоНаименованию(МассивКолонок[4], 1); 
                    Если НайденнаяБазоваяЕдиницаИзмерения <> Справочники.БазовыеЕдиницыИзмерения.ПустаяСсылка() Тогда
                        ЭлементНоменклатуры.ЕдиницаИзмерения = НайденнаяБазоваяЕдиницаИзмерения;
                    КонецЕсли;
                КонецЕсли;
                // Весовой                // 6.  [5]

                Если МассивКолонок[5] <> "" Тогда
                    Если МассивКолонок[5] = "Истина" или МассивКолонок[5] = "1" Тогда
                        ЭлементНоменклатуры.Весовой = Истина;
                    Иначе
                        ЭлементНоменклатуры.Весовой = Ложь;
                    КонецЕсли;
                КонецЕсли;
                // ВидНоменклатуры        // 7.  [6]

                Если МассивКолонок[6] <> "" Тогда
                    НайденныйВидНоменклатуры = Справочники.ВидыНоменклатуры.НайтиПоНаименованию(МассивКолонок[6], 1); 
                    Если НайденныйВидНоменклатуры <> Справочники.ВидыНоменклатуры.ПустаяСсылка() Тогда
                        ЭлементНоменклатуры.ВидНоменклатуры = НайденныйВидНоменклатуры;
                    КонецЕсли;
                КонецЕсли;
                // Комментарий            // 8.  [7]

                //Если МассивКолонок[7] <> """""" и МассивКолонок[7] <> """0""" Тогда

                //    ЭлементНоменклатуры.Комментарий = МассивКолонок[7];

                //КонецЕсли;

                // МинОстаток             // 9.  [8]

                // НеВключатьВпрайс       // 10. [9]

                // НомерГТД               // 11. [10]

                
                // ОсновнаяЕдиница        // 12. [11]

                //Если МассивКолонок[11] <> """""" Тогда

                //    ЭлементНоменклатуры. = МассивКолонок[11];

                //КонецЕсли;

                // ОсновноеСвойство       // 13. [12]

                // ПолнНаименование       // 14. [13]

                Если МассивКолонок[13] <> "" Тогда
                    ЭлементНоменклатуры.НаименованиеПолное = МассивКолонок[13];
                КонецЕсли;
                // СтавкаНДС              // 15. [14]

                Если МассивКолонок[14] <> "" Тогда
                    Если МассивКолонок[14] = "Без НДС" Тогда
                        ЭлементНоменклатуры.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
                    ИначеЕсли МассивКолонок[14] = "НДС 18" Тогда
                        ЭлементНоменклатуры.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
                    ИначеЕсли МассивКолонок[14] = "НДС 20" Тогда
                        ЭлементНоменклатуры.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
                    КонецЕсли;
                КонецЕсли;
                // СтавкаНП               // 16. [15]

                // СтранаПроисхождения    // 17. [16]

                Если МассивКолонок[16] <> "" Тогда
                    НайденнаяСтранаПроисхождения = Справочники.СтраныМира.НайтиПоНаименованию(МассивКолонок[16], 1);
                    Если НайденнаяСтранаПроисхождения <> Справочники.СтраныМира.ПустаяСсылка() Тогда 
                        ЭлементНоменклатуры.СтранаПроисхождения = НайденнаяСтранаПроисхождения;
                    КонецЕсли;
                КонецЕсли;
                // Производитель          // 18. [17]

                Если МассивКолонок[17] <> "" Тогда
                    НайденныйПроизводитель = Справочники.Контрагенты.НайтиПоНаименованию(МассивКолонок[17], 1);
                    Если НайденныйПроизводитель <> Справочники.Контрагенты.ПустаяСсылка() Тогда
                        ЭлементНоменклатуры.Производитель = НайденныйПроизводитель;
                    КонецЕсли;
                КонецЕсли;
                // Импортер               // 19. [18]

                // АлкогольнаяПродукция   // 20. [19]

                Если МассивКолонок[19] <> "" Тогда
                    Если МассивКолонок[19] = "Истина" Тогда
                        ЭлементНоменклатуры.АлкогольнаяПродукция = Истина;
                    Иначе
                        ЭлементНоменклатуры.АлкогольнаяПродукция = Ложь;
                    КонецЕсли;
                КонецЕсли;
                // ВидПродукции           // 21. [20]

                Если МассивКолонок[20] <> "" Тогда
                    НайденныйВидАлкПродукции = Справочники.ВидыАлкогольнойПродукции.НайтиПоНаименованию(МассивКолонок[20], 1);
                    Если НайденныйВидАлкПродукции <> Справочники.ВидыАлкогольнойПродукции.ПустаяСсылка() Тогда 
                        ЭлементНоменклатуры.ВидАлкогольнойПродукцииЕГАИС = МассивКолонок[20];
                    КонецЕсли;
                КонецЕсли;
                // ВидЛицензии            // 22. [21]

                // КоэффПересчетаДал      // 23. [22]

                //                               

                // Родитель.Наименование  // 24. [23]        

                Если МассивКолонок[23] <> "" Тогда
                    ЭлементНоменклатуры.Родитель = Справочники.Номенклатура.НайтиПоНаименованию(МассивКолонок[23], 1);
                КонецЕсли;
                // Родитель.Код           // 25. [24]        

                //

                ЭлементНоменклатуры.Записать();                
                Сообщить("Создан элемент " + ЭлементНоменклатуры.Наименование);
            Иначе
                Сообщить("Пропущен элемент " + МассивКолонок[2]);
            КонецЕсли;
        КонецЕсли;
        СчЭл = СчЭл + 1;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    Сообщить("Загружено: " + СТРОКА(СчЭл) + " элементов.");
КонецПроцедуры
//
   mikecool
 
46 - 08.05.19 - 15:00
(44) не, надо сразув Кремль писать )
   falselight
 
47 - 08.05.19 - 15:02
Вот. Все работает. Но иногда идет эта ошибка и все, на таких же данны!

http://joxi.ru/Vm6GePvf4jOba2
   sqr4
 
48 - 08.05.19 - 15:04
отладка - останавливать по ошибке
   trad
 
49 - 08.05.19 - 15:04
вангую, есть попытка в функции РазложитьСтрокуВМассивПодстрок()
 
 Рекламное место пустует
   sqr4
 
50 - 08.05.19 - 15:04
Ты ведь это делал да
   lodger
 
51 - 08.05.19 - 15:04
Если МассивКолонок[4] <> "" Тогда
поменять на
Если ТипЗнч(МассивКолонок[4]) = Тип("Строка") И НЕ ПустаяСтрока(МассивКолонок[4]) Тогда
   kda26
 
52 - 08.05.19 - 15:05
(47)  Добавить в условие проверку на Неопределено
   falselight
 
53 - 08.05.19 - 15:11
(48) я так и останавливаюсь на строке 2000 с лишним

(51)(52) Да можно многого добавить, но я же смотрю в отладчике, в функцию передаются верные данные, а идет ошибка.

Добавлю конечно проверки.
   sqr4
 
54 - 08.05.19 - 15:12
а ну и тестирование исправление, кэш и прочая фигня
   falselight
 
55 - 08.05.19 - 15:13
(54) Даже для пустой базы? Я туда ни разу ещё не загрузил эти элементы номенклатуры.
   sqr4
 
56 - 08.05.19 - 15:15
(55) не знаю. у меня правило, если происходит неведомая херня, нужно сначала делать это, а потом только лезть за бубном
   falselight
 
57 - 08.05.19 - 15:16
(56) Обычно, сколько кэш не чистил не помогало (
   sqr4
 
58 - 08.05.19 - 15:18
(57) ну тогда вперед к админам за снастью если своей нет и вызывать помощника.
   Галахад
 
59 - 08.05.19 - 15:19
(47) Точно останова явно не на ошибке.
   sqr4
 
60 - 08.05.19 - 15:21
(59) кстати да
   falselight
 
61 - 08.05.19 - 15:21
Кэш почищу сейчас догрузится.
Стоит галка останавливаться по ошибке.
Ошибка видимо возникает при записи элемента.
Я смотрю что там в нем, вижу проблему в единицах измерения и родителе.
Но из за чего не пойму.
   sqr4
 
62 - 08.05.19 - 15:23
(61) чё мля
   sqr4
 
63 - 08.05.19 - 15:23
иди накуй...
   palsergeich
 
64 - 08.05.19 - 15:24
(61) платформенная проверка какая то.
Сделай обменДанными.загрузка = истина.
Потом глазами увидишь
   falselight
 
65 - 08.05.19 - 15:24
Стоит галка при отладке останавливаться по ошибке. Вот на ней и вылетает.
   falselight
 
66 - 08.05.19 - 15:24
(64) А это где сделать?
   palsergeich
 
67 - 08.05.19 - 15:25
Спр = создать элемент или ПолучитьОбъект
Спр.обменДанными.загрузка = истина
Спр.записать()
   palsergeich
 
68 - 08.05.19 - 15:26
Ход такой
   falselight
 
69 - 08.05.19 - 15:26
(67) А что именно это даст?
   palsergeich
 
70 - 08.05.19 - 15:26
(69) отключит платформенные проверки
   palsergeich
 
71 - 08.05.19 - 15:27
У тебя ошибка не в найти по наименованию, а некорректная обработка исключения ранее
   palsergeich
 
72 - 08.05.19 - 15:28
Или ошибка заполнения обязательных на уровне платформы полей: наименование, владелец (если справочник подчинённый) и тд
   falselight
 
73 - 08.05.19 - 15:28
(71) У меня же нет попытки исключения?
Да ранее я вижу что в родителе и единицах измерения.
Но туда идут нормальные данные. Буду разбираться.
Видимо энергия ушла.
   falselight
 
74 - 08.05.19 - 15:29
(72) Единицу измерения обязательно заполнять, выдавать ошибку стоит.
   palsergeich
 
75 - 08.05.19 - 15:29
(74) это не валило бы в исключение
   palsergeich
 
76 - 08.05.19 - 15:32
(74) технически это отказ=истина в процедуре ПроверкаЗаполнения, но не исключение
   trad
 
77 - 08.05.19 - 15:34
(73) см (49)
   falselight
 
78 - 08.05.19 - 15:38
(77)

Функция РазложитьСтрокуВМассивПодстрок(Знач Стр, Разделитель = ",")
    МассивСтрок = Новый Массив();
    Если Разделитель = " " Тогда
        Стр = СокрЛП(Стр);
        Пока Истина Цикл
            Поз = Найти(Стр,Разделитель);
            Если Поз=0 Тогда
                МассивСтрок.Добавить(Стр);
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр,Поз-1));
            Стр = СокрЛ(Сред(Стр,Поз));
        КонецЦикла;
    Иначе
        ДлинаРазделителя = СтрДлина(Разделитель);
        Пока Истина Цикл
            Поз = Найти(Стр,Разделитель);
            Если Поз=0 Тогда
                МассивСтрок.Добавить(Стр);
                Возврат МассивСтрок;
            КонецЕсли;
            МассивСтрок.Добавить(Лев(Стр,Поз-1));
            Стр = Сред(Стр,Поз+ДлинаРазделителя);
        КонецЦикла;
    КонецЕсли;
КонецФункции
   falselight
 
79 - 08.05.19 - 15:54
http://joxi.ru/Dr8De5vTozxO7r

http://joxi.ru/V2VWkZaidKp78A

сейчас вот с этим буду бороться что это пока не знаю
   palsergeich
 
80 - 08.05.19 - 15:55
Я ж говорю - платформенные проверки
   hhhh
 
81 - 08.05.19 - 16:01
(79) наверно в поле группа фигачишь элемент. Такое 1с не прощает.
   Галахад
 
82 - 08.05.19 - 16:19
Это какая-то Санта-Барбара...
   falselight
 
83 - 08.05.19 - 16:33
(81) В родителя всмысле??????
   hhhh
 
84 - 08.05.19 - 16:39
(83) в общем пройдись по справочнику номенклатуры где-то есть одинаковое наименование у элемента и группы. Или если самому лень, посади за проверку девочку-восьмиклассницу, пусть проштудирует справочник от и до.
   falselight
 
85 - 08.05.19 - 16:41
(81) Не должно такого быть.

(84) Гружу структуру из другой базы. Я пока не могу записать ни одного элемента. Так как грузится в транзакции.

Мне не лень. Я пытаюсь разобраться. Но такого не могло в принципе быть. Надеюсь докапаться до проблемы.
   falselight
 
86 - 08.05.19 - 16:43
(84) смотрю в файле не нахожу.
Поставил останавливаться по ошибке.
Остановка же будет на проблемном элементе?
Ну вот, пока я в отладчеке не увидел там проблемы.
   mikecool
 
87 - 08.05.19 - 16:44
(82) +100500 серия )
   falselight
 
88 - 08.05.19 - 16:46
(87) Хорошо, у вас в 1с все всегда хорошо работает!
   mikecool
 
89 - 08.05.19 - 16:48
(88) да,  как то загрузки из текстовых файлов с одного прохода отладки работают
   hhhh
 
90 - 08.05.19 - 16:49
(85) ну, грузи без транзакции, ну ты чудик.
   mikecool
 
91 - 08.05.19 - 16:49
а ветка больше на бложек похожа
   falselight
 
92 - 08.05.19 - 16:50
(90) Ошибку нужно отловить. Мне нужно что бы все хорошо грузилось. Пока первичные данные.
Потом остальное ещё цеплять.
И так долго грузится. Без транзакции ещё дольше будет.
Я же отлаживаю.
   mikecool
 
93 - 08.05.19 - 16:51
"И так долго грузится." - сделай примеры покороче, делов то
   Масянька
 
94 - 08.05.19 - 16:53
Лучше день потерять - зато потом за пять минут долететь (С)
   sqr4
 
95 - 08.05.19 - 16:54
(92) без запросов в цикле еще быстрее
   Rovan
 
96 - 08.05.19 - 16:54
(9) привычка писать 1 вместо "истина" выдает "клюшечника" со стажем
   falselight
 
97 - 08.05.19 - 16:55
вот не находится группа сыр и идет ошибка
ошибка из за ошибки что выдает функция, а она должна либо находить элемент или возвращать пустую ссылку

http://joxi.ru/gmvaZ43tqv5b5r
   falselight
 
98 - 08.05.19 - 16:55
(96) Это никакого значения не имеет.
   falselight
 
99 - 08.05.19 - 16:56
Что с этим (97) делать. Реально не вижу в чем проблема?!!!
   Rovan
 
100 - 08.05.19 - 16:59
(97) а полностью ошибка вероятно звучит так

Ошибка при вызове метода контекста (НайтиПоНаименованию): В данной транзакции уже происходили ошибки!

https://downloads.v8.1c.ru/content/Conversion/ErrConversion_2_0_24_1.htm
  1  2   

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует