Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Значение поля не соответствует установленному отбору при изменении запись регистра с.

Значение поля не соответствует установленному отбору при изменении запись регистра с.
Я
   Эльчин
 
08.05.19 - 12:29
здравствуйте. нужно найти запись регистра сведений и изменить поле "Звонил". Делаю так:

&НаСервере
Процедура ОбновитьЗаписРегистра(Знач ТекущиеДанные)
    
    НаборЗаписей = РегистрыСведений.ЗвонкиКонтрагентам.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Контрагент.Установить(ТекущиеДанные.Контрагент);
    НаборЗаписей.Отбор.Звонил.Установить(Ложь);
    НаборЗаписей.Отбор.Период.Установить(ТекущиеДанные.Период);
    НаборЗаписей.Отбор.Комментарий.Установить(ТекущиеДанные.Комментарий);
    НаборЗаписей.Прочитать();
    Если НаборЗаписей.Количество() = 0 Тогда
        Сообщить("0");
    ИначеЕсли НаборЗаписей.Количество() = 1 Тогда
        Для Каждого Запись Из НаборЗаписей Цикл
            Запись.Звонил = Истина
        КонецЦикла;
        НаборЗаписей.Записать(Истина);
    КонецЕсли;        
        
КонецПроцедуры

выводит такую ошибку:

Запись не верна! Значение поля не соответствует установленному отбору: ЗвонкиКонтрагентам: 07.05.2019, Nizami Ofis, 08.05.2019 0:00:00, йййййй, Да (Регистр сведений: Müştərilərə zənglər; Номер строки: 1; Поле: Звонил)

будто ругается что нет запись с значением Да в поле Звонил. я же отбор сделал как Нет для Звонил. а потом его изменяю на Да. а он так ругается. как решать?
 
 
   hhhh
 
1 - 08.05.19 - 12:36
(0) ну вы же уже решили неделю назад. Провал в памяти что ли?
   hhhh
 
2 - 08.05.19 - 12:36
   sqr4
 
3 - 08.05.19 - 12:37
(1) все новое хорошо забытое старое
   Cyberhawk
 
4 - 08.05.19 - 12:52
Ну так отбор-то набора надо тоже поменять перед изменением значения измерения
   Эльчин
 
5 - 08.05.19 - 12:55
(1) (3) эта другая ошибка. не много все запутал. но там я решил некоторые вопросы. сейчас такая проблема. она не решена.
для решение этой проблемы там посоветовали удалить запись и снова добавить. но потом я посмотрел в гугле примеры. все так делают. не удаляя запись. почему у меня так не получается, мне это интересно))
   Эльчин
 
6 - 08.05.19 - 12:57
(4) у всех примерах в гугле снова отбор никто не делают. есть .но редкие. все так делают. почему я должен не делать так))?
   Cyberhawk
 
7 - 08.05.19 - 13:14
(6) Приди к Нуралиеву и спроси его это
   hhhh
 
8 - 08.05.19 - 13:19
(6) Потому что "Звонил" - это измерение регистра. Все делают в гугле - у них не измерение регистра. Вам всё разжевали прошлый раз, а вы опять решили той же хренью заниматься.
   catena
 
9 - 08.05.19 - 13:24
(6)Потому что ты меняешь значение измерения, не?
   hhhh
 
10 - 08.05.19 - 13:28
(6) вот эту строчку убери
  НаборЗаписей.Отбор.Звонил.Установить(Ложь);
   Эльчин
 
11 - 08.05.19 - 16:03
(8) вот сейчас понятно)). большое спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.