Вход | Регистрация
 

1с вылетает при изменение видимости элементы формы

1с вылетает при изменение видимости элементы формы
Я
   alekosansey
 
08.05.19 - 08:44
Добрый день подскажите пожалуйста у меня стоит платформа 8.3.14.1694 вылетает при изменение программно видимости элемента формы. Пишет windows осуществляет поиск способа устранения этой ошибки. Подскажите кто-нибудь сталкивался с данной ошибкой? Заранее спасибо за ответ
 
 
   Ёпрст
 
1 - 08.05.19 - 08:53
(0) ошибка в 1434 строке
   Ray Zexter
 
2 - 08.05.19 - 08:54
8.3.14 иногда на ровном месте вылетает, так что ничего удивительного...
   butterbean
 
3 - 08.05.19 - 08:55
8-ка еще сырая
   alekosansey
 
4 - 08.05.19 - 08:55
а какая стабильная версия из 8,3
   Serg_1960
 
5 - 08.05.19 - 09:01
(0) Ну что я могу сказать по этому поводу... не изменяй видимость программно :)
Уменьши ширину до минимума и задвинь максимально в право.

PS: а лучше разберись почему в конфигурации нельзя изменять видимость этого элемента формы (например, его значение возможно используется в формировании внешнего вида формы)
   butterbean
 
6 - 08.05.19 - 09:04
(0) при вызове серверных методов там где не надо иногда такое бывает
   ildary
 
7 - 08.05.19 - 09:10
(4) самая стабильная - это минимальная версия 1С, которая требуется конфигурацией (и его БСП), на сегодня это 8.3.12.
   Web00001
 
8 - 08.05.19 - 09:12
(4)Самая стабильная из ветки 8.3 это конечно же 7.7
   stix2010
 
9 - 08.05.19 - 09:27
(8)  не, в 8 стабильны 8.0, 8.1 и 8.2
   oslokot
 
10 - 08.05.19 - 09:29
(0) начать нужно с чистки кеша
 
 Рекламное место пустует
   Cyberhawk
 
11 - 08.05.19 - 09:29
Это из-за кряков. Свежие релизы, в т.ч. 8.3.14 к ним более чувствительно относятся
   alekosansey
 
12 - 08.05.19 - 09:35
(11) Кряков нет. Стоит рыбка ключ. Поставил 12 версию такая же фигня
   alekosansey
 
13 - 08.05.19 - 09:35
up
   stix2010
 
14 - 08.05.19 - 09:56
попробуй под другим пользователем
   KILL_OFF_COBECTb
 
15 - 08.05.19 - 10:05
(13) чем не подходит вариант из (5) ?
   butterbean
 
16 - 08.05.19 - 10:07
(13) проверь свой код, в обработках некоторых событий нельзя вызывать серверные методы
   lodger
 
17 - 08.05.19 - 10:07
А я тоже сталкивался с такой проблемой.
Никак это не лечится, наставления 1с надо соблюдать, т.е. не менять форму пока она живёт. Менять можно только при создании на сервере. То что не заблокировали изменения это такой же багофич, как и сохранение ком-объектов в хранилище.
   stix2010
 
18 - 08.05.19 - 10:15
(17) при чем тут изменение видимости элементов на форме?
   stix2010
 
19 - 08.05.19 - 10:18
никто кода не видел, на чем конкретно падает неизвестно. Пусть сам думает, что он накодил.
   Cyberhawk
 
20 - 08.05.19 - 10:27
(12) "Стоит рыбка ключ" // Что за рыбка? ))
   1Сергей
 
21 - 08.05.19 - 10:31
   Cyberhawk
 
22 - 08.05.19 - 10:46
(21) А, из-за формы, ясно, спс, давно вживую видел)
   alekosansey
 
23 - 08.05.19 - 11:06
&НаКлиенте  
Процедура ПереключательПриИзменении(Элемент)
    СтруктураЗаголовков = ПолучитьЗаголовкиФормы();
    Если Переключатель =0 Тогда
        //ОчиститьДанныеКлиента();

        //КлиентСтруктура =Неопределено;

        Элементы.Шаг12.Видимость = Ложь;
        Заголовок = СтруктураЗаголовков.Заголовок11;
        Элементы.Шаг11.Видимость = Истина;
    Иначеесли Переключатель =1 Тогда
        //Клиент = "";

        //Клиент = Неопределено;

        Элементы.Шаг11.Видимость = Ложь;
        Заголовок = СтруктураЗаголовков.Заголовок12;
        Если Элементы.КлиентУДЛОрганВыдачиДокумента.СписокВыбора.Количество()=0 Тогда
            Список = ПолучитьСписокОргановВыдачиДокументовНаСервере();
            Для каждого ОрганВыдачиДокумента Из Список Цикл
                Элементы.КлиентУДЛОрганВыдачиДокумента.СписокВыбора.Добавить(ОрганВыдачиДокумента);
            КонецЦикла;
            Элементы.КлиентУДЛОрганВыдачиДокумента.СписокВыбора.Добавить("Другое...");
        КонецЕсли;
        Элементы.Шаг12.Видимость = Истина;
        Если Не ЗначениеЗаполнено(КлиентЯзык)Или Не ЗначениеЗаполнено(КлиентУДЛВидДокумента) Или Не ЗначениеЗаполнено(КлиентУДЛОрганВыдачиДокумента) Тогда
            СтруктураСтандартныхДанныхНовыйКлиент = ЗаполнитьКлиентСтандартнымиДанными();
            Если СтруктураСтандартныхДанныхНовыйКлиент.Количество()>0 Тогда
                КлиентЯзык = СтруктураСтандартныхДанныхНовыйКлиент.КлиентЯзык;
                КлиентУДЛВидДокумента =  СтруктураСтандартныхДанныхНовыйКлиент.КлиентУДЛВидДокумента;
                КлиентУДЛОрганВыдачиДокумента = СтруктураСтандартныхДанныхНовыйКлиент.КлиентУДЛОрганВыдачиДокумента;
            КонецЕсли; 
        КонецЕсли;
        ЗаполнитьМаскуНомераДокументаИНадписьМаски();
        КлиентУДЛВидДокументаПриИзменении(Неопределено);
    КонецЕсли;
КонецПроцедуры
   alekosansey
 
24 - 08.05.19 - 11:09
&НаКлиенте
 Процедура КлиентОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
     Если Клиент.Пустая() Тогда
         Ответ = Вопрос("Данного клиента нет в базе. Создать нового?",РежимДиалогаВопрос.ДаНет);
         Если Ответ = КодВозвратаДиалога.Да Тогда
 
             КлиентФИО = Текст;
             Переключатель = 1;
             ПереключательПриИзменении(Неопределено);

         КонецЕсли; 
     КонецЕсли; 
 КонецПроцедуры

Это код который вызывает это событие
   Cyberhawk
 
25 - 08.05.19 - 11:11
Так ты пади сервер дергаешь
   Cyberhawk
 
26 - 08.05.19 - 11:12
А контекстно это делать нельзя в "ОкончаниеВводаТекста"
   palsergeich
 
27 - 08.05.19 - 11:15
(24) Там же в СП написано что есть запрет на серверные кнтекстные вызовы
Примечание:

В обработчике данного события нельзя использовать серверные методы формы с директивой компиляции &НаСервере.
   alekosansey
 
28 - 08.05.19 - 11:18
я уже пробовал даже если я просто оставлю   Элементы.Шаг11.Видимость = Ложь; Он все равно выдаст ошибку
   alekosansey
 
29 - 08.05.19 - 11:18
Без вызовов сервера
   Cyberhawk
 
30 - 08.05.19 - 11:20
Режим совместимости какой?
   Cyberhawk
 
31 - 08.05.19 - 11:20
До где-то 8.3.6 или 8.3.8 изменение видимости влекло к вызову сервера
   alekosansey
 
32 - 08.05.19 - 11:21
(30) 8,3,11
   zak555
 
33 - 08.05.19 - 11:21
 
 
   alekosansey
 
34 - 10.05.19 - 08:01
up
   alekosansey
 
35 - 10.05.19 - 08:03
Понял что это происходит с определенным реквизитом у которого тип справочникссылка и изменяется его видимость во время события окончания ввода этого элемента
   Василий Алибабаевич
 
36 - 10.05.19 - 08:38
(34) Чего "up"? Сколько уже раз писано, прожевано и выплюнуто : не нужно дергать видимость элементов на форме после того как она открыта. Рулите доступностью.
   H A D G E H O G s
 
37 - 10.05.19 - 10:06
Используйте
ПодключитьОбработчикОжидания

Разово, через 0.1секунду.
   hhhh
 
38 - 10.05.19 - 11:37
(35) изменение видимости это и есть обращение к серверу, поэтому читай (27)  В обработчике данного события нельзя использовать серверные методы формы
   Cyberhawk
 
39 - 13.05.19 - 11:00
(38) После (31) сервер уже не дергается
   Franchiser
 
40 - 13.05.19 - 11:33
(37)+
   palsergeich
 
41 - 13.05.19 - 11:45
(39) Не совсем.
Заголовки, табличные части, по порежнему дергают сервер.
   Cyberhawk
 
42 - 13.05.19 - 12:19
(41) Мы вроде про видимость толкуем
   Cyberhawk
 
43 - 13.05.19 - 12:20
про изменение видимости


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует