Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Автоматическое сохранение значения программно созданного реквизита в настройках формы

Автоматическое сохранение значения программно созданного реквизита в настройках формы
Я
   FiftyStars
 
07.05.19 - 10:12
Здравствуйте. Собственно вопрос как установить флаг "Сохранение" для программно созданных реквизитов?
Что то нигде найти не могу и что то даже не представляю в контексте чего именно искать это в СП.
p.s. Прошу не путать с флагом "Сохраняемые данные" =) нужный флаг появляется напротив реквизитов формы при включении АвтоматическоеСохранениеДанныхВНастройках в параметрах формы
На ИС поднимал тему, но уверенного ответа "да" или "нет" не последовало, хотя мне кажется что как то это можно установить, потому что это самое АвтоматическоеСохранениеДанныхВНастройках доступно для записи программно.
 
 
   hhhh
 
1 - 07.05.19 - 10:17
(0) ну если программно всё равно, то программно и вставляйте свой реквизит в события на форме Перед сохранением и перед восстановлением
   Cyberhawk
 
2 - 07.05.19 - 10:21
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    СохраняемыеВНастройкахДанныеМодифицированы = Истина;// чтобы при закрытии вызвался обработчик ПриСохраненииДанныхВНастройкахНаСервере

    
КонецПроцедуры
   Cyberhawk
 
3 - 07.05.19 - 10:21
&НаСервере
Процедура ПриСохраненииДанныхВНастройкахНаСервере(Настройки)
    
    #Если _ Тогда

        Настройки = Новый Соответствие;
    #КонецЕсли 

    РезультирующиеНастройки = КомпоновщикНастроек.ПолучитьНастройки();
    Настройки.Вставить("СохраненныеРезультирующиеНастройки", РезультирующиеНастройки);

КонецПроцедуры

&НаСервере
Процедура ПриЗагрузкеДанныхИзНастроекНаСервере(Настройки)
    
    #Если _ Тогда

        Настройки = Новый Соответствие;
    #КонецЕсли 


    СохраненныеРезультирующиеНастройки = Настройки.Получить("СохраненныеРезультирующиеНастройки");
    #Если _ Тогда

        СохраненныеРезультирующиеНастройки = Новый НастройкиКомпоновкиДанных;
    #КонецЕсли 

    Если СохраненныеРезультирующиеНастройки <> Неопределено Тогда
        АСУ_ОктанКлиентСервер.СкопироватьОтборКомпоновки(СохраненныеРезультирующиеНастройки.Отбор, КомпоновщикНастроек.Настройки.Отбор);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    СохраняемыеВНастройкахДанныеМодифицированы = Истина;// чтобы при закрытии вызвался обработчик ПриСохраненииДанныхВНастройкахНаСервере

    
КонецПроцедуры
   Cyberhawk
 
4 - 07.05.19 - 10:23
Просто так взять и установить этот флаг у программно создаваемого реквизита формы нельзя.
В твоих силах только самостоятельно организовать сохранение и восстановление его значений.
   FiftyStars
 
5 - 07.05.19 - 10:25
(1) (4) спасибо
ну это 100% или нет?))
Просто меня сбивает с толку возможность программного включения автоматического сохранения
   Cyberhawk
 
6 - 07.05.19 - 10:25
100%
   FiftyStars
 
7 - 07.05.19 - 10:25
(5) я до сих пор не совсем понимаю как здесь форматируются сообщения О_О =((
   FiftyStars
 
8 - 07.05.19 - 10:28
(6) Тогда еще раз спасибо за уверенный однозначный ответ =)
   FiftyStars
 
9 - 07.05.19 - 10:41
(3) кстати возник вопрос, "#Если _ Тогда" это что?О_О Впервые вижу =D

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.