Вход | Регистрация
 

Перенос значения одного реквизита при изменении другого реквизита

Перенос значения одного реквизита при изменении  другого реквизита
Я
   Теоtre
 
06.05.19 - 12:15
Есть справочник запчасти(Наименование, обозначение, необходимость)
нужно при заполнении цен запчастей что бы при выборе запчасти автоматически заполнялось обозначение

&НаКлиенте
Процедура ЗапчастьПриИзменении(Элемент)
Зч=Элементы.Запчасть.ТекущиеДанные;
Обознач=ПодставитьОбозначение(Элементы.Запчасть);
Элементы.Обозначение=Обознач;
    
КонецПроцедуры



&НаСервере
Функция ПодставитьОбозначение(Наименование)
            Спр = Справочники.Авиотехника.НайтиПоНаименованию(Наименование);
            Возврат Спр.Обозначение;    
КонецФункции
 
 
   catena
 
1 - 06.05.19 - 12:26
"Зч="
Зачем присваивать переменной и потом ее не использовать?

"Элементы.Запчасть"
Произвольное значение из любой строки?
"НайтиПоНаименованию(Наименование)"

А будет передано наименование или все-таки ссылка?
   Теоtre
 
2 - 13.05.19 - 05:52
Ну оно текущее же значение берет
и должно передать наименование
   catena
 
3 - 13.05.19 - 06:27
(2)Семерочник, чтоли?
Зч=Элементы.Запчасть.ТекущиеДанные;    <--------------Положил в переменную текущие данные
Обознач=ПодставитьОбозначение(Элементы.Запчасть); <------------передал в функцию что-то, совсем не связанное с переменной
Спр = Справочники.Авиотехника.НайтиПоНаименованию(Наименование); <---------запчасть что, строка или ссылка?
   RomaH
 
4 - 13.05.19 - 07:06
(3) - это все фигня - вот то, что идет контекстный вызов сервера там где он не нужен и "Знач" забыл - вот это фиаско
   RomaH
 
5 - 13.05.19 - 07:13
Элементы.Обозначение=Обознач
... извиняюсь спросить - а это как понимать?
Элементы.Обозначение - это все-таки либо поле, либо команда, либо декорация ... ну не группа же
и что ему присваивается?

(0) это что вообще за задача? если реальная - подложишь большую свинью
если тестовая - то концепция не верна
Спр = Справочники.Авиотехника.НайтиПоНаименованию(Наименование); использовать нельзя в этом случае - если справочники разные - то где гарантия что наименования совпадают?
если один и тот же справочник - то вообще дурное решение
и у НайтиПоНаименованию есть параметры - очень удивишься
   breezee
 
6 - 13.05.19 - 07:16
(0) Идите учиться
   RomaH
 
7 - 13.05.19 - 07:28
(6) ну так он и учится - что же теперь, пока учишься и вопросов задавать нельзя на мисте?
   RomaH
 
8 - 13.05.19 - 07:29
&НаКлиенте
Процедура ЗапчастьПриИзменении(Элемент)
КонецПроцедуры
Функция ПодставитьОбозначение(Наименование)
КонецФункции

(0) - вот коды который у тебя написан правильно
все остальные буквы - неверные
   RomaH
 
9 - 13.05.19 - 07:29
а нет
Функция ПодставитьОбозначение(Наименование)
тоже неверно

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.