Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подскажет кто из-за чего ошибка, запрос к критерий отбора (связанные документы)

Подскажет кто из-за чего ошибка, запрос к критерий отбора (связанные документы)
Я
   SkillUp
 
04.05.19 - 05:45
ОШИБКА:
{Документ.ЗаказПокупателя.Форма.ФормаСпискаУФ.Форма(55)}: Ошибка при вызове метода контекста (Выполнить)
        РезультатЗапроса = Запрос.Выполнить();
по причине:
{(4, 2)}: Ошибка обработки представления "КритерийОтбора.СвязанныеДокументы:Несоответствие типов (Параметр номер ""1"")"
<<?>>КритерийОтбора.СвязанныеДокументы(&Док) КАК СвязанныеДокументы

Мой код:
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ДокументЗаказПокупателя.Ссылка
        |ИЗ
        |    Документ.ЗаказПокупателя КАК ДокументЗаказПокупателя
        |ГДЕ
        |    ДокументЗаказПокупателя.Организация = &Организация
        |    И ДокументЗаказПокупателя.Дата МЕЖДУ &ДатаНач И &ДатаКон";
    
    Запрос.УстановитьПараметр("Организация",Организация);
    Запрос.УстановитьПараметр("ДатаНач", ДатаНач);
    Запрос.УстановитьПараметр("ДатаКон", ДатаКон);

    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    СписокЗаявок = Новый СписокЗначений;    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        СписокЗаявок.Добавить(ВыборкаДетальныеЗаписи.ссылка);
    КонецЦикла;
      
    Для Каждого Заявка из СписокЗаявок Цикл
        
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    СвязанныеДокументы.Ссылка.Ссылка
        |ИЗ
        |    КритерийОтбора.СвязанныеДокументы(&Док) КАК СвязанныеДокументы";
        
        Запрос.УстановитьПараметр("Док", Заявка);
        
        РезультатЗапроса = Запрос.Выполнить();
            ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
            Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
                //обработка полученных данных
            КонецЦикла;
    КонецЦикла;
 
 
   catena
 
1 - 04.05.19 - 06:07
(0)За 10 мес скилл уже должен быть достаточно ап, чтобы не писать Ссылка.Ссылка и уметь отладчиком посмотреть тип значения.

Запрос.УстановитьПараметр("Док", Заявка.Значение);
   SkillUp
 
2 - 04.05.19 - 06:08
(1) СПАСИБО!
   SkillUp
 
3 - 04.05.19 - 06:12
(1) Кать, просто из-за круглосуточной работы, иногда допускаю простые ошибки...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.